summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-01-24 10:19:56 -0600
committerBen Kohler <bkohler@gentoo.org>2019-01-24 10:21:57 -0600
commit65cb52fd84032b419f5f971c3c1548c681acba08 (patch)
tree1f890fd77432dda9f85e554b023da3a5dfe91c26
parentapp-backup/dar: Removed old. (diff)
downloadgentoo-65cb52fd84032b419f5f971c3c1548c681acba08.tar.gz
gentoo-65cb52fd84032b419f5f971c3c1548c681acba08.tar.bz2
gentoo-65cb52fd84032b419f5f971c3c1548c681acba08.zip
net-wireless/iwd: new kernel option & module required
Check for new PKCS8_PRIVATE_KEY_PARSER option, and also install the new modules-load.d file for it in case it's modular Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--net-wireless/iwd/iwd-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-wireless/iwd/iwd-9999.ebuild b/net-wireless/iwd/iwd-9999.ebuild
index 59cf2d5b03ad..542d347128bc 100644
--- a/net-wireless/iwd/iwd-9999.ebuild
+++ b/net-wireless/iwd/iwd-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -66,6 +66,10 @@ pkg_pretend() {
WARNING_CRYPTO_SHA512_SSSE3="CRYPTO_SHA512_SSSE3: enable for increased performance"
fi
+ if use kernel_linux && kernel_is -ge 4 20; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~PKCS8_PRIVATE_KEY_PARSER"
+ fi
+
check_extra_config
}
@@ -90,7 +94,8 @@ src_configure() {
$(use_enable ofono) \
$(use_enable wired) \
--enable-systemd-service \
- --with-systemd-unitdir="$(systemd_get_systemunitdir)"
+ --with-systemd-unitdir="$(systemd_get_systemunitdir)" \
+ --with-systemd-modloaddir=$(_systemd_get_dir modulesloaddir /usr/lib/modules-load.d)
}
src_install() {