summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2016-11-10 01:06:59 +0100
committerSebastian Pipping <sping@gentoo.org>2016-11-10 01:12:30 +0100
commit6605981fd584736b1caefe412d6f88e7c4763801 (patch)
tree7e55dcdf56c90ab6092009df314e92772c28b070
parentwww-servers/gunicorn: 19.6.0 (diff)
downloadgentoo-6605981fd584736b1caefe412d6f88e7c4763801.tar.gz
gentoo-6605981fd584736b1caefe412d6f88e7c4763801.tar.bz2
gentoo-6605981fd584736b1caefe412d6f88e7c4763801.zip
dev-python/setproctitle: 1.1.10 (bug #588186)
Package-Manager: portage-2.3.2
-rw-r--r--dev-python/setproctitle/Manifest1
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.10.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/setproctitle/Manifest b/dev-python/setproctitle/Manifest
index 0312da74c848..8bb5655ebe53 100644
--- a/dev-python/setproctitle/Manifest
+++ b/dev-python/setproctitle/Manifest
@@ -1,2 +1,3 @@
+DIST setproctitle-1.1.10.tar.gz 24042 SHA256 6283b7a58477dd8478fbb9e76defb37968ee4ba47b05ec1c053cb39638bd7398 SHA512 c976c5b86f59bc6d0f840f495b8256813169d3d7b9edae70207a24d62e1240bfec954fdc4f67b429ae124e3dc74efd7193404785643a52b2d57b55028bb3c533 WHIRLPOOL 5f0f4d890fb0ea1031d3a46aa8e3d572de0ba27bedd4327138afc379f2f36a4a51517a85627663dfab26b223757ec929c5140f0208f941f3e665e00195bc805c
DIST setproctitle-1.1.8.tar.gz 23208 SHA256 b564cf6488217c7a4632a9fe646fc3a3bea2f9712b4e667e9632b870d1a58211 SHA512 9d0ab8e65afd7e1ac019ea47995498dae1f82d8aebb333dfc4c953e745441cb9a8db942ad8417522d1f9a805bc50ad680f3a37cb4cbbd4214d261d4fed600b20 WHIRLPOOL 4014739eab6ba3d91a15e2c11d9e91ee6a0254a23be1c2f8a7963bc327559a5a7c6197398d6053743a9479562e76873fe47f11a6c810f2c21d3e462440183166
DIST setproctitle-1.1.9.tar.gz 23576 SHA256 1c3414d18f9cacdab78b0ffd8e886d56ad45f22e55001a72aaa0b2aeb56a0ad7 SHA512 f5640543105dd039192378983b098e0eca643b5eee314a18886aef0d13674e1ea74f753bfb33582f51a6fb34f9c3d0831764bc099dec9b9e14fe12e7446d30f1 WHIRLPOOL d063a443c42eaf9acf02e0e953b0b8ce080418978236700de1a23d7f234f562ae36ec3d8a965e4fd184f1d03491cc7ca159bbdf12886b7cd3e45e3f98d8db486
diff --git a/dev-python/setproctitle/setproctitle-1.1.10.ebuild b/dev-python/setproctitle/setproctitle-1.1.10.ebuild
new file mode 100644
index 000000000000..d1dc91ba2ef3
--- /dev/null
+++ b/dev-python/setproctitle/setproctitle-1.1.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# pypy doesn't get started in test run. Still required by www-servers/gunicorn
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Allow customization of the process title"
+HOMEPAGE="https://github.com/dvarrazzo/py-setproctitle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# Required for re-write of test suite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ # Make a nice html file
+ rst2html.py README.rst > README.html
+ # The README.rst will be duplicated in src_install
+ rm README.rst || die
+}
+
+python_test() {
+ # The suite via the Makefile appears to not cater to pypy
+ [[ ${EPYTHON} =~ pypy ]] && return
+
+ # prepare embedded executable
+ emake \
+ CC="$(tc-getCC)" \
+ PYINC="$(python_get_CFLAGS)" \
+ PYLIB="$(python_get_LIBS)" \
+ check
+}