summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-09-25 01:06:03 +0200
committerMichael Palimaka <kensington@gentoo.org>2016-09-26 03:44:40 +1000
commit6643fcde974dbbba16ee34ebaaeff64b24e8b7eb (patch)
tree819d4fc9e9563e15a5a54565b7e441d99b868315
parentsci-libs/blas-reference: fix eselect blas alternative, bug #595102 (diff)
downloadgentoo-6643fcde974dbbba16ee34ebaaeff64b24e8b7eb.tar.gz
gentoo-6643fcde974dbbba16ee34ebaaeff64b24e8b7eb.tar.bz2
gentoo-6643fcde974dbbba16ee34ebaaeff64b24e8b7eb.zip
app-office/calligra-l10n: Add CALLIGRA_FEATURES, EAPI 6
This enables e.g. krita to block calligra-l10n[calligra_features_krita] for avoiding file collisions. Mostly copied from existing *-l10n ebuilds. Gentoo-bug: 594772 Package-Manager: portage-2.3.0
-rw-r--r--app-office/calligra-l10n/calligra-l10n-2.9.11-r1.ebuild107
1 files changed, 107 insertions, 0 deletions
diff --git a/app-office/calligra-l10n/calligra-l10n-2.9.11-r1.ebuild b/app-office/calligra-l10n/calligra-l10n-2.9.11-r1.ebuild
new file mode 100644
index 000000000000..5a17708843b0
--- /dev/null
+++ b/app-office/calligra-l10n/calligra-l10n-2.9.11-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde4-base
+
+DESCRIPTION="Calligra localization package"
+HOMEPAGE="https://www.kde.org/"
+LICENSE="GPL-2"
+SLOT="4"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc"
+
+DEPEND="sys-devel/gettext"
+RDEPEND="!app-office/koffice-l10n"
+
+CAL_FTS="braindump flow karbon kexi krita plan sheets stage words"
+for cal_ft in ${CAL_FTS}; do
+ IUSE+=" calligra_features_${cal_ft}"
+done
+unset cal_ft
+
+MY_LANGS="bs ca ca@valencia cs da de el en_GB es et fi fr gl hu it ja kk nb nl
+pl pt pt_BR ru sk sv tr uk zh_CN zh_TW"
+
+case ${PV} in
+ 2.[456789].[789]?)
+ # beta or rc releases
+ URI_BASE="mirror://kde/unstable/${PN/-l10n/}-${PV}/${PN}" ;;
+ 2.[456789].?|2.[456789].??)
+ # stable releases
+ URI_BASE="mirror://kde/stable/${PN/-l10n/}-${PV}/${PN}" ;;
+ *)
+ SRC_URI="" ;;
+esac
+
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} l10n_${MY_LANG/[@_]/-}"
+ SRC_URI="${SRC_URI} l10n_${MY_LANG/[@_]/-}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.xz )"
+done
+unset MY_LANG
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ if [[ -z ${A} ]]; then
+ elog
+ elog "None of the requested L10N are supported by ${P}."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS//[@_]/-}"
+ elog
+ fi
+}
+
+src_unpack() {
+ [[ -n ${A} ]] && unpack ${A}
+}
+
+src_prepare() {
+ cat <<-EOF > CMakeLists.txt || die
+project(${PN})
+$(printf "add_subdirectory( %s )\n" \
+ `find . -mindepth 1 -maxdepth 1 -type d | sed -e "s:^\./::"`)
+EOF
+
+ local cal_ft
+ for cal_ft in ${CAL_FTS}; do
+ if ! use calligra_features_${cal_ft} ; then
+ if ls -U ./*/messages/calligra/${cal_ft}*po > /dev/null 2>&1; then
+ rm ./*/messages/calligra/${cal_ft}*po || \
+ die "Failed to remove ${cal_ft} messages"
+ fi
+ if ls -U ./*/docs/calligra/${cal_ft} > /dev/null 2>&1; then
+ sed -e "\:add_subdirectory(\s*${cal_ft}\s*): s:^:#:" \
+ -i ./*/docs/calligra/CMakeLists.txt || \
+ die "Failed to comment out ${cal_ft} docs"
+ fi
+ fi
+ done
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DATA=ON
+ -DBUILD_DOC=$(usex doc)
+ -DBUILD_MESSAGES=ON
+ )
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_test() { :; }
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}