summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-01-03 23:33:02 +1300
committerKent Fredric <kentnl@gentoo.org>2018-01-03 23:56:38 +1300
commit664d273e8bae3743eed1755d3ac450f29cb0f363 (patch)
tree1833443deb276e10c2d3ea836705e6921ad74b1c
parentdev-perl/RedisDB: Bump to version 2.540.0 (diff)
downloadgentoo-664d273e8bae3743eed1755d3ac450f29cb0f363.tar.gz
gentoo-664d273e8bae3743eed1755d3ac450f29cb0f363.tar.bz2
gentoo-664d273e8bae3743eed1755d3ac450f29cb0f363.zip
dev-perl/Regexp-Common-net-CIDR: Bump to version 0.30.0
- EAPI6 - Enable ( and provide ) tests - Patchify 5.26 fix Upstream: - Switch to Artistic + GPL2 License - Regen Module::Install code Package-Manager: Portage-2.3.18, Repoman-2.3.6
-rw-r--r--dev-perl/Regexp-Common-net-CIDR/Manifest1
-rw-r--r--dev-perl/Regexp-Common-net-CIDR/Regexp-Common-net-CIDR-0.30.0.ebuild27
-rw-r--r--dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-basic-tests.patch43
-rw-r--r--dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-no-dot-inc.patch23
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-perl/Regexp-Common-net-CIDR/Manifest b/dev-perl/Regexp-Common-net-CIDR/Manifest
index 8f524fc9f85f..8c5c3a19207f 100644
--- a/dev-perl/Regexp-Common-net-CIDR/Manifest
+++ b/dev-perl/Regexp-Common-net-CIDR/Manifest
@@ -1 +1,2 @@
DIST Regexp-Common-net-CIDR-0.02.tar.gz 17235 BLAKE2B 312561408fb98b4b499d671e7511c7c194cd64cc959028f0f612afdd3599c80a327e852a4d0e2b5318ee49ab262524e84ebaf1d45a4572a1c694ed142f24315d SHA512 636034b3f366e94824b3ccaff756c4717a8062d24caa13d59f6e60c04cdf0e8db0666e47a9f7d332f4546e454840d2f2e894dee4226c646adcacc88bb88c1ddd
+DIST Regexp-Common-net-CIDR-0.03.tar.gz 26311 BLAKE2B 61c7f29962fd64ebefc0bf9f10bf6f7fb19fa3fcfcc963cded5b45e21738998cda610a5a4736ae6deb30e38696c07b06fe5355c73dbda7844e2da1b34bfddb53 SHA512 0ca3d188ea4197af2981c2910e5f5a2d412d760251ee7ad9d688aa6e60f4dfdbf5583d599b1af8698ed7c740c252f0e8bda38de254f03a699122de1c1f598f20
diff --git a/dev-perl/Regexp-Common-net-CIDR/Regexp-Common-net-CIDR-0.30.0.ebuild b/dev-perl/Regexp-Common-net-CIDR/Regexp-Common-net-CIDR-0.30.0.ebuild
new file mode 100644
index 000000000000..8770f3f1c8d1
--- /dev/null
+++ b/dev-perl/Regexp-Common-net-CIDR/Regexp-Common-net-CIDR-0.30.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=BPS
+DIST_VERSION=0.03
+inherit perl-module
+
+DESCRIPTION="Provides patterns for CIDR blocks"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Regexp-Common
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? ( virtual/perl-Test-Simple )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.03-no-dot-inc.patch"
+ "${FILESDIR}/${PN}-0.03-basic-tests.patch"
+)
diff --git a/dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-basic-tests.patch b/dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-basic-tests.patch
new file mode 100644
index 000000000000..19d6c031cfe4
--- /dev/null
+++ b/dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-basic-tests.patch
@@ -0,0 +1,43 @@
+From 85dd6c8d78ab332921c109d9a8e8577d39502b7c Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 3 Jan 2018 23:24:42 +1300
+Subject: Add basic load and match test
+
+---
+ MANIFEST | 1 +
+ t/basic.t | 14 ++++++++++++++
+ 2 files changed, 15 insertions(+)
+ create mode 100644 t/basic.t
+
+diff --git a/MANIFEST b/MANIFEST
+index 9f7ef84..b5de94a 100644
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -14,3 +14,4 @@ Makefile.PL
+ MANIFEST This list of files
+ META.yml
+ README
++t/basic.t
+diff --git a/t/basic.t b/t/basic.t
+new file mode 100644
+index 0000000..48c2487
+--- /dev/null
++++ b/t/basic.t
+@@ -0,0 +1,14 @@
++
++use strict;
++use warnings;
++
++use Test::More;
++use Regexp::Common;
++use Regexp::Common::net::CIDR;
++
++ok( "1.2.3.4/1" =~ /$RE{net}{CIDR}{IPv4}/, "1.2.3.4/1 is a CIDR");
++ok( "1.2.3.4" !~ /$RE{net}{CIDR}{IPv4}/, "1.2.3.4 is not a CIDR");
++
++done_testing;
++
++
+--
+2.15.1
+
diff --git a/dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-no-dot-inc.patch b/dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-no-dot-inc.patch
new file mode 100644
index 000000000000..cdd16b7e56ed
--- /dev/null
+++ b/dev-perl/Regexp-Common-net-CIDR/files/Regexp-Common-net-CIDR-0.03-no-dot-inc.patch
@@ -0,0 +1,23 @@
+From 7edb7171dc09e2cb6157724ebeaa45eeb07d8d4b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
+Date: Tue, 4 Jul 2017 09:19:37 +1200
+Subject: Add build fix for Perl 5.26
+
+Bug: https://bugs.gentoo.org/623090
+---
+ Makefile.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 422966a..fea6408 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,4 +1,4 @@
+-use inc::Module::Install;
++use lib q[.]; use inc::Module::Install;
+ name('Regexp-Common-net-CIDR');
+ version_from('lib/Regexp/Common/net/CIDR.pm');
+ license('perl');
+--
+2.15.1
+