summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-08-14 20:50:04 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-08-14 20:50:04 +0700
commit6728a7bea148a08a84535fcef8164092578f9850 (patch)
tree253a7ce21e08055f9e753d9083a73053b3f56665
parentgentoo/dev-python/spyder: bump to 3.3.1 (diff)
downloadgentoo-6728a7bea148a08a84535fcef8164092578f9850.tar.gz
gentoo-6728a7bea148a08a84535fcef8164092578f9850.tar.bz2
gentoo-6728a7bea148a08a84535fcef8164092578f9850.zip
dev-python/spyder: bump to 4.0.0_beta1
Package-Manager: Portage-2.3.41, Repoman-2.3.9
-rw-r--r--dev-python/spyder/Manifest1
-rw-r--r--dev-python/spyder/files/spyder-4.0.0_beta1-build.patch49
-rw-r--r--dev-python/spyder/spyder-4.0.0_beta1.ebuild78
3 files changed, 128 insertions, 0 deletions
diff --git a/dev-python/spyder/Manifest b/dev-python/spyder/Manifest
index 4dba8735e428..e07e5f121128 100644
--- a/dev-python/spyder/Manifest
+++ b/dev-python/spyder/Manifest
@@ -2,3 +2,4 @@ DIST spyder-3.2.4.tar.gz 3345797 BLAKE2B 2df946f257fee7e87dd922b6ed3b3c0fa024385
DIST spyder-3.2.8.tar.gz 3414627 BLAKE2B 95f85f719eba20eb9fed5183cfac582b040abc93724df512188d14167a1663c5be9906dfc499feda9f8b0d7a713c093dbf98e4f20f732e0e9669397e1b7c8482 SHA512 03dea90632af510cfc8c4cc684068213a54dac9eef671f04c83663dd40eb480a4b818e2d040efa7a78a0d17044018aa76f2931abbf344eb684094fc7a86ddf5e
DIST spyder-3.3.0.tar.gz 2782654 BLAKE2B e85ef52109c723d6b1b011f0e81ab3a46d3e0e6ba72fd34a1eda9ed650c9e03532e8fd72e05365367f62035a6f03d6ec32d35314c54438bf639070c7bebfb4d6 SHA512 53a2b438afe245092eda4d202d2453b5b93d6682aafcdb00bf251ddcdb30cee2d81d8adadbe23fa36f64fa5f917b327690cb8f9e2cf5c0da2841b5eda648a26f
DIST spyder-3.3.1.tar.gz 2786730 BLAKE2B d906b5750cb620db41aec514a64d132b9ee5a992047828faffe11af5abd22d0cec7b876dfe79c6d378804373e8db5c661214f5730833e7599bf13b80d4dc16d6 SHA512 91d648a2717b5d5386115ba800fdd98884e609b213007dbaa09c7d16335f1b9ec3d0bc6b32d1677db8c2704e990e70eaa04d6d1efc800008cddfa511105e9c68
+DIST spyder-4.0.0b1.tar.gz 2986758 BLAKE2B 7fa918a569ed26d1d71ea7bce725f1b7d5db54badf3fb7bad1265d93f2ebdf25b1246acefb4f8517a6f34968bf8f12331958afcf72fc3c162e0d06d9dc4d4c72 SHA512 5751434b7ffac4d1e0c535f8a842656c3a306ed3d8a275a06a0eb57d3cd9bb36d01341723159292cba8616fcadc7157387fdb334b2ab0efbc1bb6b920102015a
diff --git a/dev-python/spyder/files/spyder-4.0.0_beta1-build.patch b/dev-python/spyder/files/spyder-4.0.0_beta1-build.patch
new file mode 100644
index 000000000000..2b0f9bc699f3
--- /dev/null
+++ b/dev-python/spyder/files/spyder-4.0.0_beta1-build.patch
@@ -0,0 +1,49 @@
+diff -r -U3 spyder-4.0.0b1.orig/setup.py spyder-4.0.0b1/setup.py
+--- spyder-4.0.0b1.orig/setup.py 2018-08-12 04:35:49.000000000 +0700
++++ spyder-4.0.0b1/setup.py 2018-08-14 20:25:32.827148778 +0700
+@@ -83,12 +83,7 @@
+ def get_data_files():
+ """Return data_files in a platform dependent manner"""
+ if sys.platform.startswith('linux'):
+- if PY3:
+- data_files = [('share/applications', ['scripts/spyder3.desktop']),
+- ('share/icons', ['img_src/spyder3.png']),
+- ('share/metainfo', ['scripts/spyder3.appdata.xml'])]
+- else:
+- data_files = [('share/applications', ['scripts/spyder.desktop']),
++ data_files = [('share/applications', ['scripts/spyder.desktop']),
+ ('share/icons', ['img_src/spyder.png'])]
+ elif os.name == 'nt':
+ data_files = [('scripts', ['img_src/spyder.ico',
+@@ -112,21 +107,6 @@
+
+
+ #==============================================================================
+-# Make Linux detect Spyder desktop file
+-#==============================================================================
+-class MyInstallData(install_data):
+- def run(self):
+- install_data.run(self)
+- if sys.platform.startswith('linux'):
+- try:
+- subprocess.call(['update-desktop-database'])
+- except:
+- print("ERROR: unable to update desktop database",
+- file=sys.stderr)
+-CMDCLASS = {'install_data': MyInstallData}
+-
+-
+-#==============================================================================
+ # Main scripts
+ #==============================================================================
+ # NOTE: the '[...]_win_post_install.py' script is installed even on non-Windows
+@@ -210,8 +190,7 @@
+ 'Intended Audience :: Science/Research',
+ 'Intended Audience :: Developers',
+ 'Topic :: Scientific/Engineering',
+- 'Topic :: Software Development :: Widget Sets'],
+- cmdclass=CMDCLASS)
++ 'Topic :: Software Development :: Widget Sets'])
+
+
+ #==============================================================================
diff --git a/dev-python/spyder/spyder-4.0.0_beta1.ebuild b/dev-python/spyder/spyder-4.0.0_beta1.ebuild
new file mode 100644
index 000000000000..8e9b75efc5b7
--- /dev/null
+++ b/dev-python/spyder/spyder-4.0.0_beta1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit eutils distutils-r1 xdg-utils
+MY_P=${P/_beta/b}
+
+DESCRIPTION="The Scientific PYthon Development EnviRonment"
+HOMEPAGE="
+ https://www.spyder-ide.org/
+ https://github.com/spyder-ide/spyder/
+ https://pypi.org/project/spyder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hdf5 +webengine webkit"
+REQUIRED_USE="webengine? ( !webkit )"
+
+RDEPEND="
+ hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/jedi[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ dev-python/pickleshare[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP},svg,webengine?,webkit?]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ >=dev-python/qtawesome-0.4.1[${PYTHON_USEDEP}]
+ dev-python/qtconsole[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP},svg,webengine?,webkit?]
+ >=dev-python/rope-0.10.7[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ >=dev-python/spyder-kernels-1.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Based on the courtesy of Arfrever
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+S="${WORKDIR}/${MY_P}"
+
+python_install() {
+ distutils-r1_python_install
+ python_newscript scripts/${PN} ${PN}${EPYTHON:6:1}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doicon spyder/images/spyder.svg
+ make_desktop_entry spyder Spyder spyder "Development;IDE"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog "To get additional features, optional runtime dependencies may be installed:"
+ optfeature "2D/3D plotting in the Python and IPython consoles" dev-python/matplotlib
+ optfeature "View and edit DataFrames and Series in the Variable Explorer" dev-python/pandas
+ optfeature "View and edit two or three dimensional arrays in the Variable Explorer" dev-python/numpy
+ optfeature "Symbolic mathematics in the IPython console" dev-python/sympy
+ optfeature "Import Matlab workspace files in the Variable Explorer" sci-libs/scipy
+ optfeature "Run Cython files in the IPython console" dev-python/cython
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}