summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-05 17:09:17 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-05 17:09:25 +0200
commit67c3302519d1d0befd9f3598228c7ca4a7b63233 (patch)
tree07b6e7a1c71a9e9e3b1ad1ebf53256b190bf3e3e
parentdev-ros/rosconsole: fix build with latest boost/gcc6, bug #595818. Patch by P... (diff)
downloadgentoo-67c3302519d1d0befd9f3598228c7ca4a7b63233.tar.gz
gentoo-67c3302519d1d0befd9f3598228c7ca4a7b63233.tar.bz2
gentoo-67c3302519d1d0befd9f3598228c7ca4a7b63233.zip
media-libs/libyami: bump to 1.0.0
Package-Manager: portage-2.3.1
-rw-r--r--media-libs/libyami/Manifest1
-rw-r--r--media-libs/libyami/files/oot.patch48
-rw-r--r--media-libs/libyami/libyami-1.0.0.ebuild91
-rw-r--r--media-libs/libyami/libyami-9999.ebuild12
4 files changed, 147 insertions, 5 deletions
diff --git a/media-libs/libyami/Manifest b/media-libs/libyami/Manifest
index 2d131791d687..59c5657f0564 100644
--- a/media-libs/libyami/Manifest
+++ b/media-libs/libyami/Manifest
@@ -1,3 +1,4 @@
DIST libyami-0.3.0.tar.gz 484586 SHA256 67064558999d63185025a6d63d08458375003bb86369abca50aca97fd2c63acb SHA512 691cbe90840d8cb30da958bb6621434c9962ae6cbfc75b016454570c303a01e7a465baa8622368cf1ef1c670dbc861fb1d49e0c414d684feae04ea742e8e0599 WHIRLPOOL d842f1ce57d40894b80f868934d687603014b6460bdbd274b64893d8f290f8a6a779239f931beb759a7fb8e5ed1649b90fb545391c1d9c8395bb05f6600218d2
DIST libyami-0.3.1.tar.gz 492223 SHA256 7ab680138a1d34eb306bc941198f0715631bc8e5b0ee5717b3171f6672ca3bcb SHA512 eb58a6925de8379e40b2482780340becdb8c9295041bba11bf439cc2ff19c25f10ce4b1fc2b6c421342855946ddd471745bdfb364a227499658867911325b375 WHIRLPOOL ce44614aa04127c828761319dd96ee35956daea9cf7577e7631083e10db744c76596da7135f8f6c16952639c601ee065afe8c0097bf6d23829dc9893c4aa414f
DIST libyami-0.4.0.tar.gz 445389 SHA256 b4a139fac81b6644828e8c9c377fe251128d2b4440ffd656f973c0bee14a2821 SHA512 b3c5394f1980e799717cfcb44d95dc93da10d6acb94eed106bc251ca3162194a55cedb111ac7023257b77c868807e9546df461c061ab3e1b02e3f2bbd30d3687 WHIRLPOOL 1a01901dd67d49bd26a74a00684e807e162986c9674a647e96ba5e1b573a25fca78835e377b83e348d275882c69611ce1008d01a74276468f5d475d369ba23e0
+DIST libyami-1.0.0.tar.gz 477186 SHA256 ef83e0d279b387e8475cdd5898a9a00132fabaadd4a5b6224f707a31cd159af5 SHA512 14d79991e66a83481eb2cdcc8c82e21e1d87ca90e2ae103590f3d9d68aa6d9b761034107dda34c7d20637a94e14acb40fecaf50caab22fe85f1de01fae904f88 WHIRLPOOL ead37c22a203f94f8071b0b6e70052391ed0ec4c4fb1206f7864bef062fafeda7443dfa10f94da4c3c4598800ef75d2f3bcf2bbc508eb94c1fae39c576b2c78e
diff --git a/media-libs/libyami/files/oot.patch b/media-libs/libyami/files/oot.patch
new file mode 100644
index 000000000000..96e40ba87b06
--- /dev/null
+++ b/media-libs/libyami/files/oot.patch
@@ -0,0 +1,48 @@
+Index: libyami-libyami-1.0.0/common/Makefile.am
+===================================================================
+--- libyami-libyami-1.0.0.orig/common/Makefile.am
++++ libyami-libyami-1.0.0/common/Makefile.am
+@@ -31,6 +31,7 @@ libyami_common_ldflags = \
+ libyami_common_cppflags = \
+ $(LIBVA_CFLAGS) \
+ -I$(top_srcdir)/interface \
++ -I$(top_srcdir) \
+ $(NULL)
+
+ noinst_LTLIBRARIES = libyami_common.la
+Index: libyami-libyami-1.0.0/common/Makefile.unittest
+===================================================================
+--- libyami-libyami-1.0.0.orig/common/Makefile.unittest
++++ libyami-libyami-1.0.0/common/Makefile.unittest
+@@ -22,6 +22,7 @@ unittest_CPPFLAGS = \
+ $(LIBVA_CFLAGS) \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir)/interface \
++ -I$(top_srcdir) \
+ $(NULL)
+
+ unittest_CXXFLAGS = \
+Index: libyami-libyami-1.0.0/codecparsers/Makefile.am
+===================================================================
+--- libyami-libyami-1.0.0.orig/codecparsers/Makefile.am
++++ libyami-libyami-1.0.0/codecparsers/Makefile.am
+@@ -113,6 +113,7 @@ libyami_codecparser_cppflags = \
+ -Dvp8dx_start_decode=libyami_vp8dx_start_decode \
+ -Dvp8dx_bool_decoder_fill=libyami_vp8dx_bool_decoder_fill \
+ -I$(top_srcdir)/interface \
++ -I$(top_srcdir) \
+ $(NULL)
+
+ noinst_LTLIBRARIES = libyami_codecparser.la
+Index: libyami-libyami-1.0.0/codecparsers/Makefile.unittest
+===================================================================
+--- libyami-libyami-1.0.0.orig/codecparsers/Makefile.unittest
++++ libyami-libyami-1.0.0/codecparsers/Makefile.unittest
+@@ -58,6 +58,7 @@ unittest_CPPFLAGS = \
+ $(GTEST_CPPFLAGS) \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir)/interface \
++ -I$(top_srcdir) \
+ $(NULL)
+
+ unittest_CXXFLAGS = \
diff --git a/media-libs/libyami/libyami-1.0.0.ebuild b/media-libs/libyami/libyami-1.0.0.ebuild
new file mode 100644
index 000000000000..10af6ad3b5cd
--- /dev/null
+++ b/media-libs/libyami/libyami-1.0.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM=git-r3
+ EGIT_REPO_URI="https://github.com/01org/libyami"
+fi
+
+inherit ${SCM} autotools multilib-minimal flag-o-matic
+
+DESCRIPTION="Yet Another Media Infrastructure: Media codec with hardware acceleration"
+HOMEPAGE="https://github.com/01org/libyami"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/01org/libyami/archive/${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="debug dmabuf doc md5 v4l X test wayland"
+
+RDEPEND="
+ >=x11-libs/libva-1.7.2[drm,X?,wayland?,${MULTILIB_USEDEP}]
+ v4l? (
+ >=virtual/opengl-7[${MULTILIB_USEDEP}]
+ >=media-libs/libv4l-1.6.2[${MULTILIB_USEDEP}]
+ >=media-libs/mesa-10[egl,gles2,${MULTILIB_USEDEP}]
+ )
+ X? ( >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}] )
+ md5? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ dmabuf? ( x11-libs/libdrm[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( >=dev-cpp/gtest-1.7 )
+"
+
+src_prepare() {
+ eautoreconf
+}
+
+multilib_src_configure() {
+ append-cppflags -I"${S}/"
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable debug) \
+ $(use_enable v4l v4l2) \
+ $(use_enable v4l v4l2-ops) \
+ $(use_enable X x11) \
+ $(use_enable dmabuf) \
+ $(use_enable md5) \
+ $(use_enable wayland) \
+ $(use_enable test gtest) \
+ $(multilib_native_use_enable doc docs) \
+ --enable-h265dec \
+ --enable-vc1dec \
+ --enable-h264dec \
+ --enable-jpegdec \
+ --enable-mpeg2dec \
+ --enable-vp8dec \
+ --enable-vp9dec \
+ --enable-h265enc \
+ --enable-h264enc \
+ --enable-jpegenc \
+ --enable-vp8enc \
+ --enable-vp9enc
+}
+
+multilib_src_compile() {
+ emake
+ multilib_is_native_abi && use doc && emake -C doc
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ multilib_is_native_abi && use doc && dohtml -r doc/html/*
+}
+
+src_install() {
+ multilib-minimal_src_install
+ find "${ED}" -name '*.la' -delete
+}
diff --git a/media-libs/libyami/libyami-9999.ebuild b/media-libs/libyami/libyami-9999.ebuild
index ad517708968c..10af6ad3b5cd 100644
--- a/media-libs/libyami/libyami-9999.ebuild
+++ b/media-libs/libyami/libyami-9999.ebuild
@@ -10,7 +10,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/01org/libyami"
fi
-inherit ${SCM} autotools multilib-minimal
+inherit ${SCM} autotools multilib-minimal flag-o-matic
DESCRIPTION="Yet Another Media Infrastructure: Media codec with hardware acceleration"
HOMEPAGE="https://github.com/01org/libyami"
@@ -26,10 +26,10 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="+capi debug dmabuf doc md5 v4l X test"
+IUSE="debug dmabuf doc md5 v4l X test wayland"
RDEPEND="
- >=x11-libs/libva-1.7[drm,X?,${MULTILIB_USEDEP}]
+ >=x11-libs/libva-1.7.2[drm,X?,wayland?,${MULTILIB_USEDEP}]
v4l? (
>=virtual/opengl-7[${MULTILIB_USEDEP}]
>=media-libs/libv4l-1.6.2[${MULTILIB_USEDEP}]
@@ -50,14 +50,15 @@ src_prepare() {
}
multilib_src_configure() {
+ append-cppflags -I"${S}/"
ECONF_SOURCE="${S}" econf \
$(use_enable debug) \
$(use_enable v4l v4l2) \
$(use_enable v4l v4l2-ops) \
- $(use_enable capi) \
$(use_enable X x11) \
$(use_enable dmabuf) \
$(use_enable md5) \
+ $(use_enable wayland) \
$(use_enable test gtest) \
$(multilib_native_use_enable doc docs) \
--enable-h265dec \
@@ -70,7 +71,8 @@ multilib_src_configure() {
--enable-h265enc \
--enable-h264enc \
--enable-jpegenc \
- --enable-vp8enc
+ --enable-vp8enc \
+ --enable-vp9enc
}
multilib_src_compile() {