summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-09 10:32:56 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-09 10:33:03 +0100
commit683e17b1f110306193d772b2fe92c971274f69da (patch)
tree2fbb9e7140c840910318e3ac466833d982c5e6cc
parentnet-misc/whatportis: Add missing eclass (diff)
downloadgentoo-683e17b1f110306193d772b2fe92c971274f69da.tar.gz
gentoo-683e17b1f110306193d772b2fe92c971274f69da.tar.bz2
gentoo-683e17b1f110306193d772b2fe92c971274f69da.zip
dev-python/stevedore: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/stevedore/Manifest1
-rw-r--r--dev-python/stevedore/stevedore-1.10.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/stevedore/Manifest b/dev-python/stevedore/Manifest
index a96cb4c53993..315876eaed9b 100644
--- a/dev-python/stevedore/Manifest
+++ b/dev-python/stevedore/Manifest
@@ -1,4 +1,5 @@
DIST stevedore-1.1.0.tar.gz 352294 SHA256 f98381d12a6bfff718328d14d0d26cae6c83e39feb787e7b38acfe1089c3f1d3 SHA512 70f8629fdd455421871753810c14462ba66f81d1478ea45696c400a68f034a77c2a3efaac3c96bebe7293c42f73715681161b7fca8897d545a7ae06d64ad0c44 WHIRLPOOL 1f3e5380792cea8b3ef67fc4a4f8be40fd3cb2f048caa71c0c774990dc45d9981edec599312301b3f7a54955b941a421574e3c23c794fc3f117251e845ea214d
+DIST stevedore-1.10.0.tar.gz 501859 SHA256 f5d689ef38e0ca532d57a03d1ab95e89b17c57f97b58d10c92da94699973779f SHA512 7842388475c4c2f59e0bdbd1f07cc7588a12ac61fb0f9282c4e668e2b6b7278a7ff262ff5b1678492ce6cd7844a01729ed16119ae906fe010e27b8551f30f24e WHIRLPOOL 4399418912867472ad3197b69ad23d080d15150552151efe94a5cb905acaeb7a65e4d6a5d45d5edb5231dba9dd6d7442ca33e93a2d742be5290894a2f9df4c9a
DIST stevedore-1.3.0.tar.gz 354869 SHA256 beab2b7f91966d259796392c39ed6f260b32851861561dd9f3b9be2fd0c426a5 SHA512 68583c8e7c9c667c4456754a973d344f79ca141d380e6e568d82f8b36fc77e8debc4d77a006eb7b6e580edf017307f748842f1cae8a82ef101114eebdab82c26 WHIRLPOOL 16eb37416b4dccf8606aca2d407eda9060549e014f41db0f54982707f9a9d51cb7bdfcb048b8bac494f707dce042e22a7ff87c210aff8e39d4940717a5f5a6ca
DIST stevedore-1.4.0.tar.gz 353953 SHA256 4a8d80b0a232746c09e0173bd61d60a18e9864e3dc87e3ebefa3ba3d8a00232f SHA512 a947d13ef15b2a5210da7115de7b49b4297f811a8237f0d205c2e2a676747255a852300ca99dd5279ae0de49f706b380fc8a09921c9a1e9f0bf6ad7ea34023e3 WHIRLPOOL 7c4ab9ce986cec938772ed63094a8f2d6a5072be948845dd324c7c68cae4082781babd36d87d832bae37d30960efa76309350cfafa725555e02ca6354dd7c2aa
DIST stevedore-1.6.0.tar.gz 500868 SHA256 dab2aa31ec742f651e6a2fe0429560aebbbe0fb7fc462fa0ff565c8f5ff2ec25 SHA512 bdcf3ab8f539ad2df65cb6f1d0eecf77e98a7b579ea50ccb419979ce419632963c199e3e473a36072ba303d3fbdbfea3f0f56a27831c35c65a1874ebc8b6b0b4 WHIRLPOOL 65f6a08f6fa19214725c972bdbc39f605b4a852376ad19c5c29c4bb1a361dea69677e4f7a5061f7ce6201b8da06bd12b8693256cc7b562e4f92b866fcaffd013
diff --git a/dev-python/stevedore/stevedore-1.10.0.ebuild b/dev-python/stevedore/stevedore-1.10.0.ebuild
new file mode 100644
index 000000000000..efb2e19253a2
--- /dev/null
+++ b/dev-python/stevedore/stevedore-1.10.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/openstack/stevedore https://pypi.python.org/pypi/stevedore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-1.6[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/pillow-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Delete spurious data in requirements.txt
+ sed -e '/^pbr/d' -e '/^argparse/d' \
+ -i requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ nosetests --verbosity=3 stevedore || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}