summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-09-15 21:27:58 +0800
committerJason Zaman <perfinion@gentoo.org>2016-09-15 22:07:41 +0800
commit68775d80d50c12152d5818d72d4f05e1d500fcc3 (patch)
tree24eaf98bc621481438635a575cbaa58f614e23cd
parentx11-terms/mlterm: new upstream release (diff)
downloadgentoo-68775d80d50c12152d5818d72d4f05e1d500fcc3.tar.gz
gentoo-68775d80d50c12152d5818d72d4f05e1d500fcc3.tar.bz2
gentoo-68775d80d50c12152d5818d72d4f05e1d500fcc3.zip
xfce-base/libxfce4ui: bump to 4.13.1
Package-Manager: portage-2.2.28
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.13.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index 8acbd254330f..9a6f7c27ce7f 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4ui-4.12.1.tar.bz2 665624 SHA256 3d619811bfbe7478bb984c16543d980cadd08586365a7bc25e59e3ca6384ff43 SHA512 9d132a81bc3385b6582c2d97ed7a1fc0ea289d9098cc4c3a7fb523329eb6afb18716bcf98a5832c4484794eb7a2be4242fa2e71083cd5e55cb19e3b8003458a8 WHIRLPOOL bfc23f795755af6dc7a0ea947dfc931c3dc8eaa64d73303361d0be8cad77d5a9206d349551995de8a291281270564ed54f947f4c56285f7bc8ae91dfbfdd538d
DIST libxfce4ui-4.13.0.tar.bz2 688646 SHA256 22f0b66a33945f347952249589f71618418f1e47ca847850eb0ee1bdb0c353d4 SHA512 342c4fb09b3f13e066b994c54cd557a65c116566b8201217cb663851ba387932cdd4ebf2274f32bdc97a98b3a2bd1b59de75ef6cc4c6f5d0e5f1910b7eca591e WHIRLPOOL 37d9d68af580482186e5f1bd078b72b48339ee032b85e38ea944b2a08e80deead2887fbee9f30b15251214bb0aae7cc92857f2559db116767c96f630ad5b7d80
+DIST libxfce4ui-4.13.1.tar.bz2 691839 SHA256 2a257d73ccf30c1939df2e6ba879c925a1290ae2877a79b27d389e09e01c917d SHA512 056f6c944f1060f43037427304fccc7bb835a0ba5263d9c2f41c5cd2f980a61d4c45f9aa4b97004bae0b57e0020de0af43345b28f53748cea94fcd97fe785523 WHIRLPOOL 6f4b2879d9e930efff4c0f10746a879b67c81367f5c0960da29617147a8e1571f64538f2aa03e7fcf91d75e466b8b11d36f8aa8c272b6483b051fe5502d814d5
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.13.1.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.13.1.ebuild
new file mode 100644
index 000000000000..2a913219b5c9
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.13.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="http://www.xfce.org/projects/libxfce4"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade startup-notification"
+
+RDEPEND=">=dev-libs/glib-2.30:2=
+ >=x11-libs/gtk+-2.24:2=
+ >=x11-libs/gtk+-3.2:3=
+ x11-libs/libX11:=
+ x11-libs/libICE:=
+ x11-libs/libSM:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10= )
+ startup-notification? ( x11-libs/startup-notification:= )
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable startup-notification)
+ $(xfconf_use_debug)
+ # does not build without GTK+3, #585684
+ --enable-gtk3
+ # requires deprecated glade:3 (gladeui-1.0), bug #551296
+ --disable-gladeui
+ # this one's for :3.10
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}