summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-10-23 22:33:55 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-10-24 00:59:40 +0200
commit69a66551ea050e0027cde32818eaeb31a1144cbd (patch)
tree2e591b590d2369cbc4c249f749443c9073876c85
parentapp-text/libgepub: initial ebuild for gnome-document-3.22 (diff)
downloadgentoo-69a66551ea050e0027cde32818eaeb31a1144cbd.tar.gz
gentoo-69a66551ea050e0027cde32818eaeb31a1144cbd.tar.bz2
gentoo-69a66551ea050e0027cde32818eaeb31a1144cbd.zip
gnome-extra/gnome-documents: version bump 3.20.1 → 3.22.0
Package-Manager: portage-2.3.1
-rw-r--r--gnome-extra/gnome-documents/Manifest1
-rw-r--r--gnome-extra/gnome-documents/gnome-documents-3.22.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/gnome-extra/gnome-documents/Manifest b/gnome-extra/gnome-documents/Manifest
index d9737f67e0f1..28c8d3bff832 100644
--- a/gnome-extra/gnome-documents/Manifest
+++ b/gnome-extra/gnome-documents/Manifest
@@ -1,3 +1,4 @@
DIST gnome-documents-3.18.3.tar.xz 2297720 SHA256 16a50d509d43009d58b44b5f6d4d92e155a55dcb22bd8e0fdfd63b8d2ab48b91 SHA512 69129100858434c99d3a47bfa776637e8d26eda5eb40d089f1c32da6ef1ecc3265c17cbcb657e944559dbca788445a66956c7aabbb24167ec095d8af4f4d29de WHIRLPOOL b5be7ad7ed8bc1ad484a94a1b83dc53389277181a63ccf16519b7bcf798e471082fa4d133173a6dc55628ba3a7ad2e37c8063f987ffd00a38c59efdea7749942
DIST gnome-documents-3.20.0.tar.xz 2319732 SHA256 a5fa496c5e80eccb8d2e5bba7f4d7dc4cc6c9f53d5bc028402428771be1237d2 SHA512 f69c48f8c343e674aca77f3334ce1a10d30f90f2dade5722d7c0b759e67d2c633199d510ff3c70a202e7ed6b309d93035eb35c4ae554a8da83aefb78fafeacaa WHIRLPOOL 5d7a537bfc19130646e43239acd51fa21154b4a648e0be895252c55ea84714d2a26c876862781c56d365222d1ad36fa71bac7d6d40edd31ec5ea951b06e7edb9
DIST gnome-documents-3.20.1.tar.xz 2327412 SHA256 c73810ded97431360ba80c127d3244b1e6e416643fba0ba96411d22729211394 SHA512 f879a9761f5a34cb006a7df3933dfbd8f4c54e3fecf1601bd48d05a0994821eb8e7f5ba54f7ac5a2b6cd9674b733dd74445592d1e20f6903073965ec79072916 WHIRLPOOL d66fd64403d27610725562edb444ee93108984a7b5dec7dd7322f896734e75241f67e3939cd0000f4031f531c9b9fc3354d13436394725fa845a25096596498c
+DIST gnome-documents-3.22.0.tar.xz 2336988 SHA256 edf5cd6b7b7f5847217b60885358030598e551010087d2a9d1765ae6777041ad SHA512 82bf3b67e6ebe3a8a2415d9bacfa4323eab31a32d23b852f07f30579d5437c1f436c2a0d25174e9ba9131a90eb1900dfe33cfcc214fe600a903edf00de14b325 WHIRLPOOL 254f8c30617f1aea952e07d69ce0ca43f91b208ef2d8623f79624c7371901112bf8bd409ee9ded5f779953a91117931eb2b1362888e928f7654353a939fd3fee
diff --git a/gnome-extra/gnome-documents/gnome-documents-3.22.0.ebuild b/gnome-extra/gnome-documents/gnome-documents-3.22.0.ebuild
new file mode 100644
index 000000000000..bd4afa84ff81
--- /dev/null
+++ b/gnome-extra/gnome-documents/gnome-documents-3.22.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A document manager application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Documents"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+# Need gdk-pixbuf-2.25 for gdk_pixbuf_get_pixels_with_length
+COMMON_DEPEND="
+ >=app-misc/tracker-1:=[miner-fs]
+ >=app-text/evince-3.13.3[introspection]
+ >=app-text/libgepub-0.4[introspection]
+ dev-libs/gjs
+ >=dev-libs/glib-2.39.3:2
+ >=dev-libs/gobject-introspection-1.31.6:=
+ >=dev-libs/libgdata-0.13.3:=[crypt,gnome-online-accounts,introspection]
+ gnome-base/gnome-desktop:3=[introspection]
+ >=media-libs/clutter-1.10:1.0
+ >=media-libs/clutter-gtk-1.3.2:1.0[introspection]
+ >=net-libs/gnome-online-accounts-3.2.0[introspection]
+ >=net-libs/libsoup-2.41.3:2.4
+ >=net-libs/libzapojit-0.0.2[introspection]
+ >=net-libs/webkit-gtk-2.6:4[introspection]
+ >=x11-libs/gdk-pixbuf-2.25:2[introspection]
+ >=x11-libs/gtk+-3.19.1:3[introspection]
+ x11-libs/pango[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/clutter[introspection]
+ net-misc/gnome-online-miners
+ sys-apps/dbus
+ x11-themes/adwaita-icon-theme
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ virtual/pkgconfig
+"
+# eautoreconf requires yelp-tools