summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 09:34:52 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-01 14:15:54 +0100
commit6af202dc37ef6ec98c3f93b59a2cbd80040931eb (patch)
treeed0ff200e4c10447555463cceeb33b959bed1936
parentsys-libs/compiler-rt: Switch live to monorepo (diff)
downloadgentoo-6af202dc37ef6ec98c3f93b59a2cbd80040931eb.tar.gz
gentoo-6af202dc37ef6ec98c3f93b59a2cbd80040931eb.tar.bz2
gentoo-6af202dc37ef6ec98c3f93b59a2cbd80040931eb.zip
sys-libs/libcxx: Switch live to monorepo
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-libs/libcxx/libcxx-10.0.0.9999.ebuild9
-rw-r--r--sys-libs/libcxx/libcxx-9.0.1.9999.ebuild11
2 files changed, 15 insertions, 5 deletions
diff --git a/sys-libs/libcxx/libcxx-10.0.0.9999.ebuild b/sys-libs/libcxx/libcxx-10.0.0.9999.ebuild
index 83d8eeaa8c40..9c722cc33620 100644
--- a/sys-libs/libcxx/libcxx-10.0.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-10.0.0.9999.ebuild
@@ -16,8 +16,8 @@ inherit cmake-multilib git-r3 llvm multiprocessing python-any-r1 \
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="https://libcxx.llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/libcxx.git
- https://github.com/llvm-mirror/libcxx.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/libcxx
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
@@ -73,6 +73,11 @@ pkg_setup() {
fi
}
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' libcxx
+}
+
test_compiler() {
$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c++ - \
<<<'int main() { return 0; }' &>/dev/null
diff --git a/sys-libs/libcxx/libcxx-9.0.1.9999.ebuild b/sys-libs/libcxx/libcxx-9.0.1.9999.ebuild
index 5a84e2f5f998..f70527cd308e 100644
--- a/sys-libs/libcxx/libcxx-9.0.1.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-9.0.1.9999.ebuild
@@ -16,9 +16,9 @@ inherit cmake-multilib git-r3 llvm multiprocessing python-any-r1 \
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="https://libcxx.llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/libcxx.git
- https://github.com/llvm-mirror/libcxx.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/libcxx
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
@@ -74,6 +74,11 @@ pkg_setup() {
fi
}
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' libcxx
+}
+
test_compiler() {
$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c++ - \
<<<'int main() { return 0; }' &>/dev/null