summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2018-01-30 23:06:56 -0600
committerErik Mackdanz <stasibear@gentoo.org>2018-02-04 10:51:03 -0600
commit6bc46b77ac7f5405cdec894793963e0cc94cbf42 (patch)
tree81acb862babcfdce0bbf9b5c013d570eba057cee
parentnet-libs/libupnpp: new package 0.16.1 (diff)
downloadgentoo-6bc46b77ac7f5405cdec894793963e0cc94cbf42.tar.gz
gentoo-6bc46b77ac7f5405cdec894793963e0cc94cbf42.tar.bz2
gentoo-6bc46b77ac7f5405cdec894793963e0cc94cbf42.zip
media-sound/upmpdcli: New package 1.2.15
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--media-sound/upmpdcli/Manifest1
-rw-r--r--media-sound/upmpdcli/files/upmpdcli.confd1
-rw-r--r--media-sound/upmpdcli/files/upmpdcli.initd14
-rw-r--r--media-sound/upmpdcli/metadata.xml16
-rw-r--r--media-sound/upmpdcli/upmpdcli-1.2.15.ebuild44
5 files changed, 76 insertions, 0 deletions
diff --git a/media-sound/upmpdcli/Manifest b/media-sound/upmpdcli/Manifest
new file mode 100644
index 000000000000..a5246d45e105
--- /dev/null
+++ b/media-sound/upmpdcli/Manifest
@@ -0,0 +1 @@
+DIST upmpdcli-1.2.15.tar.gz 401551 BLAKE2B 0ec3fd67d67fd039f5b0ac385ad12a78e3c48b0d2530690eb9aaff66bbdbf7ae7229d64cfe753d9e70e75070ee5bc4d0849d11909813f06377981974733134ee SHA512 4a62aced9fa2395752164332c84bf3dedd7b793e7e37638cfe063e887d52b9ce956c866de2aa1cddb7a4dcad97562050f9588aedd59e49e7d427671179f9258a
diff --git a/media-sound/upmpdcli/files/upmpdcli.confd b/media-sound/upmpdcli/files/upmpdcli.confd
new file mode 100644
index 000000000000..dce55d70aec0
--- /dev/null
+++ b/media-sound/upmpdcli/files/upmpdcli.confd
@@ -0,0 +1 @@
+config=/etc/upmpdcli.conf
diff --git a/media-sound/upmpdcli/files/upmpdcli.initd b/media-sound/upmpdcli/files/upmpdcli.initd
new file mode 100644
index 000000000000..43618aeca4ea
--- /dev/null
+++ b/media-sound/upmpdcli/files/upmpdcli.initd
@@ -0,0 +1,14 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="UPnP Media Renderer front-end for MPD, the Music Player Daemon"
+pidfile=/var/run/upmpdcli.pid
+command=/usr/bin/upmpdcli
+config="${config:-/etc/upmpdcli.conf}"
+command_args="-c ${config}"
+command_args_background="-D"
+
+depend() {
+ need localmount mpd
+}
diff --git a/media-sound/upmpdcli/metadata.xml b/media-sound/upmpdcli/metadata.xml
new file mode 100644
index 000000000000..b13ccae7c8bb
--- /dev/null
+++ b/media-sound/upmpdcli/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>stasibear@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<longdescription>
+ UPnP Media Renderer front-end for MPD, the Music Player Daemon
+</longdescription>
+<use>
+ <flag name="thirdparty">
+ Enable streaming from Qobuz and Tidal external services
+ </flag>
+</use>
+</pkgmetadata>
diff --git a/media-sound/upmpdcli/upmpdcli-1.2.15.ebuild b/media-sound/upmpdcli/upmpdcli-1.2.15.ebuild
new file mode 100644
index 000000000000..3acbdb45b480
--- /dev/null
+++ b/media-sound/upmpdcli/upmpdcli-1.2.15.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="UPnP Media Renderer front-end for MPD, the Music Player Daemon"
+HOMEPAGE="https://www.lesbonscomptes.com/upmpdcli/index.html"
+LICENSE="GPL-2"
+
+SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="thirdparty"
+
+DEPEND="
+ dev-libs/jsoncpp
+ media-libs/libmpdclient
+ net-libs/libmicrohttpd
+ net-libs/libupnpp
+"
+RDEPEND="
+ ${DEPEND}
+ thirdparty? ( dev-python/requests )
+ media-sound/mpd
+"
+
+pkg_setup() {
+ enewuser "${PN}"
+ enewgroup "${PN}"
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Consider installing media-sound/sc2mpd. If upmpdcli"
+ einfo "detects sc2mpd at run-time, capabilities are added"
+ einfo "including internet radio support. See upstream docs"
+ einfo "for more information."
+}