summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-12 10:02:30 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-12 10:06:32 +0200
commit6be64841077924e592e49be11bc2c62672c38bd5 (patch)
tree91e75f2792981b4ed660cd958bac9ba49b786153
parentdev-util/cmake: 3.3.1-r1 stable on x86, bug #561620 (diff)
downloadgentoo-6be64841077924e592e49be11bc2c62672c38bd5.tar.gz
gentoo-6be64841077924e592e49be11bc2c62672c38bd5.tar.bz2
gentoo-6be64841077924e592e49be11bc2c62672c38bd5.zip
sci-chemistry/prody: New Package
ebuild written by me Package-Manager: portage-2.2.22 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-chemistry/prody/Manifest1
-rw-r--r--sci-chemistry/prody/metadata.xml8
-rw-r--r--sci-chemistry/prody/prody-1.6.ebuild44
3 files changed, 53 insertions, 0 deletions
diff --git a/sci-chemistry/prody/Manifest b/sci-chemistry/prody/Manifest
new file mode 100644
index 000000000000..df88491d4cbf
--- /dev/null
+++ b/sci-chemistry/prody/Manifest
@@ -0,0 +1 @@
+DIST prody-1.6.tar.gz 5333629 SHA256 db5f2223005640e64b5bfd5ef147744381b9b170ced61db7bc8f3a0fdb583c86 SHA512 d913ad45b034f1b0e7e36428a6f8f199b365b94bd85bee5ade8eb9eb2b04a18c93d894a2abd18b3a1342597725ffbf96f8ce8a49191fc27e5608f3d2c9a3c49a WHIRLPOOL a6435d88046970cca53290b258017d09b19457c4bbd5530743a3dc9cbc023ee78a28a4df81b190a5499df114d9909afff0697e571ef5bc4726311f4ea287c4be
diff --git a/sci-chemistry/prody/metadata.xml b/sci-chemistry/prody/metadata.xml
new file mode 100644
index 000000000000..ae9ec7c5f6a4
--- /dev/null
+++ b/sci-chemistry/prody/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/prody/prody-1.6.ebuild b/sci-chemistry/prody/prody-1.6.ebuild
new file mode 100644
index 000000000000..a2ece4dfd984
--- /dev/null
+++ b/sci-chemistry/prody/prody-1.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Protein Dynamics Analysis"
+HOMEPAGE="http://prody.csb.pitt.edu/ https://github.com/prody/ProDy"
+SRC_URI="https://github.com/prody/ProDy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ sci-biology/biopython[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}"/ProDy-${PV}
+
+DISTUTILS_IN_SOURCE_BUILD=true
+
+python_prepare_all() {
+ emake remove
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ PATH="${S}"/scripts:${PATH} \
+ nosetests --verbose || die
+}