summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-12-02 21:03:11 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-12-02 21:24:18 -0600
commit6cec5237ad9ae4e336a287b4b2f2e7c76710caa7 (patch)
tree53a3b7bf65c74c6950a005bfb73290a25c7dc4b1
parentdev-python/python-augeas: add py39 (diff)
downloadgentoo-6cec5237ad9ae4e336a287b4b2f2e7c76710caa7.tar.gz
gentoo-6cec5237ad9ae4e336a287b4b2f2e7c76710caa7.tar.bz2
gentoo-6cec5237ad9ae4e336a287b4b2f2e7c76710caa7.zip
app-crypt/certbot-apache: 1.10.0 bump
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.10.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index 7c86ae3bafc1..d66d65257c2d 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1 +1,2 @@
+DIST certbot-1.10.0.tar.gz 1432396 BLAKE2B eae502acdac712ac148a4a349b500db61a0c14fda0ae4dc57077222d33f967595c4434d0b197649c6d2614018bafaab2c7f94c1571162a200943732cc3c0109c SHA512 af31bfa1f3d6bc189d1b55ac91aab5b7fb35579170c253f0c0e98c5f63be9ad27f3ff73cb03a4f59765874c01e78ae1423f977426e081161ae5f845ebfb0d23a
DIST certbot-1.9.0.tar.gz 1425703 BLAKE2B 9bf78824649870b3e1fc3175aae551cbfaa675a8930a89f35ba2330647d86798e4fc43011c617be2d278ab20c43dd05b02e8e61956dd7f9d10d444181874346e SHA512 098d8c077f5760c1f40f7d673820488ad7643c8b9c12561a58921cd95f60ae76515cefc19f822747f3385a68eba6f49fe5484b20142994ef67a26b0b16293ce8
diff --git a/app-crypt/certbot-apache/certbot-apache-1.10.0.ebuild b/app-crypt/certbot-apache/certbot-apache-1.10.0.ebuild
new file mode 100644
index 000000000000..b7e449dda5b7
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-1.10.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-1.6.0[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"