summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Sirabella <marco@sirabella.org>2021-04-27 23:03:13 -0400
committerPatrice Clement <monsieurp@gentoo.org>2021-05-02 22:22:27 +0200
commit6cf4381cdbc342ec0583a21316c5e64f881e05c9 (patch)
tree01e7663287643b538bb450bbe751452f5a072a99
parentgames-puzzle/xwelltris: tweak for gcc-11 (diff)
downloadgentoo-6cf4381cdbc342ec0583a21316c5e64f881e05c9.tar.gz
gentoo-6cf4381cdbc342ec0583a21316c5e64f881e05c9.tar.bz2
gentoo-6cf4381cdbc342ec0583a21316c5e64f881e05c9.zip
app-vim/*: bump EAPI 5 -> 7.
Signed-off-by: Marco Sirabella <marco@sirabella.org> Closes: https://github.com/gentoo/gentoo/pull/20530 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--app-vim/align/align-43.ebuild2
-rw-r--r--app-vim/ansiesc/ansiesc-12.ebuild2
-rw-r--r--app-vim/autoalign/autoalign-14.ebuild3
-rw-r--r--app-vim/bash-support/bash-support-4.2.1.ebuild2
-rw-r--r--app-vim/c-support/c-support-6.1.1.ebuild2
-rw-r--r--app-vim/cecutil/cecutil-17.ebuild2
-rw-r--r--app-vim/cfengine-syntax/cfengine-syntax-20141019.ebuild2
-rw-r--r--app-vim/checkattach/checkattach-0.17.ebuild2
-rw-r--r--app-vim/colorschemes/colorschemes-20140623-r1.ebuild10
-rw-r--r--app-vim/colorsel/colorsel-20100406.ebuild2
-rw-r--r--app-vim/detectindent/detectindent-1.0_p20150908.ebuild2
-rw-r--r--app-vim/fuzzyfinder/fuzzyfinder-4.2.2.ebuild2
-rw-r--r--app-vim/git-patch-tags/git-patch-tags-0.2.ebuild2
-rw-r--r--app-vim/gitlog/gitlog-5.1.0.ebuild2
-rw-r--r--app-vim/gtk-syntax/gtk-syntax-20130716.ebuild2
-rw-r--r--app-vim/json/json-20150511.ebuild3
-rw-r--r--app-vim/l9/l9-1.1.ebuild2
-rw-r--r--app-vim/multiplesearch/multiplesearch-1.3.ebuild2
-rw-r--r--app-vim/nginx-syntax/nginx-syntax-0.3.3.ebuild2
-rw-r--r--app-vim/perl-support/perl-support-5.3.2.ebuild3
-rw-r--r--app-vim/perl-support/perl-support-5.4.ebuild3
-rw-r--r--app-vim/project/project-1.4.1.ebuild2
-rw-r--r--app-vim/rails/rails-5.2.ebuild3
-rw-r--r--app-vim/recover/recover-0.18.ebuild2
-rw-r--r--app-vim/repeat/repeat-1.1.ebuild3
-rw-r--r--app-vim/salt-vim/salt-vim-20151119.ebuild2
-rw-r--r--app-vim/screen/screen-1.5.ebuild3
-rw-r--r--app-vim/securemodelines/securemodelines-20140926.ebuild2
-rw-r--r--app-vim/sleuth/sleuth-1.1.ebuild2
-rw-r--r--app-vim/snipmate/snipmate-0.87-r1.ebuild3
-rw-r--r--app-vim/sudoedit/sudoedit-0.21.ebuild3
-rw-r--r--app-vim/supertab/supertab-2.1.ebuild3
-rw-r--r--app-vim/surround/surround-2.1-r1.ebuild2
-rw-r--r--app-vim/vcscommand/vcscommand-1.99.47.ebuild2
-rw-r--r--app-vim/vim-addon-mw-utils/vim-addon-mw-utils-20121105.ebuild2
-rw-r--r--app-vim/vim-misc/vim-misc-1.17.6.ebuild3
-rw-r--r--app-vim/vim-r/vim-r-1.2.6.ebuild2
-rw-r--r--app-vim/vimcommander/vimcommander-0.81.ebuild2
-rw-r--r--app-vim/yankring/yankring-19.0.ebuild2
39 files changed, 53 insertions, 44 deletions
diff --git a/app-vim/align/align-43.ebuild b/app-vim/align/align-43.ebuild
index 02b752878794..c4bba070b473 100644
--- a/app-vim/align/align-43.ebuild
+++ b/app-vim/align/align-43.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/ansiesc/ansiesc-12.ebuild b/app-vim/ansiesc/ansiesc-12.ebuild
index b45dfc4f9b25..b5e497766e89 100644
--- a/app-vim/ansiesc/ansiesc-12.ebuild
+++ b/app-vim/ansiesc/ansiesc-12.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/autoalign/autoalign-14.ebuild b/app-vim/autoalign/autoalign-14.ebuild
index ace02e79d757..15c54639ed37 100644
--- a/app-vim/autoalign/autoalign-14.ebuild
+++ b/app-vim/autoalign/autoalign-14.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
@@ -28,4 +28,5 @@ src_prepare() {
# Don't use the cecutil.vim included in the tarball, use the one
# provided by app-vim/cecutil instead.
rm plugin/cecutil.vim || die
+ default
}
diff --git a/app-vim/bash-support/bash-support-4.2.1.ebuild b/app-vim/bash-support/bash-support-4.2.1.ebuild
index f48008913875..cce06f718a9d 100644
--- a/app-vim/bash-support/bash-support-4.2.1.ebuild
+++ b/app-vim/bash-support/bash-support-4.2.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/c-support/c-support-6.1.1.ebuild b/app-vim/c-support/c-support-6.1.1.ebuild
index f9cfe8c262e4..1d7b2734f2a7 100644
--- a/app-vim/c-support/c-support-6.1.1.ebuild
+++ b/app-vim/c-support/c-support-6.1.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/cecutil/cecutil-17.ebuild b/app-vim/cecutil/cecutil-17.ebuild
index fc93400ec1dc..6901653b0850 100644
--- a/app-vim/cecutil/cecutil-17.ebuild
+++ b/app-vim/cecutil/cecutil-17.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/cfengine-syntax/cfengine-syntax-20141019.ebuild b/app-vim/cfengine-syntax/cfengine-syntax-20141019.ebuild
index 5bc129da5027..9af1ff1f0e4f 100644
--- a/app-vim/cfengine-syntax/cfengine-syntax-20141019.ebuild
+++ b/app-vim/cfengine-syntax/cfengine-syntax-20141019.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
DESCRIPTION="vim plugin: Cfengine 3 configuration files syntax"
diff --git a/app-vim/checkattach/checkattach-0.17.ebuild b/app-vim/checkattach/checkattach-0.17.ebuild
index 8e37492bd15f..c55dee6ff51d 100644
--- a/app-vim/checkattach/checkattach-0.17.ebuild
+++ b/app-vim/checkattach/checkattach-0.17.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/colorschemes/colorschemes-20140623-r1.ebuild b/app-vim/colorschemes/colorschemes-20140623-r1.ebuild
index 6293de9868d2..0d4162e15f57 100644
--- a/app-vim/colorschemes/colorschemes-20140623-r1.ebuild
+++ b/app-vim/colorschemes/colorschemes-20140623-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit edos2unix epatch vim-plugin
+inherit edos2unix vim-plugin
DESCRIPTION="vim plugin: a collection of color schemes from vim.org"
HOMEPAGE="https://www.vim.org/"
@@ -18,10 +18,8 @@ for scheme names). To automatically set a scheme at startup, please see
:help vimrc."
src_prepare() {
- EPATCH_SOURCE="${S}/patches" \
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- epatch
+ default
+ eapply -p0 "${S}"/patches/*.patch
rm -rf patches/
# fix line endings
diff --git a/app-vim/colorsel/colorsel-20100406.ebuild b/app-vim/colorsel/colorsel-20100406.ebuild
index a98a469b5b41..2ebf3f5ec76b 100644
--- a/app-vim/colorsel/colorsel-20100406.ebuild
+++ b/app-vim/colorsel/colorsel-20100406.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/detectindent/detectindent-1.0_p20150908.ebuild b/app-vim/detectindent/detectindent-1.0_p20150908.ebuild
index 48402b60c7ee..ba779e5ec0ca 100644
--- a/app-vim/detectindent/detectindent-1.0_p20150908.ebuild
+++ b/app-vim/detectindent/detectindent-1.0_p20150908.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/fuzzyfinder/fuzzyfinder-4.2.2.ebuild b/app-vim/fuzzyfinder/fuzzyfinder-4.2.2.ebuild
index 46f399bbb7bc..b1f5a9af5db8 100644
--- a/app-vim/fuzzyfinder/fuzzyfinder-4.2.2.ebuild
+++ b/app-vim/fuzzyfinder/fuzzyfinder-4.2.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/git-patch-tags/git-patch-tags-0.2.ebuild b/app-vim/git-patch-tags/git-patch-tags-0.2.ebuild
index fc3d10475db3..9048275a2eb3 100644
--- a/app-vim/git-patch-tags/git-patch-tags-0.2.ebuild
+++ b/app-vim/git-patch-tags/git-patch-tags-0.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/gitlog/gitlog-5.1.0.ebuild b/app-vim/gitlog/gitlog-5.1.0.ebuild
index 55e58752e730..fe95f8f1921a 100644
--- a/app-vim/gitlog/gitlog-5.1.0.ebuild
+++ b/app-vim/gitlog/gitlog-5.1.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
DESCRIPTION="vim plugin: git log and diff plugin for vim"
diff --git a/app-vim/gtk-syntax/gtk-syntax-20130716.ebuild b/app-vim/gtk-syntax/gtk-syntax-20130716.ebuild
index 601005bf2004..b498994c9d19 100644
--- a/app-vim/gtk-syntax/gtk-syntax-20130716.ebuild
+++ b/app-vim/gtk-syntax/gtk-syntax-20130716.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/json/json-20150511.ebuild b/app-vim/json/json-20150511.ebuild
index 945e149aa0e4..efdbe9a258ce 100644
--- a/app-vim/json/json-20150511.ebuild
+++ b/app-vim/json/json-20150511.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
@@ -12,4 +12,5 @@ KEYWORDS="amd64 x86"
src_prepare() {
rm *-test.* license.md || die
+ default
}
diff --git a/app-vim/l9/l9-1.1.ebuild b/app-vim/l9/l9-1.1.ebuild
index 9bee66275216..53007dd4fe07 100644
--- a/app-vim/l9/l9-1.1.ebuild
+++ b/app-vim/l9/l9-1.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/multiplesearch/multiplesearch-1.3.ebuild b/app-vim/multiplesearch/multiplesearch-1.3.ebuild
index 107274f07b15..61ba9db3859f 100644
--- a/app-vim/multiplesearch/multiplesearch-1.3.ebuild
+++ b/app-vim/multiplesearch/multiplesearch-1.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/nginx-syntax/nginx-syntax-0.3.3.ebuild b/app-vim/nginx-syntax/nginx-syntax-0.3.3.ebuild
index 44bdb0ebfa04..89bac4a26854 100644
--- a/app-vim/nginx-syntax/nginx-syntax-0.3.3.ebuild
+++ b/app-vim/nginx-syntax/nginx-syntax-0.3.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/perl-support/perl-support-5.3.2.ebuild b/app-vim/perl-support/perl-support-5.3.2.ebuild
index 9950764795c4..03d23b7e14cf 100644
--- a/app-vim/perl-support/perl-support-5.3.2.ebuild
+++ b/app-vim/perl-support/perl-support-5.3.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
DESCRIPTION="vim plugin: Perl-IDE - Write and run Perl scripts using menus and hotkeys"
@@ -18,6 +18,7 @@ RDEPEND="
src_prepare() {
# Don't set tabstop and shiftwidth
sed -i '/=4/s/^/"/' ftplugin/perl.vim || die
+ default
}
src_install() {
diff --git a/app-vim/perl-support/perl-support-5.4.ebuild b/app-vim/perl-support/perl-support-5.4.ebuild
index 6ff67a56f557..b36b555f7000 100644
--- a/app-vim/perl-support/perl-support-5.4.ebuild
+++ b/app-vim/perl-support/perl-support-5.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
DESCRIPTION="vim plugin: Perl-IDE - Write and run Perl scripts using menus and hotkeys"
@@ -23,6 +23,7 @@ S="${WORKDIR}/${PN}-version-${PV}"
src_prepare() {
# Don't set tabstop and shiftwidth
sed -i '/=4/s/^/"/' ftplugin/perl.vim || die
+ default
}
src_install() {
diff --git a/app-vim/project/project-1.4.1.ebuild b/app-vim/project/project-1.4.1.ebuild
index b90a25189c63..e1880f059a45 100644
--- a/app-vim/project/project-1.4.1.ebuild
+++ b/app-vim/project/project-1.4.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/rails/rails-5.2.ebuild b/app-vim/rails/rails-5.2.ebuild
index 10a6335781c2..0cc49294e6d4 100644
--- a/app-vim/rails/rails-5.2.ebuild
+++ b/app-vim/rails/rails-5.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
@@ -20,4 +20,5 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
rm *.markdown || die
+ default
}
diff --git a/app-vim/recover/recover-0.18.ebuild b/app-vim/recover/recover-0.18.ebuild
index 7512b666fb1b..f9b860a56571 100644
--- a/app-vim/recover/recover-0.18.ebuild
+++ b/app-vim/recover/recover-0.18.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
DESCRIPTION="vim plugin: show differences for recovered files"
diff --git a/app-vim/repeat/repeat-1.1.ebuild b/app-vim/repeat/repeat-1.1.ebuild
index c2506991860e..7ef2b6215c1f 100644
--- a/app-vim/repeat/repeat-1.1.ebuild
+++ b/app-vim/repeat/repeat-1.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
@@ -18,4 +18,5 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
rm *.markdown || die
+ default
}
diff --git a/app-vim/salt-vim/salt-vim-20151119.ebuild b/app-vim/salt-vim/salt-vim-20151119.ebuild
index c063d7676013..b5584b455255 100644
--- a/app-vim/salt-vim/salt-vim-20151119.ebuild
+++ b/app-vim/salt-vim/salt-vim-20151119.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/screen/screen-1.5.ebuild b/app-vim/screen/screen-1.5.ebuild
index 1dfb67f9091b..d1ca61950c77 100644
--- a/app-vim/screen/screen-1.5.ebuild
+++ b/app-vim/screen/screen-1.5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin vcs-snapshot
@@ -18,4 +18,5 @@ RDEPEND="|| ( app-misc/screen app-misc/tmux )"
src_prepare() {
rm README || die
+ default
}
diff --git a/app-vim/securemodelines/securemodelines-20140926.ebuild b/app-vim/securemodelines/securemodelines-20140926.ebuild
index 7ab9e570dfde..8a417ec2e236 100644
--- a/app-vim/securemodelines/securemodelines-20140926.ebuild
+++ b/app-vim/securemodelines/securemodelines-20140926.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
DESCRIPTION="vim plugin: secure, user-configurable modeline support"
diff --git a/app-vim/sleuth/sleuth-1.1.ebuild b/app-vim/sleuth/sleuth-1.1.ebuild
index f3ba9c8c9560..4d001af564f0 100644
--- a/app-vim/sleuth/sleuth-1.1.ebuild
+++ b/app-vim/sleuth/sleuth-1.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/snipmate/snipmate-0.87-r1.ebuild b/app-vim/snipmate/snipmate-0.87-r1.ebuild
index 4397b174c5a4..51acbd7d6983 100644
--- a/app-vim/snipmate/snipmate-0.87-r1.ebuild
+++ b/app-vim/snipmate/snipmate-0.87-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
@@ -26,4 +26,5 @@ VIM_PLUGIN_MESSAGES="filetype"
src_prepare() {
rm addon-info.json || die
+ default
}
diff --git a/app-vim/sudoedit/sudoedit-0.21.ebuild b/app-vim/sudoedit/sudoedit-0.21.ebuild
index c2dac75eec6a..9f298e3eff3e 100644
--- a/app-vim/sudoedit/sudoedit-0.21.ebuild
+++ b/app-vim/sudoedit/sudoedit-0.21.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
@@ -16,4 +16,5 @@ RDEPEND="|| ( app-admin/sudo sys-apps/shadow )"
src_prepare() {
# remove unused windows related files
rm autoload/{sudo.cmd,SudoEdit.vbs} || die
+ default
}
diff --git a/app-vim/supertab/supertab-2.1.ebuild b/app-vim/supertab/supertab-2.1.ebuild
index cef7dfb0d3db..8f0cb83ec498 100644
--- a/app-vim/supertab/supertab-2.1.ebuild
+++ b/app-vim/supertab/supertab-2.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
inherit vim-plugin
@@ -15,4 +15,5 @@ VIM_PLUGIN_HELPFILES="${PN}.txt"
src_prepare() {
rm Makefile .gitignore || die
+ default
}
diff --git a/app-vim/surround/surround-2.1-r1.ebuild b/app-vim/surround/surround-2.1-r1.ebuild
index c74a7ec85aeb..13e9d2e108c9 100644
--- a/app-vim/surround/surround-2.1-r1.ebuild
+++ b/app-vim/surround/surround-2.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/vcscommand/vcscommand-1.99.47.ebuild b/app-vim/vcscommand/vcscommand-1.99.47.ebuild
index 4fb0a58bc0a0..fab405141aee 100644
--- a/app-vim/vcscommand/vcscommand-1.99.47.ebuild
+++ b/app-vim/vcscommand/vcscommand-1.99.47.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/vim-addon-mw-utils/vim-addon-mw-utils-20121105.ebuild b/app-vim/vim-addon-mw-utils/vim-addon-mw-utils-20121105.ebuild
index e1a865ff200a..1bdd624d46a8 100644
--- a/app-vim/vim-addon-mw-utils/vim-addon-mw-utils-20121105.ebuild
+++ b/app-vim/vim-addon-mw-utils/vim-addon-mw-utils-20121105.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/vim-misc/vim-misc-1.17.6.ebuild b/app-vim/vim-misc/vim-misc-1.17.6.ebuild
index 10ce26e479ee..43180c27bd2e 100644
--- a/app-vim/vim-misc/vim-misc-1.17.6.ebuild
+++ b/app-vim/vim-misc/vim-misc-1.17.6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
@@ -15,4 +15,5 @@ VIM_PLUGIN_HELPFILES="misc.txt"
src_prepare() {
rm INSTALL.md addon-info.json autoload/xolox/misc/echo.exe || die
+ default
}
diff --git a/app-vim/vim-r/vim-r-1.2.6.ebuild b/app-vim/vim-r/vim-r-1.2.6.ebuild
index c02b63c38175..5f14e094b4c2 100644
--- a/app-vim/vim-r/vim-r-1.2.6.ebuild
+++ b/app-vim/vim-r/vim-r-1.2.6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
diff --git a/app-vim/vimcommander/vimcommander-0.81.ebuild b/app-vim/vimcommander/vimcommander-0.81.ebuild
index 1033bee83c87..88837cdb1d98 100644
--- a/app-vim/vimcommander/vimcommander-0.81.ebuild
+++ b/app-vim/vimcommander/vimcommander-0.81.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
DESCRIPTION="vim plugin: Total Commander style file explorer"
diff --git a/app-vim/yankring/yankring-19.0.ebuild b/app-vim/yankring/yankring-19.0.ebuild
index 5f82da839157..71a8fd7d17f1 100644
--- a/app-vim/yankring/yankring-19.0.ebuild
+++ b/app-vim/yankring/yankring-19.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vim-plugin
DESCRIPTION="vim plugin: maintains a history of previous yanks and deletes"