summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2017-05-25 18:14:38 +0100
committerIan Whyman <thev00d00@gentoo.org>2017-05-25 18:15:03 +0100
commit6d815a82e3868fe52c56b8cb15b32ee79bd74aec (patch)
tree1fe8d46fc951d5bf20b3cda9880f7eb49419acc6
parentapp-emulation/docker-machine-kvm: version bump to 0.10.0 (diff)
downloadgentoo-6d815a82e3868fe52c56b8cb15b32ee79bd74aec.tar.gz
gentoo-6d815a82e3868fe52c56b8cb15b32ee79bd74aec.tar.bz2
gentoo-6d815a82e3868fe52c56b8cb15b32ee79bd74aec.zip
net-libs/libupnp: Version bump to 1.8.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--net-libs/libupnp/Manifest1
-rw-r--r--net-libs/libupnp/libupnp-1.8.1.ebuild47
-rw-r--r--net-libs/libupnp/metadata.xml3
3 files changed, 51 insertions, 0 deletions
diff --git a/net-libs/libupnp/Manifest b/net-libs/libupnp/Manifest
index 0a49354fa3c5..ac896552ba33 100644
--- a/net-libs/libupnp/Manifest
+++ b/net-libs/libupnp/Manifest
@@ -1,2 +1,3 @@
DIST libupnp-1.6.21.tar.bz2 1245353 SHA256 af3f3c0846a1d75baeadae4aa5a2bda427567e2a1fb4559bf73ccff0a4f9a39b SHA512 65a2989497b941dfa1f7ac09fe44267de4a5231af25a304f0f6e754c7cbb578bdcb3c500188b5ebfbff9f579099db7501817d45e1724ef8e384d6d918bcdcdeb WHIRLPOOL b4869189054ac00d57394e0919ad2f672af64f2c2b0ecc676c2b3fc4a3c22caa25ac38b57bbb5cf1ef12a5857b4cdfd450c6bd5955a5eacaf8bdf95a058c9dab
DIST libupnp-1.8.0.tar.gz 1380524 SHA256 1ddfb4e12e947deb5637e0d5e09bbe7835dfc8fb8a57712346026afa029165b1 SHA512 e2ae54352d747191f3ffc15c50481da515665fb35ddf6a9e488b6e1962e47803937bf078d0c2c5d56f8339cfd226ffba7433975363dc312e484ed22f83eda061 WHIRLPOOL c3d4abf54d25e87a1d650a18c475097a47633e8bf7691248695a7682ecff8aca4419c8eb2db4d24d62ca5a7905321971adf924166c20876ee18dd32d846748a1
+DIST libupnp-1.8.1.tar.gz 1363979 SHA256 0569e6afd979baa4e533312cb682394cea5b2638b8b412623e28943103593ea0 SHA512 7dd90f0c0332e7171d96a37a50223e18d5325ac1dd8dbe04fadac4655ad7c4d8443c52f904aaa35d3f12d2abd9ee2690ba990d0a93b15cbebb4d3de35d25ffe4 WHIRLPOOL 184e8844fab6a7a04d902d77c9b28141cdb15e4026b1b45105aabcf7616c2f6bbffa81fe14a1e6ddcd3f6494d9505f8f2cf190bf00fa341ca7192668e46e732d
diff --git a/net-libs/libupnp/libupnp-1.8.1.ebuild b/net-libs/libupnp/libupnp-1.8.1.ebuild
new file mode 100644
index 000000000000..46ecf1920723
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic autotools vcs-snapshot
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/mrjimenez/pupnp/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1.8"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
+IUSE="debug doc reuseaddr ipv6 static-libs"
+
+DOCS="NEWS README.md ChangeLog"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.0-docs-install.patch
+ "${FILESDIR}"/${PN}-1.6.21-cflags.patch
+)
+
+src_prepare() {
+ default
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable reuseaddr) \
+ $(use_enable static-libs static) \
+ $(use_with doc documentation "${EPREFIX}/usr/share/doc/${PF}")
+}
+
+src_install () {
+ default
+ dobin upnp/sample/.libs/tv_{combo,ctrlpt,device}-1.8
+ use static-libs || prune_libtool_files
+}
diff --git a/net-libs/libupnp/metadata.xml b/net-libs/libupnp/metadata.xml
index 108d54853cfa..4c6479b76fb7 100644
--- a/net-libs/libupnp/metadata.xml
+++ b/net-libs/libupnp/metadata.xml
@@ -13,4 +13,7 @@
<remote-id type="sourceforge">pupnp</remote-id>
<remote-id type="github">mrjimenez/pupnp</remote-id>
</upstream>
+ <use>
+ <flag name="reuseaddr">Allow clean restarts by binding the socket with SO_REUSEADDR.</flag>
+ </use>
</pkgmetadata>