summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-08-01 14:22:56 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-01 14:24:14 +0200
commit6d8908533b9be01de026a18cdb5d25e5ca0e6279 (patch)
tree8738618543d4cf8ba9c2508532156fa0a87c4dc1
parentdev-python/pypy3-bin: Fix reenabling byte-compilation for tests (diff)
downloadgentoo-6d8908533b9be01de026a18cdb5d25e5ca0e6279.tar.gz
gentoo-6d8908533b9be01de026a18cdb5d25e5ca0e6279.tar.bz2
gentoo-6d8908533b9be01de026a18cdb5d25e5ca0e6279.zip
dev-python/pypy3: Fix reenabling byte-compilation for tests
-rw-r--r--dev-python/pypy3/pypy3-6.0.0.ebuild4
-rw-r--r--dev-python/pypy3/pypy3-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/pypy3/pypy3-6.0.0.ebuild b/dev-python/pypy3/pypy3-6.0.0.ebuild
index 71af571b4767..d32be15922b2 100644
--- a/dev-python/pypy3/pypy3-6.0.0.ebuild
+++ b/dev-python/pypy3/pypy3-6.0.0.ebuild
@@ -193,11 +193,11 @@ src_compile() {
src_test() {
# (unset)
- local -x PYTHONDONTWRITEBYTECODE
+ local -x PYTHONDONTWRITEBYTECODE=
# Test runner requires Python 2 too. However, it spawns PyPy3
# internally so that we end up testing the correct interpreter.
- "${PYTHON}" ./pypy/test_all.py --pypy=./pypy3-c lib-python || die
+ "${PYTHON}" ./pypy/test_all.py --pypy=./pypy3-c -vv lib-python || die
}
src_install() {
diff --git a/dev-python/pypy3/pypy3-9999.ebuild b/dev-python/pypy3/pypy3-9999.ebuild
index 61b32ea2ad54..9aabe19e3d37 100644
--- a/dev-python/pypy3/pypy3-9999.ebuild
+++ b/dev-python/pypy3/pypy3-9999.ebuild
@@ -220,11 +220,11 @@ src_compile() {
src_test() {
# (unset)
- local -x PYTHONDONTWRITEBYTECODE
+ local -x PYTHONDONTWRITEBYTECODE=
# Test runner requires Python 2 too. However, it spawns PyPy3
# internally so that we end up testing the correct interpreter.
- "${PYTHON}" ./pypy/test_all.py --pypy=./pypy3-c lib-python || die
+ "${PYTHON}" ./pypy/test_all.py --pypy=./pypy3-c -vv lib-python || die
}
src_install() {