summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcharIes17 <charles17@arcor.de>2018-01-28 13:15:56 +0100
committerAaron Bauman <bman@gentoo.org>2018-03-26 20:42:43 -0400
commit6e1cbbcb7f0a6519abee5907397e1a0b9c69847e (patch)
treebdc608e7a670219cf158a30cf9b5e9e2b526899e
parentlxde-base/lxinput: Remove old (diff)
downloadgentoo-6e1cbbcb7f0a6519abee5907397e1a0b9c69847e.tar.gz
gentoo-6e1cbbcb7f0a6519abee5907397e1a0b9c69847e.tar.bz2
gentoo-6e1cbbcb7f0a6519abee5907397e1a0b9c69847e.zip
lxde-base/lxtask: Add locale handling
Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6984
-rw-r--r--lxde-base/lxtask/lxtask-0.1.8-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/lxde-base/lxtask/lxtask-0.1.8-r1.ebuild b/lxde-base/lxtask/lxtask-0.1.8-r1.ebuild
new file mode 100644
index 000000000000..f1ff7f5f7f0b
--- /dev/null
+++ b/lxde-base/lxtask/lxtask-0.1.8-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="af ar ast be bg bn_IN bn ca cs da de el en_GB es et eu fa fi fo fr
+frp gl he hr hu id is it ja kk ko lg lt lv ml ms nb nl nn pa pl ps pt_BR pt
+ro ru sk sl sq sr@latin sr sv te th tr tt_RU ug uk ur_PK ur vi zh_CN zh_TW"
+
+PLOCALE_BACKUP="en_GB"
+
+inherit l10n
+
+DESCRIPTION="LXDE Task manager"
+HOMEPAGE="https://wiki.lxde.org/en/LXTask"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~x86 ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0"
+
+# Upstream report:
+# https://sourceforge.net/p/lxde/patches/535/
+PATCHES=( "${FILESDIR}/lxtask-0.1.7-fix-no-common.patch" )
+
+src_prepare() {
+ default
+
+ export LINGUAS="${LINGUAS:-${PLOCALE_BACKUP}}"
+ l10n_get_locales > po/LINGUAS || die
+}