summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-18 11:00:25 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-18 11:02:25 +0200
commit6ea9470676bacc347d31dab732777b41f7b33d21 (patch)
treede15e19d4101f873b18557253fee74c55c57b913
parentdev-cpp/gccxml: Remove last-rited pkg (diff)
downloadgentoo-6ea9470676bacc347d31dab732777b41f7b33d21.tar.gz
gentoo-6ea9470676bacc347d31dab732777b41f7b33d21.tar.bz2
gentoo-6ea9470676bacc347d31dab732777b41f7b33d21.zip
dev-libs/quantlib: Remove last-rited pkg
Closes: https://bugs.gentoo.org/629984 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-libs/quantlib/Manifest1
-rw-r--r--dev-libs/quantlib/files/50quantlib-gentoo.el6
-rw-r--r--dev-libs/quantlib/metadata.xml12
-rw-r--r--dev-libs/quantlib/quantlib-1.7.1.ebuild92
-rw-r--r--profiles/package.mask8
5 files changed, 0 insertions, 119 deletions
diff --git a/dev-libs/quantlib/Manifest b/dev-libs/quantlib/Manifest
deleted file mode 100644
index 306c2ca499a8..000000000000
--- a/dev-libs/quantlib/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST QuantLib-1.7.1.tar.gz 8715844 BLAKE2B 0193f1b6d73d66b148840671b7321e926a81a3eec2d1ded3a3398e9531c71cdb12454e059960b7707c9383bedddd136ab92e2550bdda265c54b0cf26d904b972 SHA512 8ba4fdb219b2886b448dbc6370ce6acec9f919a6baf7e8275a76ba13e0bf2d08cbb88cd5a3e450bcf379c17bd0492a9259483089de65e24b95d708f259bc30a7
diff --git a/dev-libs/quantlib/files/50quantlib-gentoo.el b/dev-libs/quantlib/files/50quantlib-gentoo.el
deleted file mode 100644
index 68f6ce003295..000000000000
--- a/dev-libs/quantlib/files/50quantlib-gentoo.el
+++ /dev/null
@@ -1,6 +0,0 @@
-
-;;; quantlib site-lisp configuration
-
-(add-to-list 'load-path "@SITELISP@")
-(autoload 'ql-new-header "quantlib" nil t)
-(autoload 'ql-new-source "quantlib" nil t)
diff --git a/dev-libs/quantlib/metadata.xml b/dev-libs/quantlib/metadata.xml
deleted file mode 100644
index 7099f55d0871..000000000000
--- a/dev-libs/quantlib/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription>
-QuantLib (http://quantlib.org/) is a C++ library for financial
-quantitative analysts and developers.
-</longdescription>
- <upstream>
- <remote-id type="sourceforge">quantlib</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-libs/quantlib/quantlib-1.7.1.ebuild b/dev-libs/quantlib/quantlib-1.7.1.ebuild
deleted file mode 100644
index 763269d2f604..000000000000
--- a/dev-libs/quantlib/quantlib-1.7.1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit elisp-common eutils toolchain-funcs
-
-MY_P="QuantLib-${PV}"
-
-DESCRIPTION="A comprehensive software framework for quantitative finance"
-HOMEPAGE="https://quantlib.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc emacs examples openmp static-libs"
-
-RDEPEND="dev-libs/boost:="
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )
- emacs? ( virtual/emacs )"
-
-DOCS="*.txt"
-
-S="${WORKDIR}/${MY_P}"
-
-SITEFILE="50${PN}-gentoo.el"
-
-pkg_setup() {
- if use openmp ; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
- fi
-}
-
-src_configure() {
- # NOTE: Too fragile for single .pdf or .ps document
- local prog
- for prog in DVIPS LATEX MAKEINDEX PDFLATEX; do
- export ac_cv_path_${prog}=no
- done
-
- use doc || export ac_cv_path_DOXYGEN=no
- use emacs || export ac_cv_prog_EMACS=no
-
- # NOTE: --enable-examples will only change noinst_PROGRAMS to bin_PROGRAMS
- econf \
- $(use_enable debug error-functions) \
- $(use_enable debug error-lines) \
- $(use_enable debug tracing) \
- $(use_enable openmp) \
- $(use_enable static-libs static) \
- --enable-examples \
- --with-lispdir="${SITELISP}/${PN}"
-}
-
-src_compile() {
- default
-
- if use doc; then
- pushd Docs >/dev/null
- emake docs-html
- popd >/dev/null
- fi
-}
-
-src_install(){
- default
- prune_libtool_files
-
- if use doc; then
- find Docs \( -name '.time-stamp*' -o -name '*.doxy' -o -name 'Makefile*' \) -delete || die
- dodoc -r Docs
- fi
-
- if use examples; then
- find Examples -name '.libs' -exec rm -rf {} + || die
- find Examples \( -name '*vc*proj*' -o -name '*.dev' -o -name 'Makefile*' -o -name '*.o' \) -delete || die
- insinto "/usr/share/doc/${PF}"
- doins -r Examples
- fi
-
- use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index afd4ae746637..c8bee229bb88 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -440,14 +440,6 @@ dev-libs/xqilla
dev-cpp/rudiments
# Michał Górny <mgorny@gentoo.org> (18 Apr 2019)
-# Unmaintained. The current version does not build with modern versions
-# of dev-libs/boost. It is multiple releases behind upstream (1900
-# commits according to GitHub). With the pace of upstream development,
-# it really needs a dedicated maintainer.
-# Removal in 30 days. Bug #629984.
-dev-libs/quantlib
-
-# Michał Górny <mgorny@gentoo.org> (18 Apr 2019)
# All current versions of SystemRescueCD contain vulnerable packages.
# Bug #683724.
app-admin/systemrescuecd-x86