summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-07-07 09:37:04 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-07-07 09:37:18 +0100
commit6ef4f8fa1b9af1dbf9beefd23eecd25136064430 (patch)
tree80b5b5bb7fc57490af54632455406e77db395968
parentnet-analyzer/scanssh: Fix libdir checks (diff)
downloadgentoo-6ef4f8fa1b9af1dbf9beefd23eecd25136064430.tar.gz
gentoo-6ef4f8fa1b9af1dbf9beefd23eecd25136064430.tar.bz2
gentoo-6ef4f8fa1b9af1dbf9beefd23eecd25136064430.zip
app-misc/mc: bump up to 4.8.25-rc1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--app-misc/mc/Manifest1
-rw-r--r--app-misc/mc/mc-4.8.25_rc1.ebuild103
-rw-r--r--app-misc/mc/mc-9999.ebuild4
3 files changed, 105 insertions, 3 deletions
diff --git a/app-misc/mc/Manifest b/app-misc/mc/Manifest
index 78cdde68001e..bb187789095d 100644
--- a/app-misc/mc/Manifest
+++ b/app-misc/mc/Manifest
@@ -1 +1,2 @@
DIST mc-4.8.24.tar.xz 2434988 BLAKE2B 18bd730d5bfbad19fa5e70fb578cf587a3df8da33885543b3d316548ac0d29bd67e4683d32b2751471e148e89390c7658edb622fd741eae054b7fae774996b60 SHA512 ec9e40198455e7001bb1d06ea060b9b4c32ad3a3750d0cc9bac334b53eb666df1746335bfcd411213fa4386b23e516f6026fe3d74ad9119b2340b26c63ccd4fc
+DIST mc-4.8.25_rc1.tar.xz 2487732 BLAKE2B 18bbff9e44bdd2996e5e4dc44389167a90798bc03098850f3df70b8451951e95f66fdd58416e9f44289e072729d4217be7ecf20e65fb4f507e44669d76c13589 SHA512 61e21d905dd28ea732d62c75cb5a18e67f90c7c85376ceb2240089ff7b5d724bcf2cb7de4d89709a44b795cdcbbf123648a302552bd370972e23f0967a3a1353
diff --git a/app-misc/mc/mc-4.8.25_rc1.ebuild b/app-misc/mc/mc-4.8.25_rc1.ebuild
new file mode 100644
index 000000000000..563e47b602e1
--- /dev/null
+++ b/app-misc/mc/mc-4.8.25_rc1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic vcs-snapshot
+
+DESCRIPTION="GNU Midnight Commander is a text based file manager"
+HOMEPAGE="https://www.midnight-commander.org"
+#SRC_URI="http://ftp.midnight-commander.org/${P}.tar.xz"
+SRC_URI="https://www.midnight-commander.org/nopaste/tarball/mc-4.8.24-163-g171957980.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="+edit gpm nls samba sftp +slang spell test unicode X +xdg"
+
+REQUIRED_USE="spell? ( edit )"
+
+RDEPEND=">=dev-libs/glib-2.26.0:2
+ gpm? ( sys-libs/gpm )
+ kernel_linux? ( sys-fs/e2fsprogs )
+ samba? ( net-fs/samba )
+ sftp? ( net-libs/libssh2 )
+ slang? ( >=sys-libs/slang-2 )
+ !slang? ( sys-libs/ncurses:0=[unicode?] )
+ spell? ( app-text/aspell )
+ X? ( x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libSM )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( dev-libs/check )
+ "
+
+RESTRICT="!test? ( test )"
+
+pkg_pretend() {
+ if use slang && use unicode ; then
+ ewarn "\"unicode\" USE flag only takes effect when the \"slang\" USE flag is disabled."
+ fi
+}
+
+src_configure() {
+ [[ ${CHOST} == *-solaris* ]] && append-ldflags "-lnsl -lsocket"
+
+ local myeconfargs=(
+ --enable-charset
+ --enable-vfs
+ --with-homedir=$(usex xdg 'XDG' '.mc')
+ --with-screen=$(usex slang 'slang' "ncurses$(usex unicode 'w' '')")
+ $(use_enable kernel_linux vfs-undelfs)
+ # Today mclib does not expose any headers and is linked to
+ # single 'mc' binary. Thus there is no advantage of having
+ # a library. Let's avoid shared library altogether
+ # as it also conflicts with sci-libs/mc: bug #685938
+ --disable-mclib
+ $(use_enable nls)
+ $(use_enable samba vfs-smb)
+ $(use_enable sftp vfs-sftp)
+ $(use_enable spell aspell)
+ $(use_enable test tests)
+ $(use_with gpm gpm-mouse)
+ $(use_with X x)
+ $(use_with edit internal-edit)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # CK_FORK=no to avoid using fork() in check library
+ # as mc mocks fork() itself: bug #644462.
+ #
+ # VERBOSE=1 to make test failures contain detailed
+ # information.
+ CK_FORK=no emake check VERBOSE=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README NEWS
+
+ # fix bug #334383
+ if use kernel_linux && [[ ${EUID} == 0 ]] ; then
+ fowners root:tty /usr/libexec/mc/cons.saver
+ fperms g+s /usr/libexec/mc/cons.saver
+ fi
+
+ if ! use xdg ; then
+ sed 's@MC_XDG_OPEN="xdg-open"@MC_XDG_OPEN="/bin/false"@' \
+ -i "${ED}"/usr/libexec/mc/ext.d/*.sh || die
+ fi
+}
+
+pkg_postinst() {
+ elog "To enable exiting to latest working directory,"
+ elog "put this into your ~/.bashrc:"
+ elog ". ${EPREFIX}/usr/libexec/mc/mc.sh"
+}
diff --git a/app-misc/mc/mc-9999.ebuild b/app-misc/mc/mc-9999.ebuild
index 35e12355b85a..1220ef65dda6 100644
--- a/app-misc/mc/mc-9999.ebuild
+++ b/app-misc/mc/mc-9999.ebuild
@@ -11,10 +11,8 @@ fi
inherit flag-o-matic ${LIVE_ECLASSES}
-MY_P=${P/_/-}
-
if [[ -z ${LIVE_EBUILD} ]]; then
- SRC_URI="http://ftp.midnight-commander.org/${MY_P}.tar.xz"
+ SRC_URI="http://ftp.midnight-commander.org/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
fi