summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-30 09:38:22 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-30 10:08:00 +0200
commit711fdac7455b9bcb562367275b40f133bcfa787b (patch)
treef3997e1d604ed8127a10e8d0cdd4ff96c545745f
parentdev-python/pbkdf2: Enable py3.7 (diff)
downloadgentoo-711fdac7455b9bcb562367275b40f133bcfa787b.tar.gz
gentoo-711fdac7455b9bcb562367275b40f133bcfa787b.tar.bz2
gentoo-711fdac7455b9bcb562367275b40f133bcfa787b.zip
dev-python/pbkdf2: Bump to EAPI 7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pbkdf2/pbkdf2-1.3-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pbkdf2/pbkdf2-1.3-r1.ebuild b/dev-python/pbkdf2/pbkdf2-1.3-r1.ebuild
new file mode 100644
index 000000000000..0a5ba8456983
--- /dev/null
+++ b/dev-python/pbkdf2/pbkdf2-1.3-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Implementation of PBKDF2, specified in RSA PKCS#5 v2.0"
+HOMEPAGE="https://www.dlitz.net/software/python-pbkdf2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+python_test() {
+ "${EPYTHON}" test/test_pbkdf2.py -v || die "Tests failed with ${EPYTHON}"
+}