summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-09 13:56:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-09 14:56:26 +0100
commit715abf4929939c52b3fa57c8bdd8669b35794120 (patch)
treebc2f9a818bf6db7f8ff0584e05103067db82fb6c
parentdev-python/boto3: Bump to 1.26.26 (diff)
downloadgentoo-715abf4929939c52b3fa57c8bdd8669b35794120.tar.gz
gentoo-715abf4929939c52b3fa57c8bdd8669b35794120.tar.bz2
gentoo-715abf4929939c52b3fa57c8bdd8669b35794120.zip
app-admin/awscli: Bump to 1.27.26
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.26.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 446f919c429d..c74d2158a6cd 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -7,4 +7,5 @@ DIST aws-cli-1.27.22.gh.tar.gz 2317454 BLAKE2B b926d1e62dbea9bb2790881838dfe6e67
DIST aws-cli-1.27.23.gh.tar.gz 2318518 BLAKE2B eb04dd0f7b1ea803246c00c4dede6662af5c62918276f41b65a63ddeddf4509ffe198309f62748da7fd41fefc4a26861275e1a03d367486ee496ed84d5367ad4 SHA512 b78c75ffff12f730863290f2cf0c568a5e4ff27a4761339ca32321cbd1693984c6b80dccf0c12e4d6f103cb64caf2ea6ad3aa780b39b092d62225850a6273d7d
DIST aws-cli-1.27.24.gh.tar.gz 2319169 BLAKE2B 6677fc6d09298fc37d5aae5e9b4addc87ec873f765b59b55759c0e1dd0c65ab49234c8a8f8f979be4f4cd1361033e8e142568136e5024408dc5c839f34480274 SHA512 29d8956b665531ee3d5451fbb063f7393978f223e379fed0a61304cb6798241325191bd5ea9f76531c7009b8b0e32c849a0c4a445508751518ce33631ce6a9cd
DIST aws-cli-1.27.25.gh.tar.gz 2319262 BLAKE2B 1207b7879a82c538be9d1ee3dc8a69f20c6334afdd8d35c63ca3d44f264316680aa4d7d01b19a216ca2693748977b83851a2b75f1fd55b85989f2749ab05e827 SHA512 e46f684b219d0bce61ffae0737b2c485a4fb359b7e3ad3ef6180d5378daa49bb049033073594c63f44150266041b4a78634aced1a34fc98f08f0ca8e371558e2
+DIST aws-cli-1.27.26.gh.tar.gz 2319897 BLAKE2B 65307b3c63656b751ad3d96ca6ffdb2e9778cdb11cb35c730dc22dad83ee4b0e1cb37afc4d1de7b2c1cbbabd4622610fc2385e7dbc21cfa2c9833a36d693b1ff SHA512 508f8ae1abe037786c3ee35204f4c84fb06bb7bb8471d75217bf914cf7c9aea897cbecb364554f8b39c75001769c894ede7a1b06dd761187aff468f19001708f
DIST aws-cli-1.27.8.gh.tar.gz 2301766 BLAKE2B 1873d92b8d2f6d3f29a65b4177927a1a14034da71dbc95ff6abf3f49df6cf3ee192412eeea15be14c8cf9fca0a5603f2c76b80b280f4feb95e661055abcd8b60 SHA512 e53828cac1b3e10e2ddd45312d71cdb748216dbc37c3e9833e7a1320b236c3bef6a13204a38b946d9182430f169fca1ddc77d3d06c1c2c6e05978dc61f675168
diff --git a/app-admin/awscli/awscli-1.27.26.ebuild b/app-admin/awscli/awscli-1.27.26.ebuild
new file mode 100644
index 000000000000..9bcb01ac11e2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.26.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}