summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-12-18 12:55:42 -0500
committerMike Gilbert <floppym@gentoo.org>2016-12-18 12:57:00 -0500
commit7227f36b72ddcbc3c308af06768f367e0b447be2 (patch)
tree0be6266d83ed8b554b209c17356bd50190cf5838
parentapp-misc/rl: clean up old. (diff)
downloadgentoo-7227f36b72ddcbc3c308af06768f367e0b447be2.tar.gz
gentoo-7227f36b72ddcbc3c308af06768f367e0b447be2.tar.bz2
gentoo-7227f36b72ddcbc3c308af06768f367e0b447be2.zip
net-p2p/transmission: add optional PolarSSL support
Package-Manager: Portage-2.3.3_p7, Repoman-2.3.1
-rw-r--r--net-p2p/transmission/metadata.xml1
-rw-r--r--net-p2p/transmission/transmission-9999.ebuild11
2 files changed, 8 insertions, 4 deletions
diff --git a/net-p2p/transmission/metadata.xml b/net-p2p/transmission/metadata.xml
index 056a427f1f74..35f2bcf40c90 100644
--- a/net-p2p/transmission/metadata.xml
+++ b/net-p2p/transmission/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="lightweight">Optimize transmission for low-resource systems (smaller cache size, prefer unencrypted peer connections, etc.)</flag>
+ <flag name="polarssl">Use PolarSSL instead of OpenSSL</flag>
<flag name="xfs">Enable XFS filesystem capabilities by using <pkg>sys-fs/xfsprogs</pkg> headers (in building of fdlimit(.c))</flag>
</use>
</pkgmetadata>
diff --git a/net-p2p/transmission/transmission-9999.ebuild b/net-p2p/transmission/transmission-9999.ebuild
index 90966d2910ab..ade845a55796 100644
--- a/net-p2p/transmission/transmission-9999.ebuild
+++ b/net-p2p/transmission/transmission-9999.ebuild
@@ -33,13 +33,16 @@ HOMEPAGE="https://transmissionbt.com/"
# MIT is in several libtransmission/ headers
LICENSE="|| ( GPL-2 GPL-3 Transmission-OpenSSL-exception ) GPL-2 MIT"
SLOT="0"
-IUSE="ayatana gtk libressl lightweight nls qt5 systemd test"
+IUSE="ayatana gtk libressl lightweight nls polarssl qt5 systemd test"
RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/libevent-2.0.10:=
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ !polarssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ polarssl? ( >=net-libs/polarssl-1.2:0= )
net-libs/libnatpmp
>=net-libs/miniupnpc-1.7:=
>=net-misc/curl-7.16.3[ssl]
@@ -99,7 +102,7 @@ src_configure() {
-DUSE_SYSTEM_UTP=OFF
-DUSE_SYSTEM_B64=OFF
- -DWITH_CRYPTO=openssl
+ -DWITH_CRYPTO=$(usex polarssl polarssl openssl)
-DWITH_INOTIFY=ON
-DWITH_LIBAPPINDICATOR=$(usex ayatana ON OFF)
-DWITH_SYSTEMD=$(usex systemd ON OFF)