summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2018-09-17 13:55:54 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2018-09-19 01:03:47 +0100
commit725527923f9907ed075bb4000a777c1487a4848b (patch)
tree836c8b6456cabd108665fad468e7538025182c21
parentdev-python/jmespath: add python3_7, EAPI=7 (diff)
downloadgentoo-725527923f9907ed075bb4000a777c1487a4848b.tar.gz
gentoo-725527923f9907ed075bb4000a777c1487a4848b.tar.bz2
gentoo-725527923f9907ed075bb4000a777c1487a4848b.zip
dev-python/botocore: add python3_7
Package-Manager: Portage-2.3.48, Repoman-2.3.10
-rw-r--r--dev-python/botocore/botocore-1.12.4-r1.ebuild58
-rw-r--r--dev-python/botocore/botocore-9999.ebuild2
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/botocore/botocore-1.12.4-r1.ebuild b/dev-python/botocore/botocore-1.12.4-r1.ebuild
new file mode 100644
index 000000000000..822a910e36e1
--- /dev/null
+++ b/dev-python/botocore/botocore-1.12.4-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index 82cc15e1a9c7..822a910e36e1 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 python3_7 )
inherit distutils-r1