summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-10-27 20:18:33 +0800
committerJason Zaman <perfinion@gentoo.org>2015-10-27 20:20:04 +0800
commit73cb025a690e48db51586986926628296488627b (patch)
tree1b87eb5a37300139d4dc1ae73807a4883e3c9b60
parentnet-mail/dovecot: amd64 stable wrt bug #564154 (diff)
parentnet-p2p/rtorrent: version bump 0.9.6 (diff)
downloadgentoo-73cb025a690e48db51586986926628296488627b.tar.gz
gentoo-73cb025a690e48db51586986926628296488627b.tar.bz2
gentoo-73cb025a690e48db51586986926628296488627b.zip
Merge remote-tracking branch 'github/pr/260'
-rw-r--r--net-libs/libtorrent/Manifest1
-rw-r--r--net-libs/libtorrent/files/download_constructor.diff21
-rw-r--r--net-libs/libtorrent/libtorrent-0.13.6.ebuild53
-rw-r--r--net-libs/libtorrent/metadata.xml5
-rw-r--r--net-p2p/rtorrent/Manifest1
-rw-r--r--net-p2p/rtorrent/metadata.xml11
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.6.ebuild63
7 files changed, 128 insertions, 27 deletions
diff --git a/net-libs/libtorrent/Manifest b/net-libs/libtorrent/Manifest
index 588fdf9c1dab..5a4d1117df87 100644
--- a/net-libs/libtorrent/Manifest
+++ b/net-libs/libtorrent/Manifest
@@ -1,2 +1,3 @@
DIST libtorrent-0.13.3.tar.gz 732847 SHA256 34317d6783b7f8d0805274c9467475b5432a246c0de8e28fc16e3b0b43f35677 SHA512 40f504db26d52b0c65fc1008c7b1465bde0e316c776028c5448bf15c6fd38389fad780b0c200933e51f63974a43942603e0103d45a98a3dd57f23f01a306ef25 WHIRLPOOL 7ed5c4903413c9a1587a561a9ec4bedf86f1ed78c8f81c0d0ebe7bf7de9f45187cb41520d3187d62d3718c2fb379857fac255311618b42bfcf77794ee8636ff2
DIST libtorrent-0.13.4.tar.gz 768382 SHA256 704e097119dc89e2ee4630396b25de1cd64b0549841347ea75b9ef9217084955 SHA512 6a5ea944c1193d1160563828c5901f0cf557f38c4de61153d505344f3c3c8509c765e01b6cc5e3a53ec2bb184a9e8db32ed4ec154e93a93822804210f0fa45d0 WHIRLPOOL dc3361a1fed59d64e8b6c2fed46d8e20134cd7f0c3b1cad2a1776375a4a3ff796a63fdfb027fa3f81fbb0b409db76592985444702ddf5e034e7c6384b602c4d4
+DIST libtorrent-0.13.6.tar.gz 781253 SHA256 2838a08c96edfd936aff8fbf99ecbb930c2bfca3337dd1482eb5fccdb80d5a04 SHA512 b8aea4060357a8a40d15d42f1f698ef6f3ebdc885000bfbfa5bf9c81af8c88b5503a107e05c214e3e8489126928d336356c5e7e0eaf836b6b84a3cf74633b050 WHIRLPOOL 9bfc9444efef33dce9792b7dc50fd150ebf7462ea656f82ed7cf1b9c3873eb94742c1e3ecdea6d1c382383ca6ebd4ac1e1ea4169328534d056944fb26c2aa4fd
diff --git a/net-libs/libtorrent/files/download_constructor.diff b/net-libs/libtorrent/files/download_constructor.diff
deleted file mode 100644
index e806cabb64b2..000000000000
--- a/net-libs/libtorrent/files/download_constructor.diff
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/download/download_constructor.cc 2011-03-08 17:48:43.000000000 +0300
-+++ src/download/download_constructor.cc.new 2011-03-08 17:36:42.000000000 +0300
-@@ -97,7 +97,17 @@
-
- parse_name(b.get_key("info"));
- parse_info(b.get_key("info"));
--
-+
-+ // hack, quick fix for #2505
-+ if (b.has_key_list("announce-list"))
-+ if (b.get_key_list("announce-list").empty()) {
-+ b.erase_key("announce-list");
-+ } else {
-+ Object::list_type & l = b.get_key_list("announce-list");
-+ if (l.size() == 1 && !l.begin()->is_list()) {
-+ b.erase_key("announce-list");
-+ }
-+ }
- parse_tracker(b);
- }
-
diff --git a/net-libs/libtorrent/libtorrent-0.13.6.ebuild b/net-libs/libtorrent/libtorrent-0.13.6.ebuild
new file mode 100644
index 000000000000..42e1ba69d7de
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.13.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="BitTorrent library written in C++ for *nix"
+HOMEPAGE="https://rakshasa.github.io/rtorrent/"
+SRC_URI="http://rtorrent.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+# The README says that the library ABI is not yet stable and dependencies on
+# the library should be an explicit, syncronized version until the library
+# has had more time to mature. Until it matures we should not include a soname
+# subslot.
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="debug ipv6 libressl ssl test"
+
+RDEPEND="
+ sys-libs/zlib
+ >=dev-libs/libsigc++-2.2.2:2
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/cppunit )"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # configure needs bash or script bombs out on some null shift, bug #291229
+ CONFIG_SHELL=${BASH} econf \
+ --enable-aligned \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ --with-posix-fallocate
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}
diff --git a/net-libs/libtorrent/metadata.xml b/net-libs/libtorrent/metadata.xml
index aa0f3664825f..50a5b2c6c3fb 100644
--- a/net-libs/libtorrent/metadata.xml
+++ b/net-libs/libtorrent/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>net-p2p</herd>
+ <herd>net-p2p</herd>
+ <upstream>
+ <remote-id type="github">rakshasa/libtorrent</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/net-p2p/rtorrent/Manifest b/net-p2p/rtorrent/Manifest
index eb354f0c1a72..abc99eba05d8 100644
--- a/net-p2p/rtorrent/Manifest
+++ b/net-p2p/rtorrent/Manifest
@@ -1,2 +1,3 @@
DIST rtorrent-0.9.3.tar.gz 583311 SHA256 9e93ca41beb1afe74ad7ad8013e0d53ae3586c9b0e97263d722f721535cc7310 SHA512 a6cc390795c0cf36bf70f4f141db3e176c81df0d6754fe2e6a95ef59385a70e7ce006fe81b83deff5b32e06cc771d03c5c7ba1140be64b2d252719e8aa2058f3 WHIRLPOOL 7cb2e51718596145ef8a07b1de0bb9ccd4dc923a4ec8091a3f775dffaafe5111873d43047e6e32720a202774454e53443e402010d956954f19cdfdb08983ec52
DIST rtorrent-0.9.4.tar.gz 601913 SHA256 bc0a2c1ee613b68f37021beaf4e64a9252f91ed06f998c1e897897c354ce7e84 SHA512 ae243d0336acff50e91e4ed9d306beb4705559775518e6dc122ec18a1530e59e2c531cf54f4b79899a1569ca18d343fce255071b45c41df1357bddfe926692aa WHIRLPOOL 03eb3cff0f7d490ada2199310fd2ba7576de8e20557e532df49be17f84aa2afb9cb8137b2eb317bc0fb4ce8ce035e900c65c32e81dc5d5d215923d91e8c0612a
+DIST rtorrent-0.9.6.tar.gz 610845 SHA256 1e69c24f1f26f8f07d58d673480dc392bfc4317818c1115265b08a7813ff5b0e SHA512 704f7b79d5bc78b817da21a6886662a5a97fde210a110c50f708bdc18e1dcf3ef5c5f4e2740261d41221cfc69c19926bf34e10057adf10601da9e6e06b2cef75 WHIRLPOOL df5878014087d894e9796508627ec508ff5d042c78cc09e8d9ae57a7f9556bb549f9900e3995a7296420438ca0edda245907f8ae0c71d5a0ae28c3af7a6f992e
diff --git a/net-p2p/rtorrent/metadata.xml b/net-p2p/rtorrent/metadata.xml
index 0547227d9821..9fa2e6deabbe 100644
--- a/net-p2p/rtorrent/metadata.xml
+++ b/net-p2p/rtorrent/metadata.xml
@@ -3,11 +3,12 @@
<pkgmetadata>
<herd>net-p2p</herd>
<longdescription lang="en">
- Console BitTorrent client using ncurses based on libtorrent written in C++.
-</longdescription>
+ Console BitTorrent client using ncurses based on libtorrent written in C++.
+ </longdescription>
<use>
- <flag name="daemon">Uses <pkg>app-misc/screen</pkg> to daemonize this
- application
- </flag>
+ <flag name="daemon">Uses <pkg>app-misc/screen</pkg> to daemonize this application</flag>
</use>
+ <upstream>
+ <remote-id type="github">rakshasa/rtorrent</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/net-p2p/rtorrent/rtorrent-0.9.6.ebuild b/net-p2p/rtorrent/rtorrent-0.9.6.ebuild
new file mode 100644
index 000000000000..efbf0261f74c
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.9.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils systemd
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="https://rakshasa.github.io/rtorrent/"
+SRC_URI="http://rtorrent.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="daemon debug ipv6 selinux test xmlrpc"
+
+COMMON_DEPEND="~net-libs/libtorrent-0.13.${PV##*.}
+ >=dev-libs/libsigc++-2.2.2:2
+ >=net-misc/curl-7.19.1
+ sys-libs/ncurses:0=
+ xmlrpc? ( dev-libs/xmlrpc-c )"
+RDEPEND="${COMMON_DEPEND}
+ daemon? ( app-misc/screen )
+ selinux? ( sec-policy/selinux-rtorrent )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/cppunit
+ virtual/pkgconfig"
+
+DOCS=( doc/rtorrent.rc )
+
+src_prepare() {
+ # bug #358271
+ epatch \
+ "${FILESDIR}"/${PN}-0.9.1-ncurses.patch \
+ "${FILESDIR}"/${PN}-0.9.4-tinfo.patch
+
+ # https://github.com/rakshasa/rtorrent/issues/332
+ cp "${FILESDIR}"/rtorrent.1 "${S}"/doc/ || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # configure needs bash or script bombs out on some null shift, bug #291229
+ CONFIG_SHELL=${BASH} econf \
+ --disable-dependency-tracking \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_with xmlrpc xmlrpc-c)
+}
+
+src_install() {
+ default
+ doman doc/rtorrent.1
+
+ if use daemon; then
+ newinitd "${FILESDIR}/rtorrentd.init" rtorrentd
+ newconfd "${FILESDIR}/rtorrentd.conf" rtorrentd
+ systemd_newunit "${FILESDIR}/rtorrentd_at.service" "rtorrentd@.service"
+ fi
+}