summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2016-11-24 08:43:17 +0100
committerMichael Orlitzky <mjo@gentoo.org>2016-12-18 18:17:02 -0500
commit7597666e5c4129648723a953e015eb082fc53495 (patch)
tree806bd362cd89a7e989a352183830b127cb4ef89f
parentdev-php/semver: Add 1.0.0 version (diff)
downloadgentoo-7597666e5c4129648723a953e015eb082fc53495.tar.gz
gentoo-7597666e5c4129648723a953e015eb082fc53495.tar.bz2
gentoo-7597666e5c4129648723a953e015eb082fc53495.zip
dev-php/ca-bundle: Add 1.0.0 version
This is needed for composer-1.2.2, bug 439206. Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--dev-php/ca-bundle/Manifest1
-rw-r--r--dev-php/ca-bundle/ca-bundle-1.0.0.ebuild23
-rw-r--r--dev-php/ca-bundle/files/autoload.php8
-rw-r--r--dev-php/ca-bundle/metadata.xml18
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-php/ca-bundle/Manifest b/dev-php/ca-bundle/Manifest
new file mode 100644
index 000000000000..a15ae754520b
--- /dev/null
+++ b/dev-php/ca-bundle/Manifest
@@ -0,0 +1 @@
+DIST ca-bundle-1.0.0.tar.gz 151219 SHA256 8686dea9feeb444a5c9977e0654fc03a22b34061c05d2ae180e491ed33b6b7e5 SHA512 f83fc24caddd9b1cf7fd1d22def51372fd6d1497f39a335d0507122ab960e438e9ffadafd357d3dc742cc5e052ac197de0dd670921b076277df98bcbc2c71f42 WHIRLPOOL 30404789aa177a78773cefc0e830743b8c5963d0926b2feec205e7ba462ced0e37251a1ca10f0edbd3ad9176b6a6266b722eba7dec90c9c6d0bd62c938a3904e
diff --git a/dev-php/ca-bundle/ca-bundle-1.0.0.ebuild b/dev-php/ca-bundle/ca-bundle-1.0.0.ebuild
new file mode 100644
index 000000000000..7e6cbf7924a3
--- /dev/null
+++ b/dev-php/ca-bundle/ca-bundle-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Find a path to the system CA bundle, and fallback to the Mozilla CA bundle"
+HOMEPAGE="https://github.com/composer/ca-bundle"
+SRC_URI="https://github.com/composer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+src_install() {
+ insinto "/usr/share/php/Composer/CaBundle"
+ doins -r src/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}
diff --git a/dev-php/ca-bundle/files/autoload.php b/dev-php/ca-bundle/files/autoload.php
new file mode 100644
index 000000000000..993360676f74
--- /dev/null
+++ b/dev-php/ca-bundle/files/autoload.php
@@ -0,0 +1,8 @@
+<?php
+/* Autoloader for composer/ca-bundle and its dependencies */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addPsr4('Composer\\CaBundle\\', __DIR__);
diff --git a/dev-php/ca-bundle/metadata.xml b/dev-php/ca-bundle/metadata.xml
new file mode 100644
index 000000000000..10071bbabf1c
--- /dev/null
+++ b/dev-php/ca-bundle/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Small utility library that lets you find a path to the system CA bundle,
+ and includes a fallback to the Mozilla CA bundle.
+ Originally written as part of dev-php/composer,
+ now extracted and made available as a stand-alone library.
+ </longdescription>
+</pkgmetadata>