summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-11 13:35:53 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-11 13:36:01 +0200
commit767dc8b6ae440f90f7a6d1be3b926dde8e30af8e (patch)
treeb41638be366b74523f99e6d7cc1101231fd90309
parentx11-terms/terminator: Drop old (diff)
downloadgentoo-767dc8b6ae440f90f7a6d1be3b926dde8e30af8e.tar.gz
gentoo-767dc8b6ae440f90f7a6d1be3b926dde8e30af8e.tar.bz2
gentoo-767dc8b6ae440f90f7a6d1be3b926dde8e30af8e.zip
x11-terms/terminator: Version Bump
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=560194 Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--x11-terms/terminator/Manifest1
-rw-r--r--x11-terms/terminator/terminator-0.98.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/x11-terms/terminator/Manifest b/x11-terms/terminator/Manifest
index 1f8d777adf7c..3990ad0aa2eb 100644
--- a/x11-terms/terminator/Manifest
+++ b/x11-terms/terminator/Manifest
@@ -1,2 +1,3 @@
DIST terminator-0.97.tar.gz 5025337 SHA256 0281b568913f392eec92ebee3c6fea15afe4f4e01869bad38d9efe0eb305be49 SHA512 ac1dfb5c014323ddd3b3347645ac26083d96fe8e895d31c5992d185863d40b5f1a67c5db1315b48f483d9511faeb1adb16133a4aef1e1f178656f3437d4a7470 WHIRLPOOL 9d83bd34e1018dc535af573af27d08b425def1af5498de7be793e7c90298d0140c2e78479bae4264fa7315bcfa9b36d2d464f822b58af0d7452802a3cfc18583
+DIST terminator-0.98.tar.gz 6007243 SHA256 0a6d8c9ffe36d67e60968fbf2752c521e5d498ceda42ef171ad3e966c02f26c1 SHA512 c40ac1929bb446239f769d33f37a6d49ee79ea10755dda4bbbd228763f13661f0ef7efd950a592462150237e516077311318e2a19c9f08adac76a418cf633573 WHIRLPOOL b9a6e9bba8a945ca51aca6936b00dfc51b9c1d266315450b2f63af2d64600c18a7ff9cce712a342f236aded0bbda07b7d1a979685f68d45006a14cf7b0d9a160
DIST terminator_0.96.tar.gz 264226 SHA256 d708c783c36233fcafbd0139a91462478ae40f5cf696ef4acfcaf5891a843201 SHA512 f74b5887ea7a11bf5c6866eae5e879a60badd81dd5056cfd0fdb5e4940b81917e6cd05ea50b56a9c7beba8e9fc9e842b25d3c8ad3ed7b574b72f43a1d4fc6c5e WHIRLPOOL 53fed7d74a3a76e7cca01cb0ab7f1780f981b81aec9606a1f4416c3e786773aca41abac174e40f1b49b9285edc9d7c8fcf599395c09a9a23ec3ec4d745e35b55
diff --git a/x11-terms/terminator/terminator-0.98.ebuild b/x11-terms/terminator/terminator-0.98.ebuild
new file mode 100644
index 000000000000..d5c931d61ac5
--- /dev/null
+++ b/x11-terms/terminator/terminator-0.98.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 distutils-r1 virtualx
+
+DESCRIPTION="Multiple GNOME terminals in one window"
+HOMEPAGE="http://www.tenshu.net/p/terminator.html"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus doc gnome +libnotify"
+
+RDEPEND="
+ dev-libs/keybinder:0[python]
+ x11-libs/vte:0[python]
+ dbus? ( sys-apps/dbus )
+ gnome? (
+ dev-python/gconf-python
+ dev-python/libgnome-python
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ )
+ libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )"
+DEPEND="dev-util/intltool"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/0.90-without-icon-cache.patch
+ "${FILESDIR}"/0.94-session.patch
+ )
+
+ local i p
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ pushd "${S}"/po > /dev/null
+ strip-linguas -i .
+ for i in *.po; do
+ if ! has ${i%.po} ${LINGUAS} ; then
+ rm ${i} || die
+ fi
+ done
+ popd > /dev/null
+ fi
+
+ sed \
+ -e "/'share', 'doc'/s:${PN}:${PF}:g" \
+ -i setup.py terminatorlib/util.py || die
+
+ use doc || \
+ sed \
+ -e '/install_documentation/s:True:False:g' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ VIRTUALX_COMMAND="esetup.py"
+ virtualmake test
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}