summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-04-19 22:45:28 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-04-19 22:45:47 +0200
commit769747fcf93b9f2272d7f440afe2c8c855286f24 (patch)
treee4b7849fcf595df6ce3a5174506f48cbbc472623
parentfix <pkg/> reference in metadata.xml (diff)
downloadgentoo-769747fcf93b9f2272d7f440afe2c8c855286f24.tar.gz
gentoo-769747fcf93b9f2272d7f440afe2c8c855286f24.tar.bz2
gentoo-769747fcf93b9f2272d7f440afe2c8c855286f24.zip
dev-libs/libinput: Version bump to 1.2.3
Package-Manager: portage-2.2.28
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.2.3.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index b974d90b2b83..a900a0b50766 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -5,3 +5,4 @@ DIST libinput-1.1.5.tar.xz 806960 SHA256 5e08c45dbb8bf32490cc6cd626da098564d646d
DIST libinput-1.2.0.tar.xz 866284 SHA256 1754b917fe675507ea80445b4f2e91d76cb6a6935508fe37234807affb316e2c SHA512 ab5b534ac5db7d4142e41c61e1f8fbc7f4c9cf89567fa27196fa9300f57db7328d61af25c93126905ad06061e1b2def0abe70654ac3710b6476379f84343cce8 WHIRLPOOL 2f74bcd3ae694db9f52c450c6b96d24fd320da2002e900cf69a3ce2d9c33b00213097c0330867f32b175b5fe80d06099c3bdc461a2001f4eee4f2481ab1e32fc
DIST libinput-1.2.1.tar.xz 863660 SHA256 e2db8c5357f8859b33c58e583601f50509f085ae9340a58790bcf44f1480c1c3 SHA512 6dceed081bb0c5374d39be7ce14ccbeb7734c50a648a155ca9d57f7dabde80a35a5b3b4eb15f37ce5c475725a13624d4c7f9ab1147f71af2576fdb746310509c WHIRLPOOL 7748530169b95765f5d8a07191c8e3f8e165d5d778f6f9da8ea4dc10164501e9be4166eecb534b69153cb11d48354663739effbd324107596f496c5d38c6b632
DIST libinput-1.2.2.tar.xz 857176 SHA256 08ac5b3620d86df1cdb4970c4137c8746c9f4b9f0c8e7dfab49858dbceb8f367 SHA512 d738890b7fc34a66cdb6ebb58f28060ffc81dccda56aa144622f62efc054431d75564d11f6d9a96a2c17032f15093ca98db9f087822977cec9fced428efd2f8b WHIRLPOOL 66128be8bc6019a6c8986fa4ea05041fa75da38fc60232e3d1b12e0e4e90c2d049b622cf3cae7b4107cacbacf6139804693695928d1055a5203c664888d59547
+DIST libinput-1.2.3.tar.xz 860400 SHA256 09b2a9d3a0cc973a9d3fdc7af40162cbef0b16be0a2e415786f83761f519e9f2 SHA512 2b82169a395c4f8b3d9a6250b1e4787b7dac1a0a7ea421036ccbbfdb256c59f848f68233522db977d311a48abfef28b3c3f0b3779254c34469b84c7287a90fbf WHIRLPOOL ce0517cf824193c56a82a1ac61e5c8950e6f7910162c65b996bc0330e2a1fff53a59494b3f516b412995dc9af59c598b3ae6123ce601b32da07a370540705b86
diff --git a/dev-libs/libinput/libinput-1.2.3.ebuild b/dev-libs/libinput/libinput-1.2.3.ebuild
new file mode 100644
index 000000000000..3107c89aa9c5
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.2.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.12 )
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_prepare() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable input_devices_wacom libwacom) \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ prune_libtool_files
+}