summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-07-19 09:27:24 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-07-19 09:27:38 +0100
commit78579a637842b8fbca0df36d32a83183f53fea28 (patch)
tree86ad9d9e84cc65b8ac5f71db5a349a9eba2de622
parentapp-editors/bluefish: remove redundant dep bug #593232 (diff)
downloadgentoo-78579a637842b8fbca0df36d32a83183f53fea28.tar.gz
gentoo-78579a637842b8fbca0df36d32a83183f53fea28.tar.bz2
gentoo-78579a637842b8fbca0df36d32a83183f53fea28.zip
dev-util/include-what-you-use: bump up to 4.0, clang-4 compatible, bug #625528
Upstream did not yet publish the release on it's site. We might need to update the ebuild if release re-cut happens. Reported-by: Daniel M. Weeks Bug: https://bugs.gentoo.org/625528 Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-util/include-what-you-use/Manifest1
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-4.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/include-what-you-use/Manifest b/dev-util/include-what-you-use/Manifest
index 23c05a1d0b87..78604e47b64e 100644
--- a/dev-util/include-what-you-use/Manifest
+++ b/dev-util/include-what-you-use/Manifest
@@ -1 +1,2 @@
DIST include-what-you-use-3.9.src.tar.gz 446773 SHA256 bbea3ddbd2e0990f4edd92a994a94ca24e2ee0edba6bd5612f62e872554d777a SHA512 dd7990fa4112ddb0434807efd9dcf0f77bbecaa61eab51be24428f8e45b9321c7647a979278f3f1266ba9be05c6f1de536fc084613d38638b795248001ce4b44 WHIRLPOOL 67b4acabb887cb80c290817ab848a115b2559bcc5187f05e320ea4bdef6e9915766d824069ce1f060058ba3597b85223419fb4d932ebb536d25ef0a6de64aee2
+DIST include-what-you-use-4.0.src.tar.gz 437340 SHA256 8f6d4a279afcbbfa7247a97a03d9abc1d6834954eec7ba733519401392b328c6 SHA512 c96b78ec8f8289bfd7830acaf533aea0077bb36311d3b8bb7f31464c1b3a5b3f353b24e81ffc581811b4083d3b5959e4e947e3a3d16cb7c77de00b05b9972a90 WHIRLPOOL 63fc4df0ca3be81a8856aec22bffe3dbdebde060a91c85b38ad2e1202d8e20291d006c1739851434cc5c98dc6b3b66b9287623a8576976c741dfd6c08f5677c6
diff --git a/dev-util/include-what-you-use/include-what-you-use-4.0.ebuild b/dev-util/include-what-you-use/include-what-you-use-4.0.ebuild
new file mode 100644
index 000000000000..cb7b16cd717e
--- /dev/null
+++ b/dev-util/include-what-you-use/include-what-you-use-4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit cmake-utils flag-o-matic python-single-r1
+
+DESCRIPTION="Find unused include directives in C/C++ programs"
+HOMEPAGE="https://include-what-you-use.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/clang_${PV}.tar.gz -> ${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=sys-devel/llvm-${PV}*
+ =sys-devel/clang-${PV}*
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${PN}-clang_${PV}
+
+src_prepare() {
+ python_fix_shebang .
+ default
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DIWYU_LLVM_INCLUDE_PATH=$(llvm-config --includedir)
+ -DIWYU_LLVM_LIB_PATH=$(llvm-config --libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${EPYTHON}" run_iwyu_tests.py
+}