summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-09-26 16:34:57 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-09-27 02:14:48 +0200
commit789799cad385d9036ff428a5940cf38cc362476d (patch)
treefbf8b9fb5541598b6a41add9515005c2c8262ebe
parentapp-backup/rear: remove unused patch(es) (diff)
downloadgentoo-789799cad385d9036ff428a5940cf38cc362476d.tar.gz
gentoo-789799cad385d9036ff428a5940cf38cc362476d.tar.bz2
gentoo-789799cad385d9036ff428a5940cf38cc362476d.zip
app-crypt/monkeysphere: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/17682 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.37_default_shell.patch12
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.37_hd_od.patch14
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.38-asprintf.patch45
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.38-revert-executable-patch.patch98
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.38-syssharedir-whitespace.patch53
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.39-make-tests-work-with-gnupg-2.1.15.patch45
6 files changed, 0 insertions, 267 deletions
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.37_default_shell.patch b/app-crypt/monkeysphere/files/monkeysphere-0.37_default_shell.patch
deleted file mode 100644
index f979114181d1..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.37_default_shell.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -r d0c02fe6a949 src/share/common
---- a/src/share/common Sun Oct 06 19:21:18 2013 +0200
-+++ b/src/share/common Sun Oct 06 19:21:49 2013 +0200
-@@ -108,7 +108,7 @@
- # if root, su command as monkeysphere user
- 'root')
- # requote arguments using bash builtin feature (see "help printf"):
-- su "$MONKEYSPHERE_USER" -c "$(printf "%q " "$@")"
-+ su -s /bin/bash "$MONKEYSPHERE_USER" -c "$(printf "%q " "$@")"
- ;;
-
- # otherwise, fail
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.37_hd_od.patch b/app-crypt/monkeysphere/files/monkeysphere-0.37_hd_od.patch
deleted file mode 100644
index 7cdaa74b5735..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.37_hd_od.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -r 6150774ec7f4 tests/keytrans
---- a/tests/keytrans Sun Feb 16 20:11:02 2014 +0100
-+++ b/tests/keytrans Sun Feb 16 20:11:40 2014 +0100
-@@ -104,8 +104,8 @@
- <(gpg --list-packets < "$TEMPDIR"/converted.secret.key)
-
- diff -u \
-- <(hd "$TEMPDIR"/secret.key) \
-- <(hd "$TEMPDIR"/converted.secret.key)
-+ <(od -xc "$TEMPDIR"/secret.key) \
-+ <(od -xc "$TEMPDIR"/converted.secret.key)
-
- KEYFPR=$(gpg --fingerprint --with-colons --list-keys | grep ^fpr | cut -f10 -d:)
- KEYID=$(printf "%s" "$KEYFPR" | cut -b25-40)
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.38-asprintf.patch b/app-crypt/monkeysphere/files/monkeysphere-0.38-asprintf.patch
deleted file mode 100644
index dbf9d5f590ca..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.38-asprintf.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From b756fd2e58ab013b5c9bfc2658ed9ad48868067c Mon Sep 17 00:00:00 2001
-From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
-Date: Sun, 7 Aug 2016 18:24:47 -0400
-Subject: [PATCH] avoid warning about unused asprintf return value
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-some versions of gcc produce this warning, which is treated as an
-error due to our conservative defaults in Makefile:
-
-src/agent-transfer/main.c: In function ‘main’:
-src/agent-transfer/main.c:676:5: error: ignoring return value of ‘asprintf’, declared with attribute warn_unused_result [-Werror=unused-result]
- asprintf (&alt_comment, "GnuPG keygrip %s", args.keygrip);
- ^
-cc1: all warnings being treated as errors
-
-this patch avoids the warning.
----
- src/agent-transfer/main.c | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/src/agent-transfer/main.c b/src/agent-transfer/main.c
-index 406aaa3..3038f5c 100644
---- a/src/agent-transfer/main.c
-+++ b/src/agent-transfer/main.c
-@@ -672,8 +672,13 @@ int main (int argc, const char* argv[]) {
- return 1;
- }
-
-- if (!args.comment)
-- asprintf (&alt_comment, "GnuPG keygrip %s", args.keygrip);
-+ if (!args.comment) {
-+ err = asprintf (&alt_comment, "GnuPG keygrip %s", args.keygrip);
-+ if (err < 0) {
-+ fprintf (stderr, "failed to generate key comment\n");
-+ return 1;
-+ }
-+ }
-
- err = send_to_ssh_agent (&e, ssh_sock_fd, args.seconds, args.confirm,
- args.comment ? args.comment : alt_comment);
---
-2.7.3
-
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.38-revert-executable-patch.patch b/app-crypt/monkeysphere/files/monkeysphere-0.38-revert-executable-patch.patch
deleted file mode 100644
index 4d98c0a7cf5b..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.38-revert-executable-patch.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-From c75c7553a88e387013e2b4310f4c4956adfd8a98 Mon Sep 17 00:00:00 2001
-From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
-Date: Mon, 8 Aug 2016 20:45:07 -0400
-Subject: [PATCH 1/2] avoid treating src/share/common as an executable
-
-having src/share/common treated as an executable (commit
-ed10318d3760b56e57d5e1bef04ab57761ab8bd1) was actually a terrible
-idea.
-
-In addition to causing "monkeysphere version" to print the version
-number twice, it meant that any invocation of a monkeysphere command
-that sourced src/share/common and had a first argument that happened
-to be a function name would accidentally invoke that function.
-
-This commit reverts that idea.
----
- Makefile | 2 +-
- src/share/common | 5 -----
- src/share/ma/add_certifier | 2 +-
- src/share/ma/update_users | 2 +-
- src/share/mh/add_revoker | 2 +-
- 5 files changed, 4 insertions(+), 9 deletions(-)
- mode change 100755 => 100644 src/share/common
-
-diff --git a/Makefile b/Makefile
-index 608a317..768564a 100755
---- a/Makefile
-+++ b/Makefile
-@@ -55,7 +55,7 @@ install: all installman
- install src/monkeysphere-authentication $(DESTDIR)$(PREFIX)/sbin
- sed -i 's:__SYSSHAREDIR_PREFIX__:$(PREFIX):' $(DESTDIR)$(PREFIX)/sbin/monkeysphere-authentication
- install src/monkeysphere-authentication-keys-for-user $(DESTDIR)$(PREFIX)/share/monkeysphere
-- install -m 0755 src/share/common $(DESTDIR)$(PREFIX)/share/monkeysphere
-+ install -m 0644 src/share/common $(DESTDIR)$(PREFIX)/share/monkeysphere
- install -m 0644 src/share/defaultenv $(DESTDIR)$(PREFIX)/share/monkeysphere
- sed -i 's:__SYSCONFDIR_PREFIX__:$(ETCPREFIX):' $(DESTDIR)$(PREFIX)/share/monkeysphere/defaultenv
- sed -i 's:__SYSDATADIR_PREFIX__:$(LOCALSTATEDIR):' $(DESTDIR)$(PREFIX)/share/monkeysphere/defaultenv
-diff --git a/src/share/common b/src/share/common
-old mode 100755
-new mode 100644
-index 66181a3..b10a040
---- a/src/share/common
-+++ b/src/share/common
-@@ -1,4 +1,3 @@
--#!/usr/bin/env bash
- # -*-shell-script-*-
- # This should be sourced by bash (though we welcome changes to make it POSIX sh compliant)
-
-@@ -1022,7 +1021,3 @@ report_cruft() {
- printf "The directories above are backups left over from a monkeysphere transition.\nThey may contain copies of sensitive data (host keys, certifier lists), but\nthey are no longer needed by monkeysphere.\nYou may remove them at any time.\n\n" | log info
- fi
- }
--
--if [ -n "$1" ] && [ "$(type -t "$1" || true)" = "function" ]; then
-- "$@"
--fi
-diff --git a/src/share/ma/add_certifier b/src/share/ma/add_certifier
-index 1d450e7..5416aa9 100644
---- a/src/share/ma/add_certifier
-+++ b/src/share/ma/add_certifier
-@@ -101,7 +101,7 @@ if [ -f "$keyID" -o "$keyID" = '-' ] ; then
- # check the key is ok as monkeysphere user before loading
- log debug "checking keys in file..."
- fingerprint=$(su_monkeysphere_user \
-- "${SYSSHAREDIR}/common" list_primary_fingerprints < "$keyID")
-+ bash -c ". ${SYSSHAREDIR}/common && list_primary_fingerprints" < "$keyID")
-
- if [ $(printf "%s" "$fingerprint" | egrep -c '^[A-F0-9]{40}$') -ne 1 ] ; then
- failure "There was not exactly one gpg key in the file."
-diff --git a/src/share/ma/update_users b/src/share/ma/update_users
-index d23c125..4f83e0c 100644
---- a/src/share/ma/update_users
-+++ b/src/share/ma/update_users
-@@ -79,7 +79,7 @@ for uname in $unames ; do
-
- # process authorized_user_ids file, as monkeysphere user
- su_monkeysphere_user \
-- /usr/bin/env "STRICT_MODES=$STRICT_MODES" "${SYSSHAREDIR}/common" process_authorized_user_ids - \
-+ /usr/bin/env "STRICT_MODES=$STRICT_MODES" bash -c ". ${SYSSHAREDIR}/common && process_authorized_user_ids -" \
- < "$authorizedUserIDs" \
- > "$tmpAuthorizedKeys"
-
-diff --git a/src/share/mh/add_revoker b/src/share/mh/add_revoker
-index 28b11ac..e00ac4e 100644
---- a/src/share/mh/add_revoker
-+++ b/src/share/mh/add_revoker
-@@ -52,7 +52,7 @@ if [ -f "$revokerKeyID" -o "$revokerKeyID" = '-' ] ; then
- # check the key is ok as monkeysphere user before loading
- log debug "checking keys in file..."
- fingerprint=$(su_monkeysphere_user \
-- "${SYSSHAREDIR}/common" list_primary_fingerprints < "$revokerKeyID")
-+ bash -c ". ${SYSSHAREDIR}/common && list_primary_fingerprints" < "$revokerKeyID")
-
- if [ $(printf "%s" "$fingerprint" | egrep -c '^[A-F0-9]{40}$') -ne 1 ] ; then
- failure "There was not exactly one gpg key in the file."
---
-2.7.3
-
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.38-syssharedir-whitespace.patch b/app-crypt/monkeysphere/files/monkeysphere-0.38-syssharedir-whitespace.patch
deleted file mode 100644
index 65d3ba6a95aa..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.38-syssharedir-whitespace.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 0e339de4772b6de1849dc55790821c3dd5943be3 Mon Sep 17 00:00:00 2001
-From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
-Date: Tue, 9 Aug 2016 09:39:45 -0400
-Subject: [PATCH 2/2] ensure that this works even if SYSSHAREDIR has whitespace
-
----
- src/share/ma/add_certifier | 2 +-
- src/share/ma/update_users | 2 +-
- src/share/mh/add_revoker | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/share/ma/add_certifier b/src/share/ma/add_certifier
-index 5416aa9..9488806 100644
---- a/src/share/ma/add_certifier
-+++ b/src/share/ma/add_certifier
-@@ -101,7 +101,7 @@ if [ -f "$keyID" -o "$keyID" = '-' ] ; then
- # check the key is ok as monkeysphere user before loading
- log debug "checking keys in file..."
- fingerprint=$(su_monkeysphere_user \
-- bash -c ". ${SYSSHAREDIR}/common && list_primary_fingerprints" < "$keyID")
-+ bash -c "$(printf ". %q && list_primary_fingerprints" "${SYSSHAREDIR}/common")" < "$keyID")
-
- if [ $(printf "%s" "$fingerprint" | egrep -c '^[A-F0-9]{40}$') -ne 1 ] ; then
- failure "There was not exactly one gpg key in the file."
-diff --git a/src/share/ma/update_users b/src/share/ma/update_users
-index 4f83e0c..a0ec21b 100644
---- a/src/share/ma/update_users
-+++ b/src/share/ma/update_users
-@@ -79,7 +79,7 @@ for uname in $unames ; do
-
- # process authorized_user_ids file, as monkeysphere user
- su_monkeysphere_user \
-- /usr/bin/env "STRICT_MODES=$STRICT_MODES" bash -c ". ${SYSSHAREDIR}/common && process_authorized_user_ids -" \
-+ /usr/bin/env "STRICT_MODES=$STRICT_MODES" bash -c "$(printf ". %q && process_authorized_user_ids -" "${SYSSHAREDIR}/common")"\
- < "$authorizedUserIDs" \
- > "$tmpAuthorizedKeys"
-
-diff --git a/src/share/mh/add_revoker b/src/share/mh/add_revoker
-index e00ac4e..de08961 100644
---- a/src/share/mh/add_revoker
-+++ b/src/share/mh/add_revoker
-@@ -52,7 +52,7 @@ if [ -f "$revokerKeyID" -o "$revokerKeyID" = '-' ] ; then
- # check the key is ok as monkeysphere user before loading
- log debug "checking keys in file..."
- fingerprint=$(su_monkeysphere_user \
-- bash -c ". ${SYSSHAREDIR}/common && list_primary_fingerprints" < "$revokerKeyID")
-+ bash -c "$(printf ". %q && list_primary_fingerprints" "${SYSSHAREDIR}/common")" < "$revokerKeyID")
-
- if [ $(printf "%s" "$fingerprint" | egrep -c '^[A-F0-9]{40}$') -ne 1 ] ; then
- failure "There was not exactly one gpg key in the file."
---
-2.7.3
-
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.39-make-tests-work-with-gnupg-2.1.15.patch b/app-crypt/monkeysphere/files/monkeysphere-0.39-make-tests-work-with-gnupg-2.1.15.patch
deleted file mode 100644
index 776e633b3d73..000000000000
--- a/app-crypt/monkeysphere/files/monkeysphere-0.39-make-tests-work-with-gnupg-2.1.15.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From b1dd8fb1b84c6eea25523c3ea746852b3dce6034 Mon Sep 17 00:00:00 2001
-From: Valo <valo@autoproduzioni.net>
-Date: Wed, 31 Aug 2016 14:00:05 -0400
-Subject: [PATCH] Make tests pass with GnuPG 2.1.15
-
-2.1.15 appears to always emit the fingerprint lines in these cases,
-while 2.1.14 did not.
----
- tests/keytrans | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/tests/keytrans b/tests/keytrans
-index 3076e3f..5c7d2c8 100755
---- a/tests/keytrans
-+++ b/tests/keytrans
-@@ -140,7 +140,7 @@ uid:u::::$timestamp::8200BD0425CC70C7D698DF3FE412044EAAB83F94::testtest
- sig:!::1:$KEYID:$timestamp::::monkeymonkey:13x:::::8
- EOF
-
--diff -u "$TEMPDIR"/expectedout <(gpg --check-sigs --with-colons | grep -v ^tru | sed 's/:*$//')
-+diff -u "$TEMPDIR"/expectedout <(gpg --check-sigs --with-colons | grep -vE '^(tru|fpr):' | sed 's/:*$//')
-
- echo "##################################################"
- echo "### sleeping to avoid test suite breakage on fast"
-@@ -170,7 +170,7 @@ rev:!::1:$KEYID:$revtime::::monkeymonkey:30x:::::8
- EOF
-
-
--diff -u "$TEMPDIR"/expectedout <(gpg --check-sigs --with-colons | grep -v ^tru | sed 's/:*$//')
-+diff -u "$TEMPDIR"/expectedout <(gpg --check-sigs --with-colons | grep -vE '^(tru|fpr):' | sed 's/:*$//')
-
-
- echo "##################################################"
-@@ -206,7 +206,7 @@ sig:!::1:$NEWKEYID:$(($timestamp + 1))::::fubar:13x:::::8
- EOF
-
- echo "test: diff expected gpg list output"
--diff -u "$TEMPDIR"/expectedout <(gpg --check-sigs --with-colons | grep -v ^tru | sed 's/:*$//')
-+diff -u "$TEMPDIR"/expectedout <(gpg --check-sigs --with-colons | grep -vE '^(tru|fpr):' | sed 's/:*$//')
-
- sort >"$TEMPDIR"/expectedout <<EOF
- $KEYFPR
---
-2.7.3
-