summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:11:36 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:04 +0000
commit78a4bcd1437adbb1072c68e474abc99de3e4a8ed (patch)
treeb74496c3ee3fd2dd600e6ae785b147dbdc173338
parentapp-i18n/freewnn: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-78a4bcd1437adbb1072c68e474abc99de3e4a8ed.tar.gz
gentoo-78a4bcd1437adbb1072c68e474abc99de3e4a8ed.tar.bz2
gentoo-78a4bcd1437adbb1072c68e474abc99de3e4a8ed.zip
app-misc/cdircmp: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-misc/cdircmp/cdircmp-0.3-r2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-misc/cdircmp/cdircmp-0.3-r2.ebuild b/app-misc/cdircmp/cdircmp-0.3-r2.ebuild
index 320af7a9c01d..d4f394e39881 100644
--- a/app-misc/cdircmp/cdircmp-0.3-r2.ebuild
+++ b/app-misc/cdircmp/cdircmp-0.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,7 +29,7 @@ src_prepare() {
src_compile() {
emake CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" \
- LDFLAGS="$(pkg-config --libs ncurses) ${LDFLAGS}"
+ LDFLAGS="$($(tc-getPKG_CONFIG) --libs ncurses) ${LDFLAGS}"
}
src_install() {