summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-27 11:09:34 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-27 11:27:27 +0100
commit7954e810b7a27d3a55dd0b1ce0cb828b0a7b47c3 (patch)
tree79fc3299f09cbc2293e324a910bdcab24a78514a
parentdev-python/requests: Support running tests without trustme (diff)
downloadgentoo-7954e810b7a27d3a55dd0b1ce0cb828b0a7b47c3.tar.gz
gentoo-7954e810b7a27d3a55dd0b1ce0cb828b0a7b47c3.tar.bz2
gentoo-7954e810b7a27d3a55dd0b1ce0cb828b0a7b47c3.zip
dev-python/requests-toolbelt: Remove stale py2 patch
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/requests-toolbelt/files/requests-toolbelt-0.9.1-tests-py2.patch68
-rw-r--r--dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild5
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/requests-toolbelt/files/requests-toolbelt-0.9.1-tests-py2.patch b/dev-python/requests-toolbelt/files/requests-toolbelt-0.9.1-tests-py2.patch
deleted file mode 100644
index 6825c5f4ed4c..000000000000
--- a/dev-python/requests-toolbelt/files/requests-toolbelt-0.9.1-tests-py2.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-diff --git a/tests/threaded/test_pool.py b/tests/threaded/test_pool.py
-index 3e54b3c..9583c7b 100644
---- a/tests/threaded/test_pool.py
-+++ b/tests/threaded/test_pool.py
-@@ -5,6 +5,7 @@ except ImportError:
- import Queue as queue
- import unittest
-
-+import sys
- import mock
- import pytest
-
-@@ -60,6 +61,7 @@ class TestPool(unittest.TestCase):
- assert session.called is True
- session.assert_called_once_with()
-
-+ @pytest.mark.skipif(sys.hexversion < 0x3000000, reason="broken on python2")
- def test_from_exceptions_populates_a_queue(self):
- """Ensure a Queue is properly populated from exceptions."""
- urls = ["https://httpbin.org/get?n={}".format(n) for n in range(5)]
-@@ -77,6 +79,7 @@ class TestPool(unittest.TestCase):
- for url in urls
- ]
-
-+ @pytest.mark.skipif(sys.hexversion < 0x3000000, reason="broken on python2")
- def test_from_urls_constructs_get_requests(self):
- """Ensure a Queue is properly populated from an iterable of urls."""
- urls = ["https://httpbin.org/get?n={}".format(n) for n in range(5)]
-@@ -92,6 +95,7 @@ class TestPool(unittest.TestCase):
- for url in urls
- ]
-
-+ @pytest.mark.skipif(sys.hexversion < 0x3000000, reason="broken on python2")
- def test_from_urls_constructs_get_requests_with_kwargs(self):
- """Ensure a Queue is properly populated from an iterable of urls."""
- def merge(*args):
-@@ -130,6 +134,7 @@ class TestPool(unittest.TestCase):
- for st in session_threads:
- st.join.assert_called_once_with()
-
-+ @pytest.mark.skipif(sys.hexversion < 0x3000000, reason="broken on python2")
- def test_get_response_returns_thread_response(self):
- """Ensure that a ThreadResponse is made when there's data."""
- queues = []
-@@ -149,6 +154,7 @@ class TestPool(unittest.TestCase):
- assert isinstance(p.get_response(), pool.ThreadResponse)
- assert len([q for q in queues if q.get_nowait.called]) == 1
-
-+ @pytest.mark.skipif(sys.hexversion < 0x3000000, reason="broken on python2")
- def test_get_exception_returns_thread_exception(self):
- """Ensure that a ThreadException is made when there's data."""
- queues = []
-@@ -168,6 +174,7 @@ class TestPool(unittest.TestCase):
- assert isinstance(p.get_exception(), pool.ThreadException)
- assert len([q for q in queues if q.get_nowait.called]) == 1
-
-+ @pytest.mark.skipif(sys.hexversion < 0x3000000, reason="broken on python2")
- def test_get_response_returns_none_when_queue_is_empty(self):
- """Ensure that None is returned when the response Queue is empty."""
- queues = []
-@@ -187,6 +194,7 @@ class TestPool(unittest.TestCase):
- assert p.get_response() is None
- assert len([q for q in queues if q.get_nowait.called]) == 1
-
-+ @pytest.mark.skipif(sys.hexversion < 0x3000000, reason="broken on python2")
- def test_get_exception_returns_none_when_queue_is_empty(self):
- """Ensure that None is returned when the exception Queue is empty."""
- queues = []
diff --git a/dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild b/dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild
index c3c2c1f2eca4..ea834e88ccdd 100644
--- a/dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild
+++ b/dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild
@@ -29,11 +29,6 @@ PATCHES=(
"${FILESDIR}/requests-toolbelt-0.8.0-test-tracebacks.patch"
"${FILESDIR}/requests-toolbelt-0.9.1-tests.patch"
- # disable python2.7 test failures with newer requests versions
- # bug: https://bugs.gentoo.org/635824
- # https://github.com/requests/toolbelt/issues/213
- "${FILESDIR}/requests-toolbelt-0.9.1-tests-py2.patch"
-
# disable tests that require internet access
"${FILESDIR}/requests-toolbelt-0.9.1-tests-internet.patch"