summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-05-05 23:45:53 +0200
committerSebastian Pipping <sping@gentoo.org>2017-05-05 23:45:53 +0200
commit797e96637f9207fa40b5c3bff2bddda59b6dad2b (patch)
tree3ef57612b412735269ba369bd0893c82d9a10a4a
parentapp-office/libreoffice: 5.2.7.2 version bump (diff)
downloadgentoo-797e96637f9207fa40b5c3bff2bddda59b6dad2b.tar.gz
gentoo-797e96637f9207fa40b5c3bff2bddda59b6dad2b.tar.bz2
gentoo-797e96637f9207fa40b5c3bff2bddda59b6dad2b.zip
dev-python/html2text: 2016.9.19
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-python/html2text/Manifest1
-rw-r--r--dev-python/html2text/html2text-2016.9.19.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/html2text/Manifest b/dev-python/html2text/Manifest
index 513c3a813f41..617f01e63955 100644
--- a/dev-python/html2text/Manifest
+++ b/dev-python/html2text/Manifest
@@ -1 +1,2 @@
DIST html2text-2016.5.29.tar.gz 46879 SHA256 7f59fb29083a7819063b227c24a8dd5e25aeef74b68bf2318a68cc1e3e653add SHA512 58b71fda6ea6fd1a71dec757c91cf342265a2c89ff5c45e752436068419fb6c1faa1ca0d5a6baafaaa60186a85aefdd840989177ce30e55bcda1c6209fc375be WHIRLPOOL 23f8625952dbd3543687976fa2595a0859d18376e716e83848aec29f7f704e40c71142c3d01bdcbdc8f8542b1e03a5ee695da40d4b6b9d436108a10b1ad57456
+DIST html2text-2016.9.19.tar.gz 48003 SHA256 21c0237fae4f640eef53343a2965f44bfd907f0e1b956cd1171fb3884541767a SHA512 bfa7d051e49bea592413bc6e335aad34f6b10d3e718170e709dd9d4bb55cc26b7da4c3f64f512022efe41df80a1157b542ab2ca897612b702f9285cef3b44f40 WHIRLPOOL 7b39ab2351d057aa82b63cef0bcce71bb8d2ac053a940b01e9dcfb6ff4909d5cfb79ee52ebd6cd6f2998785808e9a925107c1f9cc7b3d4a2ea5aacd180af2f8c
diff --git a/dev-python/html2text/html2text-2016.9.19.ebuild b/dev-python/html2text/html2text-2016.9.19.ebuild
new file mode 100644
index 000000000000..e28994c5a64b
--- /dev/null
+++ b/dev-python/html2text/html2text-2016.9.19.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Turn HTML into equivalent Markdown-structured text"
+HOMEPAGE="https://github.com/html2text/html2text
+ https://github.com/Alir3z4/html2text https://pypi.python.org/pypi/html2text"
+SRC_URI="https://github.com/Alir3z4/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+
+DOCS=( AUTHORS.rst ChangeLog.rst README.md )
+
+src_prepare() {
+ default
+
+ # naming conflict with app-text/html2text, bug 421647
+ sed -i 's/html2text=html2text.cli:main/py\0/' setup.py || die
+}
+
+python_test() {
+ "${PYTHON}" test/test_html2text.py -v || die "tests failed with ${EPYTHON}"
+}