summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-07-13 15:16:11 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-07-13 15:16:11 -0400
commit7ba5ca4b7c2416acd1ee1298305ab1d24fe09bdd (patch)
treea90e3a5f6dc7f7e7359ae35488f0c5bd11ee6a17
parentkde-plasma/kactivities-workspace: Fix bogus deps (diff)
downloadgentoo-7ba5ca4b7c2416acd1ee1298305ab1d24fe09bdd.tar.gz
gentoo-7ba5ca4b7c2416acd1ee1298305ab1d24fe09bdd.tar.bz2
gentoo-7ba5ca4b7c2416acd1ee1298305ab1d24fe09bdd.zip
net-analyzer/nagircbot: add libressl support
Package-Manager: portage-2.2.28
-rw-r--r--net-analyzer/nagircbot/nagircbot-0.0.33.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-analyzer/nagircbot/nagircbot-0.0.33.ebuild b/net-analyzer/nagircbot/nagircbot-0.0.33.ebuild
index 5712d19a96e0..ea0a54b0dbd1 100644
--- a/net-analyzer/nagircbot/nagircbot-0.0.33.ebuild
+++ b/net-analyzer/nagircbot/nagircbot-0.0.33.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit toolchain-funcs
@@ -13,9 +13,11 @@ SRC_URI="http://www.vanheusden.com/nagircbot/${P}.tgz"
LICENSE="GPL-2" # GPL-2 only
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
+IUSE="libressl"
-CDEPEND="dev-libs/openssl"
+CDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
DEPEND="virtual/pkgconfig
${CDEPEND}"
RDEPEND="net-analyzer/nagios-core