summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-16 03:28:49 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-16 21:25:55 +0200
commit7e90cfe01e784e9dcb4c3cdbce3fe02dcae0ea78 (patch)
tree7a3b285630ce1a131daf4a136828740b466aedc9
parentdev-perl/SUPER: Add to tree at version 1.201.411.170 (diff)
downloadgentoo-7e90cfe01e784e9dcb4c3cdbce3fe02dcae0ea78.tar.gz
gentoo-7e90cfe01e784e9dcb4c3cdbce3fe02dcae0ea78.tar.bz2
gentoo-7e90cfe01e784e9dcb4c3cdbce3fe02dcae0ea78.zip
dev-perl/Test-MockModule: Bump to version 0.110.0
- EAPI6 - Cleanup tests Upstream: - unmock() on inherited subroutines will dispatch to the parent module, rather than replace the local subroutine with the parent's subroutine from the time of mocking (RT77439) Keywording: - New dependency causes the loss of: arm, hppa, ppc Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
-rw-r--r--dev-perl/Test-MockModule/Manifest1
-rw-r--r--dev-perl/Test-MockModule/Test-MockModule-0.110.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Test-MockModule/Manifest b/dev-perl/Test-MockModule/Manifest
index f9dc91c57ebe..2b626941c485 100644
--- a/dev-perl/Test-MockModule/Manifest
+++ b/dev-perl/Test-MockModule/Manifest
@@ -1 +1,2 @@
DIST Test-MockModule-0.05.tar.gz 5608 SHA256 67c515258c76780009e58305ec56f195e1b110d0cabb52792d57dd1761396e07 SHA512 8cbd2461dd0d9e9107c48a98be615c10dd77401569065a14cec555cc92f22c7211e7a7fb40149bd98c624bb1da838aa7be22a01391e2b6a70e7e58ec8af24da7 WHIRLPOOL 5d96b2a6050dce8b35a6bf842f10090bdf13b2382ef30877c7fd8db9499b4a7754b7d03be6d61f473aca185088961e1d7b9c2e1d70b0e7a998977e92da3a3fac
+DIST Test-MockModule-0.11.tar.gz 23756 SHA256 05584ba3a67f811e0d563eb9fb68049db0ee81c2cdaf56535067c6df922f14b9 SHA512 417a0de701458e3e26ea194cb2de7756d9a1665b2b7283a375ee95362ee2d7b77996801d4dafd8ead12e97d59c2a57ffd1e98620446d5f47a1836c8ef18983b4 WHIRLPOOL 7ba1cb00938b5d83292870565bcf4cd0502e9599b58ecaef86d422bd0ba7a0a74322aaa69507f2b9a64100aebe26818188d0665b46ff30a8d02c6e0821b11db3
diff --git a/dev-perl/Test-MockModule/Test-MockModule-0.110.0.ebuild b/dev-perl/Test-MockModule/Test-MockModule-0.110.0.ebuild
new file mode 100644
index 000000000000..12a21e35c6b0
--- /dev/null
+++ b/dev-perl/Test-MockModule/Test-MockModule-0.110.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_VERSION=0.11
+DIST_AUTHOR=GFRANKS
+inherit perl-module
+
+DESCRIPTION="Override subroutines in a module for unit testing"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/SUPER
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? ( >=virtual/perl-Test-Simple-0.450.0 )
+"
+src_test() {
+ perl_rm_files t/pod_coverage.t t/pod.t
+ perl-module_src_test
+}