summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2020-12-14 12:53:35 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2020-12-14 13:02:34 +0000
commit7ebb9f5de8c1784e402047cf49a061e8ce7ce500 (patch)
tree287fb1378ce9ed75eacecdfc41c7d5e52d68e470
parentx11-misc/synergy: Fix non-GUI build without avahi (diff)
downloadgentoo-7ebb9f5de8c1784e402047cf49a061e8ce7ce500.tar.gz
gentoo-7ebb9f5de8c1784e402047cf49a061e8ce7ce500.tar.bz2
gentoo-7ebb9f5de8c1784e402047cf49a061e8ce7ce500.zip
dev-python/slixmpp: run tests the right way
Upstream means the tests appropriate for this phase to be invoked via ./run_tests.py . Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
-rw-r--r--dev-python/slixmpp/slixmpp-1.5.2.ebuild4
-rw-r--r--dev-python/slixmpp/slixmpp-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/slixmpp/slixmpp-1.5.2.ebuild b/dev-python/slixmpp/slixmpp-1.5.2.ebuild
index 64f1fc02263a..4bdc2f5616c8 100644
--- a/dev-python/slixmpp/slixmpp-1.5.2.ebuild
+++ b/dev-python/slixmpp/slixmpp-1.5.2.ebuild
@@ -31,4 +31,6 @@ RDEPEND="
${DEPEND}
"
-distutils_enable_tests pytest
+python_test() {
+ "${EPYTHON}" ./run_tests.py || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/slixmpp/slixmpp-9999.ebuild b/dev-python/slixmpp/slixmpp-9999.ebuild
index 64f1fc02263a..4bdc2f5616c8 100644
--- a/dev-python/slixmpp/slixmpp-9999.ebuild
+++ b/dev-python/slixmpp/slixmpp-9999.ebuild
@@ -31,4 +31,6 @@ RDEPEND="
${DEPEND}
"
-distutils_enable_tests pytest
+python_test() {
+ "${EPYTHON}" ./run_tests.py || die "Tests failed with ${EPYTHON}"
+}