summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-10-12 07:35:46 +0200
committerJeroen Roovers <jer@gentoo.org>2015-10-12 07:35:46 +0200
commit7fe68b272f953a81bdee41ba14e2563f9653b1e1 (patch)
treeebb2d3c302277de2a042ea96ca6d9bb9dae19775
parentnet-im/gajim: Stable for PPC64 (bug #561644). (diff)
downloadgentoo-7fe68b272f953a81bdee41ba14e2563f9653b1e1.tar.gz
gentoo-7fe68b272f953a81bdee41ba14e2563f9653b1e1.tar.bz2
gentoo-7fe68b272f953a81bdee41ba14e2563f9653b1e1.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.2.23
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2015.10.12.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index ca92414fa535..4482648813bd 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2015.04.03.tar.gz 1472296 SHA256 0521a15a24a9b620728a2f45ea9163ca74660ed443781b6e69b4e06d36d7bf59 SHA512 6b2c85cfa222a31f3462aab583fa98bb92544cd5fb0d395ca0b69a26c24ab174870d02264e058281f09305752d50aa5a06d0d747205499a530b275e3194fc6f9 WHIRLPOOL 391e06ea261f92e03a0b38618307f1c9d53a2dfb9f2062fe0cd3ded1ea0c411033a17ded581616032c74a9e4fb398a57e565bf847196a23a9f89433f861362ae
DIST youtube-dl-2015.10.06.2.tar.gz 1753731 SHA256 5907be4d930ce68c3ed4b555e1c2f1f7a47069cfe7638300c4f124afca0fb25f SHA512 1114e5a65f204110f71890a6fe95a29fb5561bd60a928b9c198e921b153fd4e5b5b9cfd7cf87fcb377f1cc7878c6cbd9033108b932c36512cd9051090ba4162c WHIRLPOOL 6a0bb93f9ec9cc7381a5e9c0d60bfb617a29992b9f545882c827129a58d5c53bdc1da93f35af6e5a4442702364285c2c7f36f3b003e0881405e110233fe9f2db
DIST youtube-dl-2015.10.09.tar.gz 1754748 SHA256 33103a3197ee1bfa5e9fa78449ed19de888d6b36cc27f46f5c2e76ea11aee0ab SHA512 5e1c9e2344bd4b02834310be8cfae27f734a846d995a5890522ad9d2908832127ab20b76557a7986b146bb2ad7c278815c50523a946ee8a3eb2b5cd76db31290 WHIRLPOOL bd6f1b1525b5b2fae35490ba7823dde878d88f20f13d3f6de4a95a677ec03ed1b527ff8845406cdee658f6d6c668bd528f20863fb753616caab3fa3dfd8b0e44
+DIST youtube-dl-2015.10.12.tar.gz 1758938 SHA256 3e620a6d7edb656b48eef913d3350e925679ccdb959184c5fa88f4e55604289f SHA512 810ac5ad45c1fb7f01b09636f9fc1bfef1dc4bd4d00f8b6c50393e380e291a18b2410050c111f9f08f8a467df111afc7714043c5f766301aa2955e7d9a9e2168 WHIRLPOOL 6957b6a2bf883632087b4bd3830e1cf9ea12e91f90a08d334b0eda93a72b2c6f8a89a22f8df3fbdf90d1208af425b663bb258f5ddc7d3308d12ad3040ed3e8cf
diff --git a/net-misc/youtube-dl/youtube-dl-2015.10.12.ebuild b/net-misc/youtube-dl/youtube-dl-2015.10.12.ebuild
new file mode 100644
index 000000000000..db29af284def
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2015.10.12.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink drtuber eporner eroprofile extremetube
+ fourtube foxgay goshgay hellporno hentaistigma hornbunny keezmovies
+ mofosex motherless porn91 pornhd pornotube pornovoisines pornoxo
+ redtube sexykarma sexu sunporno slutload spankbang spankwire thisav
+ trutube tube8 vporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ youtube_dl/extractor/tumblr.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}