summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2016-10-15 12:55:06 +0200
committerHanno <hanno@gentoo.org>2016-10-15 12:55:06 +0200
commit8011caca58dc751581813c005155940b607df371 (patch)
tree175f317a69250754fbefbf2a8ff8ed8a59a5cd15
parentmail-filter/opensmtpd-extras: Remove short <longdescription /> that matches D... (diff)
downloadgentoo-8011caca58dc751581813c005155940b607df371.tar.gz
gentoo-8011caca58dc751581813c005155940b607df371.tar.bz2
gentoo-8011caca58dc751581813c005155940b607df371.zip
app-arch/unp: respect LINGUAS variable
Also port to EAPI 6, change upstream URL to https. Package-Manager: portage-2.3.2
-rw-r--r--app-arch/unp/unp-2.0_pre7_p1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-arch/unp/unp-2.0_pre7_p1-r1.ebuild b/app-arch/unp/unp-2.0_pre7_p1-r1.ebuild
new file mode 100644
index 000000000000..0c2a68df8c29
--- /dev/null
+++ b/app-arch/unp/unp-2.0_pre7_p1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Script for unpacking various file formats"
+HOMEPAGE="https://packages.qa.debian.org/u/unp.html"
+TEMP_PV="${PV/_pre/$'\x7e'pre}"
+MY_PV="${TEMP_PV/_p/+nmu}"
+SRC_URI="mirror://debian/pool/main/u/unp/${PN}_${MY_PV}.tar.bz2"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+PATCHES=( "${FILESDIR}/${P}-remove-deprecated-have.diff" )
+
+src_compile() {
+ if use nls; then
+ strip-linguas -i .
+ emake -C po MOFILES="${LINGUAS/ /.po }.po"
+ fi
+}
+
+src_install() {
+ dobin unp || die "dobin failed"
+ dosym /usr/bin/unp /usr/bin/ucat
+ doman debian/unp.1 || die "doman failed"
+ dodoc debian/changelog debian/README.Debian
+ dobashcomp bash_completion.d/unp
+
+ if use nls; then
+ emake -C po MOFILES="${LINGUAS/ /.mo }.mo" DESTDIR="${D}" install
+ fi
+}