summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-10-03 22:27:24 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-10-03 22:38:42 -0700
commit80261bb7bc5b4be5fc8141f4e98ec1f8ba8e9d0e (patch)
tree41248c9fa0ecd485d58d5d2be40070b5b7284106
parentmedia-libs/libtheora: Fix undefined behaviour, EAPI-7 bump (diff)
downloadgentoo-80261bb7bc5b4be5fc8141f4e98ec1f8ba8e9d0e.tar.gz
gentoo-80261bb7bc5b4be5fc8141f4e98ec1f8ba8e9d0e.tar.bz2
gentoo-80261bb7bc5b4be5fc8141f4e98ec1f8ba8e9d0e.zip
net-dns/dnscrypt-proxy: version bump to 2.0.17
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
-rw-r--r--net-dns/dnscrypt-proxy/Manifest1
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.17.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/net-dns/dnscrypt-proxy/Manifest b/net-dns/dnscrypt-proxy/Manifest
index 25ffa0e6c664..eba38c4d971d 100644
--- a/net-dns/dnscrypt-proxy/Manifest
+++ b/net-dns/dnscrypt-proxy/Manifest
@@ -1,2 +1,3 @@
DIST dnscrypt-proxy-2.0.16.tar.gz 3770249 BLAKE2B e6dc40ec503cff11e4deec1a243875fff42ec7ecba8c7c3552b69322d405c762fa152e7e9417baf944e2a476715f00813a305c20db583970520d35acd378f1d4 SHA512 f138df20560dd440a2ed390c1468d630191ae7b0e50521b4dde3fa7ef4377c3ae6409e8c547858bace53216c84aeeea6794305546b9ff87832f704c160c6782f
+DIST dnscrypt-proxy-2.0.17.tar.gz 3364933 BLAKE2B 65f2f1c91cc175a3bc92103dd0a2984dfccf5b961d070097035e8bd8058c7eab41c05cd3fabbff729f9521b16ebbfb188008c65efa5c89578b4b54ce43348d05 SHA512 c1cb2cfff4a5f6eba81ac3b520ddb3acb311031588495b9f94a7ee5ab35ed0827a856369ce0ac7ff206445dbf24f7931cf937ccd9f724b4e38c97f10814df129
DIST dnscrypt-proxy-da5ee45b8ceb9233f4bc21b2a5f1eb7c875947cc.tar.gz 3266257 BLAKE2B bc724b56ef75faf1e2416e81fe3e68947f1581ef1c85575b8c7c5bde721f41f32604835678923dd12654b23a2c97a7e84d598eb8c7a7f553cb59c998141ff19c SHA512 cd23bc4cee7a1d9337ad5a41cf49c5603d9bfb8b7a0458532de68df35f8bd1bb75c39c069dc692506673bdba485e360b23712e997072ed86b541597aa3ea9b12
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.17.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.17.ebuild
new file mode 100644
index 000000000000..e2157844bf14
--- /dev/null
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.17.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/jedisct1/${PN}"
+
+inherit fcaps golang-build systemd user
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://${EGO_PN}.git"
+else
+ SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
+HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="pie test"
+
+FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
+PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
+
+pkg_setup() {
+ enewgroup dnscrypt-proxy
+ enewuser dnscrypt-proxy -1 -1 /var/empty dnscrypt-proxy
+}
+
+src_prepare() {
+ default
+ # Create directory structure suitable for building
+ mkdir -p "src/${EGO_PN%/*}" || die
+ mv "${PN}" "src/${EGO_PN}" || die
+ mv "vendor" "src/" || die
+}
+
+src_configure() {
+ EGO_BUILD_FLAGS="-buildmode=$(usex pie pie default)"
+}
+
+src_install() {
+ dobin dnscrypt-proxy
+
+ insinto /etc/dnscrypt-proxy
+ newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
+ doins "src/${EGO_PN}"/example-{blacklist.txt,whitelist.txt}
+ doins "src/${EGO_PN}"/example-{cloaking-rules.txt,forwarding-rules.txt}
+
+ insinto /usr/share/dnscrypt-proxy
+ doins -r "utils/generate-domains-blacklists/."
+
+ newinitd "${FILESDIR}"/dnscrypt-proxy.initd dnscrypt-proxy
+ newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy
+ systemd_newunit "${FILESDIR}"/dnscrypt-proxy.service dnscrypt-proxy.service
+ systemd_newunit "${FILESDIR}"/dnscrypt-proxy.socket dnscrypt-proxy.socket
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ if ! use filecaps; then
+ ewarn "'filecaps' USE flag is disabled"
+ ewarn "${PN} will fail to listen on port 53"
+ ewarn "please do one the following:"
+ ewarn "1) re-enable 'filecaps'"
+ ewarn "2) change port to > 1024"
+ ewarn "3) configure to run ${PN} as root (not recommended)"
+ ewarn
+ fi
+
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ ${v} == 1.* ]] ; then
+ elog "Version 2 is a complete rewrite of ${PN}"
+ elog "please clean up old config/log files"
+ elog
+ fi
+ if [[ ${v} == 2.* ]] ; then
+ elog "As of version 2.0.12 of ${PN} runs as an 'dnscrypt-proxy' user/group"
+ elog "you can remove obsolete 'dnscrypt' accounts from the system"
+ elog
+ fi
+ done
+
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog "Using systemd socket activation may cause issues with speed"
+ elog "latency and reliability of ${PN} and is discouraged by upstream"
+ elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
+ elog "It is disabled by default for new installations"
+ elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
+ elog
+
+ fi
+
+ elog "After starting the service you will need to update your"
+ elog "/etc/resolv.conf and replace your current set of resolvers"
+ elog "with:"
+ elog
+ elog "nameserver 127.0.0.1"
+ elog
+ elog "Also see https://github.com/jedisct1/${PN}/wiki"
+}