summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-17 11:20:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-17 14:02:22 +0200
commit80dfffe14e4abcf01a126c1405770e022e04b039 (patch)
tree9359697bc3fe7293c081f5a1305641cdc1a95333
parentsci-chemistry/molequeue: 0.9.0 version bump, build with Qt-5.11_beta3 (diff)
downloadgentoo-80dfffe14e4abcf01a126c1405770e022e04b039.tar.gz
gentoo-80dfffe14e4abcf01a126c1405770e022e04b039.tar.bz2
gentoo-80dfffe14e4abcf01a126c1405770e022e04b039.zip
media-libs/liblastfm: Fix cmake/Qt-5.11_beta3 patch
Closes: https://bugs.gentoo.org/653316 Package-Manager: Portage-2.3.29, Repoman-2.3.9
-rw-r--r--media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-cmake.patch97
-rw-r--r--media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-qt-5.11b3.patch114
-rw-r--r--media-libs/liblastfm/liblastfm-1.1.0_pre20150206.ebuild5
3 files changed, 111 insertions, 105 deletions
diff --git a/media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-cmake.patch b/media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-cmake.patch
deleted file mode 100644
index a42baf0ca30e..000000000000
--- a/media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-cmake.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-From 8703c12d7a177627fab4a2f67018d01cc7bf0808 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 1 Apr 2018 11:51:42 +0200
-Subject: [PATCH 1/3] Make Qt5 build default and simplify logic, add missing
- deps
-
----
- CMakeLists.txt | 10 +++-------
- 1 file changed, 3 insertions(+), 7 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index be88967..a8c81dd 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -27,16 +27,12 @@ set(CMAKE_MODULE_PATH "${CMAKE_MODULE_PATH}" "${PROJECT_SOURCE_DIR}/cmake/Module
- # setup qt stuff
- set(CMAKE_AUTOMOC ON)
-
--option(BUILD_WITH_QT4 "Build liblastfm with Qt4 no matter if Qt5 was found" OFF)
-+option(BUILD_WITH_QT4 "Build liblastfm with Qt4" OFF)
-
--if( NOT BUILD_WITH_QT4 )
-- # try Qt5 first, and prefer that if found
-- find_package(Qt5Core QUIET)
--endif()
-+if(NOT BUILD_WITH_QT4)
-+ find_package(Qt5 CONFIG REQUIRED Core Network Sql Xml)
-
--if(Qt5Core_DIR)
- set(LASTFM_LIB_VERSION_SUFFIX 5)
-- message(STATUS "Found Qt5! Please keep in mind, this is highly experimental and not our main development target..")
- include_directories(${Qt5Core_INCLUDE_DIRS})
- if(UNIX AND NOT APPLE)
- find_package(Qt5DBus REQUIRED)
---
-2.16.3
-
-
-From 22f6900552839bc90c0fc68b62707d42544eaccf Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 1 Apr 2018 11:56:48 +0200
-Subject: [PATCH 2/3] Make use of FeatureSummary
-
----
- CMakeLists.txt | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a8c81dd..d5fd5b1 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -20,6 +20,7 @@ option(BUILD_TESTS "Build liblastfm tests" ON)
-
- # installation dirs
- include(GNUInstallDirs)
-+include(FeatureSummary)
-
- #cmake module path
- set(CMAKE_MODULE_PATH "${CMAKE_MODULE_PATH}" "${PROJECT_SOURCE_DIR}/cmake/Modules")
-@@ -93,3 +94,5 @@ if(BUILD_TESTS)
- enable_testing()
- add_subdirectory(tests)
- endif()
-+
-+feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
---
-2.16.3
-
-
-From bf3ee28f1aa5de7a3f3f5a3077adc97804e27b0e Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 1 Apr 2018 12:06:48 +0200
-Subject: [PATCH 3/3] Cleanup include dirs
-
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index d5fd5b1..ef7fdd5 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -34,10 +34,10 @@ if(NOT BUILD_WITH_QT4)
- find_package(Qt5 CONFIG REQUIRED Core Network Sql Xml)
-
- set(LASTFM_LIB_VERSION_SUFFIX 5)
-- include_directories(${Qt5Core_INCLUDE_DIRS})
- if(UNIX AND NOT APPLE)
- find_package(Qt5DBus REQUIRED)
- endif()
-+ include_directories(Qt5::Core Qt5::Network Qt5::Xml)
-
- # macro(qt_wrap_ui)
- # qt5_wrap_ui(${ARGN})
---
-2.16.3
-
diff --git a/media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-qt-5.11b3.patch b/media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-qt-5.11b3.patch
index dfbd694ed3d5..fc0e9b8938dd 100644
--- a/media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-qt-5.11b3.patch
+++ b/media-libs/liblastfm/files/liblastfm-1.1.0_pre20150206-qt-5.11b3.patch
@@ -1,7 +1,113 @@
-From 5d6ef4c27804a43b26dffcb46d6b27523a1ca340 Mon Sep 17 00:00:00 2001
+From 62a08d490a1e75e3ef5d08f3fb37e65c1563e706 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 1 Apr 2018 11:51:42 +0200
+Subject: [PATCH 1/4] Make Qt5 build default and simplify logic, add missing
+ deps
+
+---
+ CMakeLists.txt | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index be88967..e628611 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -27,19 +27,19 @@ set(CMAKE_MODULE_PATH "${CMAKE_MODULE_PATH}" "${PROJECT_SOURCE_DIR}/cmake/Module
+ # setup qt stuff
+ set(CMAKE_AUTOMOC ON)
+
+-option(BUILD_WITH_QT4 "Build liblastfm with Qt4 no matter if Qt5 was found" OFF)
++option(BUILD_WITH_QT4 "Build liblastfm with Qt4" OFF)
+
+-if( NOT BUILD_WITH_QT4 )
+- # try Qt5 first, and prefer that if found
+- find_package(Qt5Core QUIET)
+-endif()
++if(NOT BUILD_WITH_QT4)
++ find_package(Qt5 REQUIRED COMPONENTS Core Network Xml CONFIG)
++
++ if(BUILD_FINGERPRINT)
++ find_package(Qt5Sql REQUIRED CONFIG)
++ endif()
+
+-if(Qt5Core_DIR)
+ set(LASTFM_LIB_VERSION_SUFFIX 5)
+- message(STATUS "Found Qt5! Please keep in mind, this is highly experimental and not our main development target..")
+ include_directories(${Qt5Core_INCLUDE_DIRS})
+ if(UNIX AND NOT APPLE)
+- find_package(Qt5DBus REQUIRED)
++ find_package(Qt5DBus REQUIRED CONFIG)
+ endif()
+
+ # macro(qt_wrap_ui)
+--
+2.17.0
+
+
+From ff32d56e5e1bd8b1f86a8e9840c778249ff19118 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 1 Apr 2018 11:56:48 +0200
+Subject: [PATCH 2/4] Make use of FeatureSummary
+
+---
+ CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e628611..dcdfd91 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -20,6 +20,7 @@ option(BUILD_TESTS "Build liblastfm tests" ON)
+
+ # installation dirs
+ include(GNUInstallDirs)
++include(FeatureSummary)
+
+ #cmake module path
+ set(CMAKE_MODULE_PATH "${CMAKE_MODULE_PATH}" "${PROJECT_SOURCE_DIR}/cmake/Modules")
+@@ -97,3 +98,5 @@ if(BUILD_TESTS)
+ enable_testing()
+ add_subdirectory(tests)
+ endif()
++
++feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
+--
+2.17.0
+
+
+From 5762278b29c1ab6559dcca7a1e8fbad1d75134da Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 1 Apr 2018 12:06:48 +0200
+Subject: [PATCH 3/4] Cleanup include dirs
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index dcdfd91..52589b5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -38,10 +38,10 @@ if(NOT BUILD_WITH_QT4)
+ endif()
+
+ set(LASTFM_LIB_VERSION_SUFFIX 5)
+- include_directories(${Qt5Core_INCLUDE_DIRS})
+ if(UNIX AND NOT APPLE)
+ find_package(Qt5DBus REQUIRED CONFIG)
+ endif()
++ include_directories(Qt5::Core Qt5::Network Qt5::Xml)
+
+ # macro(qt_wrap_ui)
+ # qt5_wrap_ui(${ARGN})
+--
+2.17.0
+
+
+From aeb0cbc56376021444a56a984613faacefedfea9 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
Date: Sun, 15 Apr 2018 21:31:14 +0200
-Subject: [PATCH] Fix build with Qt 5.11_beta3 (drop qt5_use_modules)
+Subject: [PATCH 4/4] Fix build with Qt 5.11_beta3 (drop qt5_use_modules)
---
CMakeLists.txt | 3 --
@@ -11,10 +117,10 @@ Subject: [PATCH] Fix build with Qt 5.11_beta3 (drop qt5_use_modules)
4 files changed, 55 insertions(+), 47 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index be88967..57da635 100644
+index 52589b5..c8bc89d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -56,9 +56,6 @@ if(Qt5Core_DIR)
+@@ -57,9 +57,6 @@ if(NOT BUILD_WITH_QT4)
# endmacro()
else()
find_package(Qt4 COMPONENTS QtCore QtNetwork QtXml REQUIRED)
diff --git a/media-libs/liblastfm/liblastfm-1.1.0_pre20150206.ebuild b/media-libs/liblastfm/liblastfm-1.1.0_pre20150206.ebuild
index 6e0926da1028..b20109621436 100644
--- a/media-libs/liblastfm/liblastfm-1.1.0_pre20150206.ebuild
+++ b/media-libs/liblastfm/liblastfm-1.1.0_pre20150206.ebuild
@@ -33,10 +33,7 @@ DEPEND="${RDEPEND}
# 1 of 2 (UrlBuilderTest) is failing, last checked version 1.0.9
RESTRICT="test"
-PATCHES=(
- "${FILESDIR}/${P}-cmake.patch"
- "${FILESDIR}/${P}-qt-5.11b3.patch"
-)
+PATCHES=( "${FILESDIR}/${P}-qt-5.11b3.patch" )
src_configure() {
# demos not working