summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-08-19 16:42:09 +0200
committerMichael Weber <xmw@gentoo.org>2016-08-19 16:53:37 +0200
commit8100a3ba123d59bd291f7c99e8eaf3fffc75b9ec (patch)
treed0f564d67a5ac30d6644d8faa3f7cfbc38bd2ad3
parentdev-ml/cppo: bump to 1.4.0 (diff)
downloadgentoo-8100a3ba123d59bd291f7c99e8eaf3fffc75b9ec.tar.gz
gentoo-8100a3ba123d59bd291f7c99e8eaf3fffc75b9ec.tar.bz2
gentoo-8100a3ba123d59bd291f7c99e8eaf3fffc75b9ec.zip
dev-util/pycharm-community: Version bump (bug 589840, thanks lumbrius@gmail.com and c.a.strahl@gmail.com for testing).
Package-Manager: portage-2.2.28
-rw-r--r--dev-util/pycharm-community/Manifest1
-rw-r--r--dev-util/pycharm-community/pycharm-community-2016.2.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index 766e36fd1177..9aef69b93b02 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -1,2 +1,3 @@
DIST pycharm-community-2016.1.3.tar.gz 207707566 SHA256 98c406abf20cbe18565dfe17a62ac7dba094ed15100aab566ff343eb726647cf SHA512 09327867d231b311616d76d860e27ed0c1ac20ca86eda0be9d58666993b860f3c562fa5ce7e533f898eccf7ad2c72954681c83095310bfe01c428a64c59a475e WHIRLPOOL eb03ad07a14707d0650b9991e0494e299336bb61722b6384fa1a2721cc8b692a031ac84f4cfdbd909a45bbacc6d2e1e3d6eec0e5c202a22133f953a402b38b6d
DIST pycharm-community-2016.1.4.tar.gz 207346180 SHA256 bc548a200022111e741604e76b579e71e5a75d23c2bbb9c4cb9ed88b18a3d622 SHA512 f86726d921baec5a5f2691f7e9ee4f81d4abd3a55edc09f091593434d79a51e0058025eb52f1ca5455844d47d325e209f73d7e701d218db57bcf9502244201d6 WHIRLPOOL 9e51cb7f5c2e3530666831803c4bc0dfe8d36b58da0e593763028e9097f95e778098923f837a771c063fa1336cf3a58ba4ebe14cddbbec6f9c74921a1deedb9c
+DIST pycharm-community-2016.2.1.tar.gz 212670595 SHA256 76a5d58a6ecbafa48abde9823948f0614472ecbc0535c639ceb593569a1e06a7 SHA512 46777642ca0adb6aa40828d37328846b399b44c6625065ed00a6d2d46b3c82f10f1640a4206d703be84c3429ec2d76a71dfdb38fe9ae70a8b094d518d0f3a60b WHIRLPOOL 086aa3c1e05d0c0ba7fddb904a3e793dfcf00a9bd830fdd65b3bdf70b8ad9cb700fead63be7186a90b5a32a9b3584afa89a9a84c098d24dedc82daedca49ea9b
diff --git a/dev-util/pycharm-community/pycharm-community-2016.2.1.ebuild b/dev-util/pycharm-community/pycharm-community-2016.2.1.ebuild
new file mode 100644
index 000000000000..233c50990d3d
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2016.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils readme.gentoo-r1
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.8"
+DEPEND=""
+
+RESTRICT="mirror strip"
+QA_PREBUILT="/opt/${PN}/bin/fsnotifier
+ /opt/${PN}/bin/fsnotifier64"
+
+MY_PN=${PN/-community/}
+
+QA_PREBUILT="*"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon "bin/${MY_PN}.png" ${PN}.png
+ make_desktop_entry ${PN} "${PN}" "${PN}"
+
+ readme.gentoo_create_doc
+}