summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-06-16 11:18:06 -0400
committerMatt Turner <mattst88@gentoo.org>2023-06-16 11:18:36 -0400
commit81ab240277694a0d2b23e0109826c236714c1fff (patch)
treeb6e02b929ba923d5c4fdc39e34c36db250cee109
parentsci-geosciences/gpxsee: bump to 13.4 (diff)
downloadgentoo-81ab240277694a0d2b23e0109826c236714c1fff.tar.gz
gentoo-81ab240277694a0d2b23e0109826c236714c1fff.tar.bz2
gentoo-81ab240277694a0d2b23e0109826c236714c1fff.zip
x11-base/xorg-proto: Version bump to 2023.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-base/xorg-proto/Manifest1
-rw-r--r--x11-base/xorg-proto/xorg-proto-2023.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/x11-base/xorg-proto/Manifest b/x11-base/xorg-proto/Manifest
index 6f7afb747bc8..25c2c1adeba2 100644
--- a/x11-base/xorg-proto/Manifest
+++ b/x11-base/xorg-proto/Manifest
@@ -1,2 +1,3 @@
DIST xorgproto-2022.2.tar.xz 757080 BLAKE2B 0fee7910fced83548780fd1c7bfd214c932c7c5064c6ebd40ac9285d071837056b9eca24dadb53a572a05768f8762c4dd81ac58fcf6b43028f557ed56a98f7f9 SHA512 8e6108110600d076a94cc6d0e465b2e9adfbbe8d7e6b75fae9c5262d99dc6074ab1ed561a74d6d451f00f5b7af9f507a6317be9c0770efeed9e60b64beb7a1c9
DIST xorgproto-2023.1.tar.xz 759168 BLAKE2B e794f8acb2b01f97cee80b01b3b67aa0691517d4eb17c5304768932785b087d86bc610e9e448c623e31b665e72c4b4c0432766767e01e8d835d88a3bf45adce6 SHA512 342128ca2e9a6806a7ff33f426434bee29626a13a592b9544654a010cb7be208b0862e3cd063773a0003ca0ec7d48361cfcc384fe207efe9ecb6ec3f2b8e7d56
+DIST xorgproto-2023.2.tar.xz 759040 BLAKE2B ff255b91770ad11cdcc48d12815317285d8d16d28011a86166f3e07af18b30fdf35c2eb7b6537504eb4c0e9ca65b3116493422b6faebe04ee80e6aee92387675 SHA512 af0a8c8094fc6a490a886a8c048175762b6334798f2e48b6f6e19a7bb39ddbef05fa1237c4e9d9f1d870d24f5ca7a7c463044c41ceebd108f8ab0816677a582d
diff --git a/x11-base/xorg-proto/xorg-proto-2023.2.ebuild b/x11-base/xorg-proto/xorg-proto-2023.2.ebuild
new file mode 100644
index 000000000000..5e165a925d02
--- /dev/null
+++ b/x11-base/xorg-proto/xorg-proto-2023.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+MY_PN="${PN/xorg-/xorg}"
+MY_P="${MY_PN}-${PV}"
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/${MY_PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson python-any-r1
+
+DESCRIPTION="X.Org combined protocol headers"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.xz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ python_has_version "dev-python/python-libevdev[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/share/doc/{xorgproto,${P}} || die
+}