summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-07-24 11:53:27 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-07-25 19:27:49 +0200
commit81e94287a5769df3a005373ce8b7d7f4b04c9052 (patch)
tree10cf2e673b1d265da17de0f8e4ac22ebc8683a79
parentdev-python/s3fs: version bump. (diff)
downloadgentoo-81e94287a5769df3a005373ce8b7d7f4b04c9052.tar.gz
gentoo-81e94287a5769df3a005373ce8b7d7f4b04c9052.tar.bz2
gentoo-81e94287a5769df3a005373ce8b7d7f4b04c9052.zip
app-vim/syntastic: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--app-vim/syntastic/Manifest1
-rw-r--r--app-vim/syntastic/syntastic-3.9.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-vim/syntastic/Manifest b/app-vim/syntastic/Manifest
index b641bad03ba3..2ddcf65d0cc3 100644
--- a/app-vim/syntastic/Manifest
+++ b/app-vim/syntastic/Manifest
@@ -1 +1,2 @@
DIST syntastic-3.8.0.tar.gz 253425 BLAKE2B a003b9166aba2915b5421ac02544d128b8befca0af4f15c880f56ad046fad0ca7c202e6f7dda44588a6ad4ac3b77a3ed3602613855c6755261b5941d45464eff SHA512 b2f7fb07d457169a397a1ed42141e099cad14ded0b43f54a11060f2952843387396fcc539ffc9aaa1aa137ae62801e346a73c6de6035a0504706c59e40acef5c
+DIST syntastic-3.9.0.tar.gz 263275 BLAKE2B 574cf958b859a108cdfdffed29b3ff0f0903dac5c7fbc497e2c69831ee35532d317bde0ab827dda828ee7cb3cc13ab9176c9ea6ea233e03e7b3fcb5b7c49757e SHA512 04cee939226940bb95935434b7aba42a3419b8b7b73d5fa9052a6aaccec5d0724c4e3634edd56573d0080b31baf49c1a00811c6f88e4fbbdea7e761e5707dcb5
diff --git a/app-vim/syntastic/syntastic-3.9.0.ebuild b/app-vim/syntastic/syntastic-3.9.0.ebuild
new file mode 100644
index 000000000000..6776db4e00ef
--- /dev/null
+++ b/app-vim/syntastic/syntastic-3.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scrooloose/syntastic.git"
+else
+ SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: syntax checking using external tools"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2736 https://github.com/scrooloose/syntastic/"
+LICENSE="WTFPL-2"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ default
+ rm -r _assets LICENCE README.markdown || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Syntastic has many optional dependencies depending on the type"
+ elog "of syntax checking being performed. Look in the related files in"
+ elog "the syntax_checkers directory to help figure out what programs"
+ elog "different languages need."
+ fi
+}