summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-12 10:42:33 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-12 10:45:26 +0200
commit83448cbe1c00975628a0aaf35d008653ac38e6ee (patch)
tree05300aac5e824803cd36215dee5971f58e6e47c3
parentsys-block/parted: ia64 stable, bug #618186 (diff)
downloadgentoo-83448cbe1c00975628a0aaf35d008653ac38e6ee.tar.gz
gentoo-83448cbe1c00975628a0aaf35d008653ac38e6ee.tar.bz2
gentoo-83448cbe1c00975628a0aaf35d008653ac38e6ee.zip
media-sound/mpg123: Bump to version 1.25.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--media-sound/mpg123/Manifest1
-rw-r--r--media-sound/mpg123/mpg123-1.25.2.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/media-sound/mpg123/Manifest b/media-sound/mpg123/Manifest
index cdf3b041e55d..9036b437cac1 100644
--- a/media-sound/mpg123/Manifest
+++ b/media-sound/mpg123/Manifest
@@ -1,3 +1,4 @@
DIST mpg123-1.24.0.tar.bz2 912049 SHA256 55fb169a7711938f5df0497d1ffe28419fbef50011dc01d00b216379e6a2256c SHA512 e7c0d7a103daf496e75a6aa6aca861cfc0ad391f242335990c2360305e567039d24ca3b37a35f79b75749055e255f4692b8b43d2fec332b119223b00e12b0cb7 WHIRLPOOL 3d1c882c4c2c0cf8fc575be3a65f9c9d61a1549f75abeb983c2bafef3c303507bdc494594060bc732096c3d7fb96c372d2554a698a46a19c1c6e5f48e5e61771
DIST mpg123-1.25.0.tar.bz2 917205 SHA256 552e3e1db045e00f474252917007795ac295863fc8b13891859b3382d2f24e48 SHA512 fc5047fe88639b1cd5c44cdd054d452984abfbf572d064c7f465b7cef8a03b389591daf4934010f227a28d0e12bf0b0214d0c92132e893af90cd859389558e3c WHIRLPOOL c4fb1c198f29a41d494e1442223532ec65712f6f83bf8eb12ab60fee7a3a61652e0f7be8d42bff747bc1f1d0c0615256238abc98fa9b5812889959ab1a49eef9
DIST mpg123-1.25.1.tar.bz2 917500 SHA256 0fe7270a4071367f97a7c1fb45fb2ef3cfef73509c205124e080ea569217b05f SHA512 5857fc91baf913e3116a808657d2246cf7662944a991652e53130b70464d821469c72574dff4d227c600276c0ec7e83990bdb99b6ce0144d167cc666f0a70789 WHIRLPOOL 79a6bd6c84f4d7c2485ad10bb47ac75302acbbca7da0724aee15626f0f539e07aa8bc101508951f1e44241b035d70218193fa2c6ebafa46760224afca70d5e65
+DIST mpg123-1.25.2.tar.bz2 918024 SHA256 5314b0fb8ad291bfc79ff4c5c321b971916819a65233ec065434358fcf8aee38 SHA512 1b063a7a497d6f643b43a0e0db0e1a8951bf110cabf8f3dc63d7ed1b8e47ef4a42649622a5e4efb582479beacd7d3872b4f061716a5f6970b3f5bed7ef4f3fe9 WHIRLPOOL e8d6e74b857cac86e77651339d3491088ac5024aae149bbcc691a28bb8cda46395ab8f4505d2ff7eb6ba3311c97db1baa64c686ed508adb0ba3c91cd2faf1e32
diff --git a/media-sound/mpg123/mpg123-1.25.2.ebuild b/media-sound/mpg123/mpg123-1.25.2.ebuild
new file mode 100644
index 000000000000..37789fbf780b
--- /dev/null
+++ b/media-sound/mpg123/mpg123-1.25.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic toolchain-funcs libtool multilib-minimal
+
+DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="http://www.mpg123.org/"
+SRC_URI="http://www.mpg123.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext alsa altivec coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
+
+# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
+RDEPEND="app-eselect/eselect-mpg123
+ dev-libs/libltdl:0
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ nas? ( media-libs/nas )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-soundlibs-20130224-r9
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
+
+pkg_setup() {
+ # Build fails without -D_GNU_SOURCE like this:
+ # error: ‘struct hostent’ has no member named ‘h_addr’
+ append-cflags -D_GNU_SOURCE
+}
+
+src_prepare() {
+ default
+ elibtoolize # for Darwin bundles
+}
+
+multilib_src_configure() {
+ local _audio=dummy
+ local _output=dummy
+ local _cpu=generic_fpu
+
+ if $(multilib_is_native_abi) ; then
+ for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
+ if use ${flag}; then
+ _audio+=" ${flag/pulseaudio/pulse}"
+ _output=${flag/pulseaudio/pulse}
+ fi
+ done
+ fi
+
+ use altivec && _cpu=altivec
+
+ if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
+ use cpu_flags_x86_sse && _cpu=x86-64
+ elif use x86 && gcc-specs-pie ; then
+ # Don't use any mmx, 3dnow, sse and 3dnowext #bug 164504
+ _cpu=generic_fpu
+ elif use x86-macos ; then
+ # ASM doesn't work quite as expected with the Darwin linker
+ _cpu=generic_fpu
+ else
+ use cpu_flags_x86_mmx && _cpu=mmx
+ use cpu_flags_x86_3dnow && _cpu=3dnow
+ use cpu_flags_x86_sse && _cpu=x86
+ use cpu_flags_x86_3dnowext && _cpu=x86
+ fi
+
+ local myconf=""
+ multilib_is_native_abi || myconf="${myconf} --disable-modules"
+
+ ECONF_SOURCE="${S}" econf \
+ --with-optimization=0 \
+ --with-audio="${_audio}" \
+ --with-default-audio=${_output} \
+ --with-cpu=${_cpu} \
+ --enable-network \
+ $(use_enable ipv6) \
+ --enable-int-quality=$(usex int-quality) \
+ ${myconf}
+
+ if ! $(multilib_is_native_abi) ; then
+ sed -i -e 's:src doc:src/libmpg123:' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ mv "${ED}"/usr/bin/mpg123{,-mpg123}
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+}
+
+pkg_postinst() {
+ eselect mpg123 update ifunset
+}
+
+pkg_postrm() {
+ eselect mpg123 update ifunset
+}