summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-06-02 02:05:20 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-06-02 02:08:52 +1000
commit83cf9006ffff43c39ad42faab8705f05235bad23 (patch)
tree852c840da1b378f93aafff5da56d4d661a9da82e
parentnet-misc/openntpd-6.0_p1-r0: add alpha keyword (diff)
downloadgentoo-83cf9006ffff43c39ad42faab8705f05235bad23.tar.gz
gentoo-83cf9006ffff43c39ad42faab8705f05235bad23.tar.bz2
gentoo-83cf9006ffff43c39ad42faab8705f05235bad23.zip
dev-lang/dmd-bin: remove last-rited package
Gentoo-bug: 212793
-rw-r--r--dev-lang/dmd-bin/Manifest2
-rw-r--r--dev-lang/dmd-bin/dmd-bin-1.016.ebuild109
-rw-r--r--dev-lang/dmd-bin/dmd-bin-2.008-r1.ebuild105
-rw-r--r--dev-lang/dmd-bin/files/25dmd2
-rw-r--r--dev-lang/dmd-bin/metadata.xml9
5 files changed, 0 insertions, 227 deletions
diff --git a/dev-lang/dmd-bin/Manifest b/dev-lang/dmd-bin/Manifest
deleted file mode 100644
index 85904b4c011d..000000000000
--- a/dev-lang/dmd-bin/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST dmd.1.016.zip 4813864 SHA256 839c0d0288560989e16271e842c368347ff392c648b8fe5e4daa9853dfd6684d SHA512 d7d801904c706b2a1fbecadc51a49f2549a4a8b2da6027195d56c9ff2a271ad2f90eb091b80066a0a4608d38905de988a7320c9c720df876bad79dd4f5c14674 WHIRLPOOL 619d0d5a5baf849fff96433b332b99fc868bb30f6cfeab1221f217c953d546312c0ebc088f782edbfcd1630d4541f998167493df20bf90288c718fb51fc6f993
-DIST dmd.2.008.zip 5325757 SHA256 8d8a0b4399ebf1ecc7e88ee68852db5e944ec7b88607d7c02a150bfcdfaf2b64 SHA512 a66aa0141147f2c6a46938c235bc2f7747f493fd09c5265b7d6bb77242075f5e262efb2b03425f2e2ed1e6b7c2bef4ab4c0e935e1ce8167738abb86f4967db96 WHIRLPOOL 356f307353a57fa75a32866d7c21b95f92da308bd6d2afc8bb7bc559a6f18138c6f17975b2b4ea7e332130bbb5e37d1b0ec96ac28d63331a8b13b972e959d8de
diff --git a/dev-lang/dmd-bin/dmd-bin-1.016.ebuild b/dev-lang/dmd-bin/dmd-bin-1.016.ebuild
deleted file mode 100644
index 31876f81e6de..000000000000
--- a/dev-lang/dmd-bin/dmd-bin-1.016.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils
-
-MY_P=${P/-bin/}
-MY_P=${MY_P/-/.}
-
-DESCRIPTION="Digital Mars D Compiler"
-HOMEPAGE="http://www.digitalmars.com/d/"
-SRC_URI="http://ftp.digitalmars.com/${MY_P}.zip"
-
-LICENSE="DMD"
-SLOT="0"
-KEYWORDS="~x86"
-RESTRICT="mirror strip"
-
-LOC="/opt/dmd"
-S="${WORKDIR}"
-
-DEPEND="sys-apps/findutils
- app-arch/unzip"
-RDEPEND="~virtual/libstdc++-3.3"
-
-src_unpack() {
- unpack ${A}
-
- # Remove unneccessary files
- mv "${S}"/dmd/lib/libphobos.a "${S}"/dmd
- rm -r "${S}"/dmd/lib
- mkdir "${S}"/dmd/lib
- mv "${S}"/dmd/libphobos.a "${S}"/dmd/lib
-
- rm -r "${S}"/dm
- rm "${S}"/dmd/bin/*.dll "${S}"/dmd/bin/*.exe "${S}"/dmd/bin/readme.txt
- rm "${S}"/dmd/bin/sc.ini "${S}"/dmd/bin/windbg.hlp
-
- # Cleanup line endings
- cd "${S}"/dmd
- edos2unix `find . -name '*.c' -type f`
- edos2unix `find . -name '*.d' -type f`
- edos2unix `find . -name '*.ddoc' -type f`
- edos2unix `find . -name '*.h' -type f`
- edos2unix `find . -name '*.mak' -type f`
- edos2unix `find . -name '*.txt' -type f`
- edos2unix `find samples -name '*.html' -type f`
-
- # Fix permissions
- fperms guo=r `find . -type f`
- fperms guo=rx `find . -type d`
- fperms guo=rx bin/dmd bin/dumpobj bin/obj2asm bin/rdmd
-}
-
-src_compile() {
- cd "${S}"/dmd/src/phobos
- sed -i -e "s:DMD=.*:DMD=${S}/dmd/bin/dmd -I${S}/dmd/src/phobos -L${S}/dmd/lib/libphobos.a:" linux.mak internal/gc/linux.mak
- edos2unix linux.mak internal/gc/linux.mak
- make -f linux.mak
- cp libphobos.a "${S}"/dmd/lib
-
- # Clean up
- make -f linux.mak clean
- rm internal/gc/*.o
-}
-
-src_install() {
- cd "${S}"/dmd
-
- # Broken dmd.conf
- # http://d.puremagic.com/issues/show_bug.cgi?id=278
- mv bin/dmd bin/dmd.bin
- cat <<END > "bin/dmd"
-#!/bin/sh
-${LOC}/bin/dmd.bin -I${LOC}/src/phobos -L${LOC}/lib/libphobos.a \$*
-END
- fperms guo=rx bin/dmd bin/dmd.bin
-
- # Man pages
- doman man/man1/dmd.1
- doman man/man1/dumpobj.1
- doman man/man1/obj2asm.1
- rm -r man
-
- # Install
- mkdir "${D}/opt"
- mv "${S}/dmd" "${D}/opt/dmd"
-
- # Set PATH
- doenvd "${FILESDIR}/25dmd"
-}
-
-pkg_postinst () {
- ewarn "The DMD Configuration file has been disabled, "
- ewarn "and will be re-enabled when: "
- ewarn " "
- ewarn "http://d.puremagic.com/issues/show_bug.cgi?id=278"
- ewarn " "
- ewarn "has been fixed. Meanwhile, please supply all your"
- ewarn "configuration options in the /opt/dmd/bin/dmd "
- ewarn "shell script. "
- ewarn " "
- ewarn "You may need to run: "
- ewarn " "
- ewarn "env-update && source /etc/profile "
- ewarn " "
- ewarn "to be able to use the compiler immediately. "
- ewarn " "
-}
diff --git a/dev-lang/dmd-bin/dmd-bin-2.008-r1.ebuild b/dev-lang/dmd-bin/dmd-bin-2.008-r1.ebuild
deleted file mode 100644
index cbe2bdb2ee5f..000000000000
--- a/dev-lang/dmd-bin/dmd-bin-2.008-r1.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils
-
-MY_P=${P/-bin/}
-MY_P=${MY_P/-/.}
-
-DESCRIPTION="Digital Mars D Compiler"
-HOMEPAGE="http://www.digitalmars.com/d/"
-SRC_URI="http://ftp.digitalmars.com/${MY_P}.zip"
-
-LICENSE="DMD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="mirror strip"
-
-LOC="/opt/dmd"
-S="${WORKDIR}"
-
-DEPEND="sys-apps/findutils
- app-arch/unzip"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
-
- # Cleanup line endings
- cd "${S}/dmd"
- edos2unix `find . -name '*.c' -type f`
- edos2unix `find . -name '*.d' -type f`
- edos2unix `find . -name '*.ddoc' -type f`
- edos2unix `find . -name '*.h' -type f`
- edos2unix `find . -name '*.mak' -type f`
- edos2unix `find . -name '*.txt' -type f`
- edos2unix `find samples -name '*.html' -type f`
- edos2unix src/phobos/linux.mak src/phobos/internal/gc/linux.mak
-
- # Fix permissions and clean up
- fperms guo=r `find . -type f`
- fperms guo=rx `find . -type d`
- fperms guo=rx bin/dmd bin/dumpobj bin/obj2asm bin/rdmd
-}
-
-src_compile() {
- # Don't use teh bundled library since on gentoo we do teh compile
- cd "${S}/dmd/src/phobos"
- sed -i -e "s:DMD=.*:DMD=${S}/dmd/bin/dmd:" linux.mak internal/gc/linux.mak
- # Can't use emake, customized build system
- make -f linux.mak
- cp obj/release/libphobos2.a "${S}/dmd/lib"
-
- # Clean up
- make -f linux.mak clean
-}
-
-src_install() {
- cd "${S}/dmd"
-
- # Setup dmd.conf
- cat <<END > "bin/dmd.conf"
-[Environment]
-DFLAGS=-I/opt/dmd/src/phobos -L-L/opt/dmd/lib
-END
- insinto /etc
- doins bin/dmd.conf
-
- # Man pages
- doman man/man1/dmd.1
- doman man/man1/dumpobj.1
- doman man/man1/obj2asm.1
-
- # Documentation
- dohtml "html/d/*" "html/d/phobos/*"
-
- # Install
- exeinto /opt/dmd/bin
- doexe bin/dmd
- doexe bin/dumpobj
- doexe bin/obj2asm
- doexe bin/rdmd
-
- insinto /opt/dmd/lib
- doins lib/libphobos2.a
-
- insinto /opt/dmd/samples
- doins "samples/d/*"
-
- # Phobos and DMD source
- mv src "${D}/opt/dmd/"
-
- # Set PATH
- doenvd "${FILESDIR}/25dmd"
-}
-
-pkg_postinst () {
- ewarn "You may need to run: "
- ewarn "env-update && source /etc/profile "
- ewarn "to be able to use the compiler immediately. "
- einfo " "
- einfo "The bundled samples and sources may be found in "
- einfo "/opt/dmd/samples and /opt/dmd/src respectively. "
- einfo " "
-}
diff --git a/dev-lang/dmd-bin/files/25dmd b/dev-lang/dmd-bin/files/25dmd
deleted file mode 100644
index ab7699d90d75..000000000000
--- a/dev-lang/dmd-bin/files/25dmd
+++ /dev/null
@@ -1,2 +0,0 @@
-PATH=/opt/dmd/bin
-ROOTPATH=/opt/dmd/bin
diff --git a/dev-lang/dmd-bin/metadata.xml b/dev-lang/dmd-bin/metadata.xml
deleted file mode 100644
index 0440d04c60f0..000000000000
--- a/dev-lang/dmd-bin/metadata.xml
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-<longdescription>
- This package provides a binary version of
- the D language compiler from Digital Mars
-</longdescription>
-</pkgmetadata>