summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-09-27 07:21:31 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-09-27 07:21:31 +0000
commit83d9a4327343bdbf8a9a456a59d320595373546d (patch)
treee0c7d33f47ffe748025d7c09df301835bd78f572
parent2021-09-27 07:06:42 UTC (diff)
parentdev-python/aesara: Add missing multiprocessing inherit (diff)
downloadgentoo-83d9a4327343bdbf8a9a456a59d320595373546d.tar.gz
gentoo-83d9a4327343bdbf8a9a456a59d320595373546d.tar.bz2
gentoo-83d9a4327343bdbf8a9a456a59d320595373546d.zip
Merge updates from master
-rw-r--r--dev-python/aesara/Manifest1
-rw-r--r--dev-python/aesara/aesara-2.1.3.ebuild70
-rw-r--r--dev-python/aesara/aesara-2.2.1.ebuild2
-rw-r--r--dev-python/aesara/aesara-2.2.2.ebuild2
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.14.1.ebuild51
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.18.0.ebuild51
-rw-r--r--dev-util/catfish/Manifest1
-rw-r--r--dev-util/catfish/catfish-4.16.0.ebuild51
9 files changed, 2 insertions, 229 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index 222f2b542e60..52d060705d36 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -1,3 +1,2 @@
-DIST aesara-rel-2.1.3.tar.gz 8170822 BLAKE2B dbbc4a453c5d7f9cd4ab2c925dd9293e835db23100686a8d7ab2c47182b1bc05f883eeb60d6f47f8f34e4187f3ac07b632cde43fe82a99e2145a2f699a2b3582 SHA512 52d1724eb7b3c9bae4bdbf1735db9ef96cdfa94f3e2281b255201d0baba260fe31f78c00719a53ce3c59ea9c66ff218d8acd7bc012b386942f29806c07ffc466
DIST aesara-rel-2.2.1.tar.gz 8166022 BLAKE2B af3c17029dacb3d365bf49eb01d4d03b5a4f770f66d3e5eba2c4576ef156056bc1aca3571442c1cb7352c358978b47faa7af70ca0da2a2168d8c9bfd47b17138 SHA512 f7bab8ca80e8d13ef7698c1efa56ff37c561786330bf756c7a00c54ae1f131810d68bfd6e328b0705d45788759bd984d42306d2c545d2de6b9a3592b5c021ad8
DIST aesara-rel-2.2.2.tar.gz 8174668 BLAKE2B c95347e8b74f6600c3570177f86b7ebd7511899ed0ceb24a2d79a03a44ee498a8062b92fb79867f59b609f66315704ee92e28e12a5ab600d54d0d35ef799b66b SHA512 d5f62e42c36100b2fd25eba492590eb306b1394aa01bf2e90d43e84ac67701e5b756be6bc08d0e6b82fb1f37689dbbba1d7ef67c8525555a700a634d742056bb
diff --git a/dev-python/aesara/aesara-2.1.3.ebuild b/dev-python/aesara/aesara-2.1.3.ebuild
deleted file mode 100644
index 99157397bfef..000000000000
--- a/dev-python/aesara/aesara-2.1.3.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 optfeature
-
-MY_P=aesara-rel-${PV}
-DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
-HOMEPAGE="https://github.com/aesara-devs/aesara"
-SRC_URI="https://github.com/aesara-devs/aesara/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- dev-python/filelock[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.17.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx doc 'dev-python/sphinx_rtd_theme'
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -i -e "s/tests.\*/tests\*/" setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local exclude=(
- # speed tests are unreliable
- tests/scan/test_basic.py::test_speed
- tests/scan/test_basic.py::test_speed_rnn
- tests/scan/test_basic.py::test_speed_batchrnn
- tests/link/test_vm.py::test_speed
- tests/link/test_vm.py::test_speed_lazy
- tests/tensor/test_gc.py::test_merge_opt_runtime
-
- # rounding problem?
- # https://github.com/aesara-devs/aesara/issues/477
- tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
- tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
- )
-
- distutils_install_for_testing
- # we do not package numba
- epytest ${exclude[@]/#/--deselect } \
- --ignore tests/link/test_numba.py \
- -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
-}
-
-# https://dev.gentoo.org/~mgorny/python-guide/concept.html#packaging-pkgutil-style-namespaces-in-gentoo
-python_install() {
- rm "${BUILD_DIR}"/lib/bin/__init__.py || die
- distutils-r1_python_install
-}
-
-pkg_postinst() {
- optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
- optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
-}
diff --git a/dev-python/aesara/aesara-2.2.1.ebuild b/dev-python/aesara/aesara-2.2.1.ebuild
index b037f472b6ac..3618da94f435 100644
--- a/dev-python/aesara/aesara-2.2.1.ebuild
+++ b/dev-python/aesara/aesara-2.2.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 optfeature
+inherit distutils-r1 multiprocessing optfeature
MY_P=aesara-rel-${PV}
DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
diff --git a/dev-python/aesara/aesara-2.2.2.ebuild b/dev-python/aesara/aesara-2.2.2.ebuild
index 3148f85f3cf9..86721797fe0f 100644
--- a/dev-python/aesara/aesara-2.2.2.ebuild
+++ b/dev-python/aesara/aesara-2.2.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 optfeature
+inherit distutils-r1 multiprocessing optfeature
MY_P=aesara-rel-${PV}
DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 9cbdaff79d89..a10babbe4505 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,5 +1,3 @@
-DIST google-api-python-client-2.14.1.tar.gz 25415625 BLAKE2B 2b843a6ec6345e51c5a92c0285c2b8ae195928bec61b73033fbc64d8e55c34ae39d8d542534d89edac36d6ddc6c12b6acf11a25dbcbc06f72776799a70606659 SHA512 e22600b9b87d646775780d0f45043753e4dea24e898faf16ae49f2c91677282700b45de993d085923c006f2948747a6afa2e58b38f42f934f1602401faa30d22
-DIST google-api-python-client-2.18.0.tar.gz 26442309 BLAKE2B 84f0cadeed015e9e0cafa209f6256b6262822f7161728aa5eba88f0def718b11c555bd0d87867c1e1ebb02e93046cec068e4ac0f855c55b7abf34a8d51d42fdc SHA512 19b06a252c440d5bb8454fc79487f4009ff73a7bd4882b2d33a354d4c4f287a6ea09f30cff94df4c1d1e898ca237d8e118a7fd5e63022133338d944dcec1243c
DIST google-api-python-client-2.19.1.tar.gz 26659303 BLAKE2B b1b5064c39b7e0d31e7ee01a7556a9ea6feaac1782d6714e50a32f0dfafedcab59628a1ff32774c426136d7ab796a1a6baf1f9ce7fbd1d233149c3a62648f280 SHA512 85272cd0741caed6ff76b930a69a67f1683886df82681b49f3069243dd40ef3f12febc7c1004ecf230d96bae005a8725d502032a9c85eb1bf9e4ee37af7018b9
DIST google-api-python-client-2.20.0.tar.gz 26723285 BLAKE2B 3c0cb64ea8c58fe20356cd097676bc7741ea454e61d9dc8807689fe2296c3ddd0da1cb208a639e8b47a981437dea39de9a7c26b669c7dc27a79a0c5ca4a6c463 SHA512 bed0b1a0e0c5384c80e337339e9c5526e0cd5b2d39a3bd69fec1c65a3fed5bf26e6f4f983daed7663d2cd6c47b8a2a7ad54395f8e5dada2b49c15d98a9ff04dd
DIST google-api-python-client-2.21.0.tar.gz 26754841 BLAKE2B e09b48d80d72e56656b366bd60972cde91d0c705ffe94b61d168e808e575a42f1dbbefdaf21ead1e57bab54a1b2453ba39ed5ae1d2ee616a5ba1418acc9f7534 SHA512 c572e5eab313e01ae94b026e32cf40fb479154942168cc09f2b74f184383ff5fc27cc5c0ae48c34d8ddbd8abe8840520a62a43708bd601341d5b32460f5f07df
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.14.1.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.14.1.ebuild
deleted file mode 100644
index a03212659345..000000000000
--- a/dev-python/google-api-python-client/google-api-python-client-2.14.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="Google API Client for Python"
-HOMEPAGE="https://github.com/googleapis/google-api-python-client"
-SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
- <dev-python/httplib2-1[${PYTHON_USEDEP}]
- dev-python/google-api-core[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.16.0[${PYTHON_USEDEP}]
- >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
- >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
- <dev-python/uritemplate-4[${PYTHON_USEDEP}]
- "
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/oauth2client[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests --install pytest
-
-src_prepare() {
- find tests -name '*.py' -exec \
- sed -i -e 's:unittest2 as ::' {} + || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local deselect=(
- # require Internet access (and credentials)
- tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
- tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
- )
-
- distutils_install_for_testing
- epytest tests ${deselect[@]/#/--deselect }
-}
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.18.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.18.0.ebuild
deleted file mode 100644
index 2bf8009bdc63..000000000000
--- a/dev-python/google-api-python-client/google-api-python-client-2.18.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="Google API Client for Python"
-HOMEPAGE="https://github.com/googleapis/google-api-python-client"
-SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-RDEPEND="
- >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
- <dev-python/httplib2-1[${PYTHON_USEDEP}]
- dev-python/google-api-core[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
- >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
- >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
- <dev-python/uritemplate-4[${PYTHON_USEDEP}]
- "
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/oauth2client[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests --install pytest
-
-src_prepare() {
- find tests -name '*.py' -exec \
- sed -i -e 's:unittest2 as ::' {} + || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local deselect=(
- # require Internet access (and credentials)
- tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
- tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
- )
-
- distutils_install_for_testing
- epytest tests ${deselect[@]/#/--deselect }
-}
diff --git a/dev-util/catfish/Manifest b/dev-util/catfish/Manifest
index 136a163b6abb..e4e8f8a2f79e 100644
--- a/dev-util/catfish/Manifest
+++ b/dev-util/catfish/Manifest
@@ -1,3 +1,2 @@
-DIST catfish-4.16.0.tar.bz2 261252 BLAKE2B b495814857cb551c00dff8b92d2b24df876b1ab269bcb0ba468c791b97f3e962b875c5a687010472c5d47719475c99131d5ee6df3ce642af147b199976eb3538 SHA512 926318d3b2387386a5141347cf23b7e1505f83c48dac3804dc9c51aeeede2ef71d6d70e61bd5f608145249ccb4d3d87662bdab0c0a88dc69608b2edee55ddc19
DIST catfish-4.16.2.tar.bz2 270051 BLAKE2B 41048edc3933664af389ae7120e6f2b25f6c92632a4d00b999eef4e26e0f6eeeed70320ed740f26a0649e423e3b8316e33b8c671a282ae1a4474b3cc6bbc4824 SHA512 a1dc2839106d55e11e537478402b44d3794cdcf326c5984bd95d0d5a8bad52d91df1be22ba347d23f030d0c62fdf2b90a507e2abc30ed4b4d1804ab8dbde1dbe
DIST catfish-4.16.3.tar.bz2 271642 BLAKE2B cebadeeb478a041ba6f815aec81b18d317ebf468bfe0699e33c4550a2f4b1b3377cbabd08d7d6504c3d94169b2be68d35ade9bd77e018ea7c099370ccf4ac124 SHA512 23ffa160b0593033a9696644fd00c48e4a6f54dc25448f975f0949aece50d8e4fbb45b9ad086a8e14072ac1dab27e0b4ecd19af0f31a5b4a775b17e18b00c7bb
diff --git a/dev-util/catfish/catfish-4.16.0.ebuild b/dev-util/catfish/catfish-4.16.0.ebuild
deleted file mode 100644
index 5d3b27cfd10d..000000000000
--- a/dev-util/catfish/catfish-4.16.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1 xdg-utils
-
-DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
-HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
-SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
-
-# yep, GPL-2 only
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-
-RDEPEND="
- >=dev-libs/glib-2.42
- dev-libs/gobject-introspection
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/gdk-pixbuf[introspection]
- >=x11-libs/gtk+-3.22:3[introspection]
- x11-libs/pango[introspection]
- >=xfce-base/xfconf-4.14[introspection]
- virtual/freedesktop-icon-theme
-"
-BDEPEND="
- dev-python/python-distutils-extra[${PYTHON_USEDEP}]
- sys-devel/gettext
-"
-
-python_install() {
- distutils-r1_python_install
- python_optimize
- rm -r "${ED}"/usr/share/doc/catfish || die
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}