summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeather Cynede <cynede@gentoo.org>2015-08-14 14:32:37 +0400
committerHeather Cynede <cynede@gentoo.org>2015-08-14 14:33:11 +0400
commit84f1c3c1c9197598271b7d96eedda7d606a0b26a (patch)
tree4d70fa897fd55a7b4672a52ce7a109aff42373fd
parentnet-proxy/bfilter: correct dependency for dev-libs/ace in stable ebuild (diff)
downloadgentoo-84f1c3c1c9197598271b7d96eedda7d606a0b26a.tar.gz
gentoo-84f1c3c1c9197598271b7d96eedda7d606a0b26a.tar.bz2
gentoo-84f1c3c1c9197598271b7d96eedda7d606a0b26a.zip
dev-dotnet/xdt-for-monodevelop add missing 2.8.1
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-dotnet/xdt-for-monodevelop/Manifest1
-rw-r--r--dev-dotnet/xdt-for-monodevelop/xdt-for-monodevelop-2.8.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-dotnet/xdt-for-monodevelop/Manifest b/dev-dotnet/xdt-for-monodevelop/Manifest
index cc4ad97146fd..45116f30d5ef 100644
--- a/dev-dotnet/xdt-for-monodevelop/Manifest
+++ b/dev-dotnet/xdt-for-monodevelop/Manifest
@@ -1 +1,2 @@
+DIST xdt-for-monodevelop-2.8.1.tar.gz 50980 SHA256 d4e87e92eb5e38ea46c9d1a8df54b99f52b628f8283e5b819cd0a354db61df61 SHA512 67732aea4fd65e01c32e83a14c8a5b08e9173779cfdabd03bc43d373074b3b4d80c682c04e3ef35bdfd56bedc33f8f4e6ba6980565bccb711001f87a3e675210 WHIRLPOOL 6b53cb25f9e1b8db93e1d2bed9879eb406e8470ff4999ac4438e472ee201b975ae819e8d9ec12fe1d4ae29a746feaf1ab8a49bf10bf2256af6dd77dfd9ff252e
DIST xdt-for-monodevelop-2.8.3.tar.gz 50974 SHA256 fb1a92dd745ca564d7179113bef6ca4e719d75583b33ca2bc65b74ce89c5d3c4 SHA512 3770b1ad8aab9c85e0b93bbf42415130b83eccf766fee5a2d08fe276af01cbf31ff4ab4cac661df982587e5b83b8efc8cd733a79bc387d666526aeb146f79f02 WHIRLPOOL 75fcc1b9054de7c8f6ed0e99ea3cb40e1d60fbaa4a077c86ed018ed462ceb2194111133e6a66a46e503eb5cd6230e3d1c96d97ed0c2572e0571c872b501eb099
diff --git a/dev-dotnet/xdt-for-monodevelop/xdt-for-monodevelop-2.8.1.ebuild b/dev-dotnet/xdt-for-monodevelop/xdt-for-monodevelop-2.8.1.ebuild
new file mode 100644
index 000000000000..811cade9e5bf
--- /dev/null
+++ b/dev-dotnet/xdt-for-monodevelop/xdt-for-monodevelop-2.8.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit dotnet eutils
+
+DESCRIPTION="Microsoft's Xml Document Transformation library"
+HOMEPAGE="https://github.com/mrward/xdt"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+SRC_URI="https://github.com/mrward/xdt/archive/Release-NuGet-${PV}-Mono.tar.gz -> xdt-for-monodevelop-${PV}.tar.gz"
+S=${WORKDIR}/xdt-Release-NuGet-${PV}-Mono
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="|| ( dev-lang/mono )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ dotnet_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/disable-testproject-build-in-sln.patch"
+ cp "${FILESDIR}/rsa-4096.snk" "${S}/XmlTransform" || die
+ epatch "${FILESDIR}/add-keyfile-option-to-csproj.patch"
+ sed -i -e "s/1.0.0/${PV}/g" "${S}/XmlTransform/Properties/AssemblyInfo.cs" || die
+}
+
+src_configure() {
+ export EnableNuGetPackageRestore="true"
+}
+
+src_compile() {
+ exbuild Microsoft.Web.XmlTransform.sln
+}
+
+src_install() {
+ elog "Installing Microsoft.Web.XmlTransform.dll to GAC"
+ egacinstall XmlTransform/bin/Release/Microsoft.Web.XmlTransform.dll
+}