summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukáš Poláček <lukas@ksp.sk>2017-10-19 21:30:12 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-11-15 23:15:31 +0100
commit8718b11b0e6ab3685973b4d5aa4ec8b2be788a3f (patch)
tree04a8c57927c469ef2908f72dfcb3902b0d13e5b1
parentnet-misc/seafile-client: version bump to 6.1.3. (diff)
downloadgentoo-8718b11b0e6ab3685973b4d5aa4ec8b2be788a3f.tar.gz
gentoo-8718b11b0e6ab3685973b4d5aa4ec8b2be788a3f.tar.bz2
gentoo-8718b11b0e6ab3685973b4d5aa4ec8b2be788a3f.zip
app-shells/autojump: version bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://bugs.gentoo.org/636528 Closes: https://github.com/gentoo/gentoo/pull/5988
-rw-r--r--app-shells/autojump/Manifest1
-rw-r--r--app-shells/autojump/autojump-22.5.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-shells/autojump/Manifest b/app-shells/autojump/Manifest
index 72ef1de455c2..2635ca58770e 100644
--- a/app-shells/autojump/Manifest
+++ b/app-shells/autojump/Manifest
@@ -1 +1,2 @@
DIST autojump-22.2.4.tar.gz 52724 SHA256 816badb0721f735e2b86bdfa8b333112f3867343c7c2263c569f75b4ec91f475 SHA512 bdfca07bb57b3a2733a2085af14f23c3e980b1b00db1c90247c2341ac73f60f171bdde29dd9917aac0808d0b8f2902d48096c990e09281745a71755f5abc921c WHIRLPOOL 29fe48cc2d8eee809a79c3d9b923d16be32a1591dc3bfa911bda26eceeb4fe0c05a49e1218958f63eb4b609837b2dc4b0ba4d4b23070c7fea0cad3d833e0fa39
+DIST autojump-22.5.1.tar.gz 54721 SHA256 765fabda130eb4df70d1c1e5bc172e1d18f8ec22c6b89ff98f1674335292e99f SHA512 ed1bb28b62d14a481d5c8ee8ebbfc286d21ca54c961904f81ac123c784e17810217dfe1689bdd4b50fd7a9d72509c0cb13583a9817074f6afe26dc3144f64243 WHIRLPOOL d0d6d36e8cb471bfa69312a591d53a3996866eec8134fbcc8ee0ce7259518a8f4e1c982afe88572a2edebd6b7994a39ab073684ef97298f0762fc6db75843654
diff --git a/app-shells/autojump/autojump-22.5.1.ebuild b/app-shells/autojump/autojump-22.5.1.ebuild
new file mode 100644
index 000000000000..6c2501ca72ba
--- /dev/null
+++ b/app-shells/autojump/autojump-22.5.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit bash-completion-r1 python-r1 vcs-snapshot
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="https://github.com/wting/autojump"
+SRC_URI="https://github.com/wting/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="ipython test"
+REQUIRED_USE="ipython? ( ${PYTHON_REQUIRED_USE} )"
+
+# Not all tests pass. Need investigation.
+RESTRICT="test"
+RDEPEND="ipython? ( ${PYTHON_DEPS} )"
+DEPEND="test? ( dev-python/flake8 dev-python/tox )"
+
+src_prepare() {
+ eapply_user
+ sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
+ -e "s:/usr/local/share:/usr/share:" \
+ -i bin/autojump.sh || die
+
+ # autojump_argparse is only there for Python 2.6 compatibility
+ sed -e "s:autojump_argparse:argparse:" \
+ -i bin/autojump || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin bin/"${PN}"
+ python_replicate_script "${ED}"/usr/bin/"${PN}"
+
+ insinto /etc/profile.d
+ doins bin/"${PN}".sh
+
+ insinto /usr/share/"${PN}"/
+ doins bin/"${PN}.bash"
+ doins bin/"${PN}.zsh"
+ doins bin/"${PN}.fish"
+ insinto /usr/share/zsh/site-functions
+ doins bin/_j
+
+ python_foreach_impl python_domodule bin/autojump_argparse.py bin/autojump_data.py \
+ bin/autojump_match.py bin/autojump_utils.py
+ if use ipython; then
+ python_foreach_impl python_domodule tools/autojump_ipython.py
+ fi
+
+ doman docs/"${PN}.1"
+ einstalldocs
+}
+
+pkg_postinst() {
+ if use ipython; then
+ elog 'This tool provides "j" for ipython, please add'
+ elog '"import autojump_ipython" to your ipy_user_conf.py.'
+ elog
+ fi
+
+ elog 'If you use app-shells/fish, add the following code to your'
+ elog 'config.fish to get autojump support:'
+ elog 'if test -f /usr/share/autojump/autojump.fish'
+ elog ' source /usr/share/autojump/autojump.fish'
+ elog 'end'
+}