summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-05 14:02:30 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-05 14:02:43 +0200
commit87dc5b7dd6501c80df10b9eaa23c7fdd6c3bd964 (patch)
tree197d3b46b79baa8eb4d3fbdf780f091a7f94d006
parentnet-misc/modemmanager: bump to 1.10.0 (diff)
downloadgentoo-87dc5b7dd6501c80df10b9eaa23c7fdd6c3bd964.tar.gz
gentoo-87dc5b7dd6501c80df10b9eaa23c7fdd6c3bd964.tar.bz2
gentoo-87dc5b7dd6501c80df10b9eaa23c7fdd6c3bd964.zip
net-misc/wget: Security bump to version 1.20.3
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-misc/wget/Manifest1
-rw-r--r--net-misc/wget/wget-1.20.3.ebuild118
2 files changed, 119 insertions, 0 deletions
diff --git a/net-misc/wget/Manifest b/net-misc/wget/Manifest
index 97b3c5a40655..79d60d0897b3 100644
--- a/net-misc/wget/Manifest
+++ b/net-misc/wget/Manifest
@@ -1,2 +1,3 @@
DIST wget-1.20.1.tar.gz 4392853 BLAKE2B 5740fa70064e24a699ba5fc0b6262b372fc877e86fc74bede07bcfe7dcdf6d4a15db7686fc900d8ec90ad3adce8c4af1c00460601c1845da7907f929d8d48447 SHA512 855c7e3c45f9020a9fdb30e286ee6a0bdcaa780be3d0dda9ffdae73b562ae1012d4550242f66240407a28076a7054328d4f08a469a0da227a9e3410b8d5f46dc
DIST wget-1.20.2.tar.gz 4486237 BLAKE2B 7392e445cb801ac5fafee804e6b0459d0a001b91b5b413f1a5592da6bea690a2d6b864b64a1add1c4114085def7a73312a88cd1cf1c12434c6535f79de222d9a SHA512 42d59ddb3abec6ff30e2be890ceeec35fc144acd8e2def25f5280c2f8c21e6fd54dc71217e9ca7fb1d4f0470716bf288e90501e8e6e39b09938e3f5710a3016a
+DIST wget-1.20.3.tar.gz 4489249 BLAKE2B 89fa7997a02be6fb1a869d1bf359ce4e43b41f8069d1520e6d0b48739b9b6030b1dec7b7e8cbe833ea1070b30f551b1a9d72c6f4a43bb58df20b680b42a68805 SHA512 e8b82b40e270296228094a78d47f81580bdbdea9e6b93fd61b37dccb39430aeb9bda5397dc53a31c952a61629383c7e2a8c8abf414c8a4dd369af6ecf2717e6c
diff --git a/net-misc/wget/wget-1.20.3.ebuild b/net-misc/wget/wget-1.20.3.ebuild
new file mode 100644
index 000000000000..b9c1aa3290a5
--- /dev/null
+++ b/net-misc/wget/wget-1.20.3.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="https://www.gnu.org/software/wget/"
+SRC_URI="mirror://gnu/wget/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug gnutls idn ipv6 libressl nls ntlm pcre +ssl static test uuid zlib"
+REQUIRED_USE=" ntlm? ( !gnutls ssl ) gnutls? ( ssl )"
+
+# Force a newer libidn2 to avoid libunistring deps. #612498
+LIB_DEPEND="
+ idn? ( >=net-dns/libidn2-0.14:=[static-libs(+)] )
+ pcre? ( dev-libs/libpcre2[static-libs(+)] )
+ ssl? (
+ gnutls? ( net-libs/gnutls:0=[static-libs(+)] )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0=[static-libs(+)] )
+ libressl? ( dev-libs/libressl:0=[static-libs(+)] )
+ )
+ )
+ uuid? ( sys-apps/util-linux[static-libs(+)] )
+ zlib? ( sys-libs/zlib[static-libs(+)] )
+"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ static? ( ${LIB_DEPEND} )
+ test? (
+ ${PYTHON_DEPS}
+ dev-lang/perl
+ dev-perl/HTTP-Daemon
+ dev-perl/HTTP-Message
+ dev-perl/IO-Socket-SSL
+ )
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # revert some hack that breaks linking, bug #585924
+ if [[ ${CHOST} == *-darwin* ]] \
+ || [[ ${CHOST} == *-solaris* ]] \
+ || [[ ${CHOST} == *-uclibc* ]] \
+ || [[ ${CHOST} == *-cygwin* ]] \
+ ; then
+ sed -i \
+ -e 's/^ LIBICONV=$/:/' \
+ configure || die
+ fi
+}
+
+src_configure() {
+ # fix compilation on Solaris, we need filio.h for FIONBIO as used in
+ # the included gnutls -- force ioctl.h to include this header
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DBSD_COMP=1
+
+ if use static ; then
+ append-ldflags -static
+ tc-export PKG_CONFIG
+ PKG_CONFIG+=" --static"
+ fi
+
+ # There is no flag that controls this. libunistring-prefix only
+ # controls the search path (which is why we turn it off below).
+ # Further, libunistring is only needed w/older libidn2 installs,
+ # and since we force the latest, we can force off libunistring. #612498
+ local myeconfargs=(
+ --disable-assert
+ --disable-pcre
+ --disable-rpath
+ --without-included-libunistring
+ --without-libunistring-prefix
+ $(use_enable debug)
+ $(use_enable idn iri)
+ $(use_enable ipv6)
+ $(use_enable nls)
+ $(use_enable ntlm)
+ $(use_enable pcre pcre2)
+ $(use_enable ssl digest)
+ $(use_enable ssl opie)
+ $(use_with idn libidn)
+ $(use_with ssl ssl $(usex gnutls gnutls openssl))
+ $(use_with uuid libuuid)
+ $(use_with zlib)
+ )
+ ac_cv_libunistring=no \
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ sed -i \
+ -e "s:/usr/local/etc:${EPREFIX}/etc:g" \
+ "${ED%/}"/etc/wgetrc \
+ "${ED%/}"/usr/share/man/man1/wget.1 \
+ "${ED%/}"/usr/share/info/wget.info \
+ || die
+}