summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-11-03 09:48:20 -0500
committerMike Frysinger <vapier@gentoo.org>2015-11-03 10:08:05 -0500
commit87ec7f7f26cabc142eb8460a4d3287940fea9fa3 (patch)
treec28b0edf1d9912e9e0674f3a0c05fc4a679c7829
parentnet-nds/rpcbind: minor style fix (diff)
downloadgentoo-87ec7f7f26cabc142eb8460a4d3287940fea9fa3.tar.gz
gentoo-87ec7f7f26cabc142eb8460a4d3287940fea9fa3.tar.bz2
gentoo-87ec7f7f26cabc142eb8460a4d3287940fea9fa3.zip
net-nds/rpcbind: add upstream fix for building w/newer libtirpc
-rw-r--r--net-nds/rpcbind/files/rpcbind-0.2.3-libtirpc.patch42
-rw-r--r--net-nds/rpcbind/rpcbind-0.2.3.ebuild1
2 files changed, 43 insertions, 0 deletions
diff --git a/net-nds/rpcbind/files/rpcbind-0.2.3-libtirpc.patch b/net-nds/rpcbind/files/rpcbind-0.2.3-libtirpc.patch
new file mode 100644
index 000000000000..92ea22f0e4ce
--- /dev/null
+++ b/net-nds/rpcbind/files/rpcbind-0.2.3-libtirpc.patch
@@ -0,0 +1,42 @@
+fix from upstream for building w/newer libtirpc
+
+From 9194122389f2a56b1cd1f935e64307e2e963c2da Mon Sep 17 00:00:00 2001
+From: Steve Dickson <steved@redhat.com>
+Date: Mon, 2 Nov 2015 17:05:18 -0500
+Subject: [PATCH rpcbind] handle_reply: Don't use the xp_auth pointer directly
+
+In the latest libtirpc version to access the xp_auth
+one must use the SVC_XP_AUTH macro. To be backwards
+compatible a couple ifdefs were added to use the
+macro when it exists.
+
+Signed-off-by: Steve Dickson <steved@redhat.com>
+---
+ src/rpcb_svc_com.c | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/src/rpcb_svc_com.c b/src/rpcb_svc_com.c
+index 4ae93f1..22d6c84 100644
+--- a/src/rpcb_svc_com.c
++++ b/src/rpcb_svc_com.c
+@@ -1295,10 +1295,17 @@ handle_reply(int fd, SVCXPRT *xprt)
+ a.rmt_localvers = fi->versnum;
+
+ xprt_set_caller(xprt, fi);
++#if defined(SVC_XP_AUTH)
++ SVC_XP_AUTH(xprt) = svc_auth_none;
++#else
+ xprt->xp_auth = &svc_auth_none;
++#endif
+ svc_sendreply(xprt, (xdrproc_t) xdr_rmtcall_result, (char *) &a);
++#if !defined(SVC_XP_AUTH)
+ SVCAUTH_DESTROY(xprt->xp_auth);
+ xprt->xp_auth = NULL;
++#endif
++
+ done:
+ if (buffer)
+ free(buffer);
+--
+2.5.2
+
diff --git a/net-nds/rpcbind/rpcbind-0.2.3.ebuild b/net-nds/rpcbind/rpcbind-0.2.3.ebuild
index 23a68efce49e..a2437fee0602 100644
--- a/net-nds/rpcbind/rpcbind-0.2.3.ebuild
+++ b/net-nds/rpcbind/rpcbind-0.2.3.ebuild
@@ -31,6 +31,7 @@ RDEPEND="${CDEPEND}
src_prepare() {
[[ ${PV} == "9999" ]] && eautoreconf
+ epatch "${FILESDIR}"/${P}-libtirpc.patch
epatch_user
}