summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-06-17 13:13:08 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-17 13:13:08 +0200
commit89bca67ee94dbb20449f5dbbfb8afc048c28a1d2 (patch)
tree06a014080ffc1b5fac627580f29a7ef946353a3c
parentapp-misc/eid-viewer-bin: Remove last-rited pkg (diff)
downloadgentoo-89bca67ee94dbb20449f5dbbfb8afc048c28a1d2.tar.gz
gentoo-89bca67ee94dbb20449f5dbbfb8afc048c28a1d2.tar.bz2
gentoo-89bca67ee94dbb20449f5dbbfb8afc048c28a1d2.zip
xfce-base/xfdesktop: Bump to 4.13.2 (with new Thunar support!)
-rw-r--r--profiles/package.mask1
-rw-r--r--xfce-base/xfdesktop/Manifest1
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.13.2.ebuild53
3 files changed, 55 insertions, 0 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index f7ea5cbb0e85..322ae9c99322 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -338,6 +338,7 @@ games-kids/crayon-physics
# Masked until the latter sees a new release.
>=dev-python/thunarx-python-0.4.0
>=xfce-base/thunar-1.7
+>=xfce-base/xfdesktop-4.13.2
>=xfce-extra/thunar-archive-plugin-0.4.0
>=xfce-extra/thunar-media-tags-plugin-0.3.0
>=xfce-extra/thunar-shares-plugin-0.3.0
diff --git a/xfce-base/xfdesktop/Manifest b/xfce-base/xfdesktop/Manifest
index 34b4bc761931..a8043544b0ac 100644
--- a/xfce-base/xfdesktop/Manifest
+++ b/xfce-base/xfdesktop/Manifest
@@ -1,2 +1,3 @@
DIST xfdesktop-4.12.4.tar.bz2 1421623 BLAKE2B a18b891d639165d617f2701106dedb2f8577273ece5a4c93f6b5e1ef26f801304ea2014f21bd2821eb9bac9b19e02dd75cd4054a116eefd544f4d8e5d6968879 SHA512 29f170b96836298dc83e3c49650ab7e88a93c1a2fa1599d1d98f3b6c80c9c059748b76a821077eea39b5b4619998bb300ff17f06e88483a59bd5ae2b76d0605e
DIST xfdesktop-4.13.1.tar.bz2 1485914 BLAKE2B 2b991b40317c9d92b53f357d674078598a7b17dd870155de8eb360fd9998d5376582909b57a93e00628a7dfd7e65bfea22b7f57b9373bab869296ef9b2973af5 SHA512 efe5ffe450f498ee0188a1ca5efd0ef340d73b5650060f18db4fe94ae9130dd27e41c6b30af2f90839e6c8272f3e270d16b86df64d595fe82169c26d624f806a
+DIST xfdesktop-4.13.2.tar.bz2 1486455 BLAKE2B 38ba5da7172212f74281f60688a581e525dcbb91ea381f8fcbdef57f90b54b9c21d08f20f3b1da5c91dcab158c2a7ba415822ec7b1f92f1cef80e53624a1f741 SHA512 0002ed639f8554144d8c921ca5bd9d1c2ed634baa11c98f95685c8a636ae6bdc87f8df19aa138fe4eda591facba964451a10aef6ba303be1fad66013bb06ae13
diff --git a/xfce-base/xfdesktop/xfdesktop-4.13.2.ebuild b/xfce-base/xfdesktop/xfdesktop-4.13.2.ebuild
new file mode 100644
index 000000000000..87c12c2ee90d
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.13.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify +thunar"
+
+RDEPEND=">=x11-libs/cairo-1.12:=
+ >=dev-libs/glib-2.42:=
+ >=x11-libs/gtk+-3.20:3=
+ >=x11-libs/libwnck-3.14:3=
+ x11-libs/libX11:=
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/garcon-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.13:=
+ >=xfce-base/xfconf-4.12.1:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ thunar? (
+ >=dev-libs/glib-2.38:=
+ >=xfce-base/thunar-1.7:=
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}